Bad display tearing even in text mode with Intel i15 + ATI card in 13.2

Just got this nice Toshiba L70 B150, a fast and nice machine for my purposes, which don’t include gaming, so the lack of fast 3D acceleration is not an issue. But I’ve got used to desktop effects, something the lowly built in i915 card can in theory perform, so I don’t even need the built-in Radeon 8850M mobile card. So there I went, to install OpenSUSE 13.2. And it mostly went very well.

However I can’t get KDE OpenGL desktop effects enabled unless I have also huge tearing issues, even in text mode (CTRL+ALT+F1) If I disable kms (nomodeset in Grub boot command line) I don’t get any tearing, neither in text mode or in X, but the more useful desktop effects (ALT+TAB window switching) are disabled and I want to have these. The tearing (and I don’t know if this helps, but it is surprising for me anyway) is much more visible with darkest colors than brigther ones: if you set the desktop background to solid white, only a tiny line of pixels tears at the top of the screen. If you set a solid black background, half of the screen is shifted horizontally at least a quarter of the screen width with a fast, but very noticeable frequency. I’ve not tried to change the background in text mode.

I’ve tried installing fglrx (wrong, the driver does not support 13.2), uninstalling radeon (wrong, it wants to remove the whole KDE environment), blacklisting radeon (no graphics mode at all), adding the “Tear Free” option to the Intel card in the X config options (no difference in tearing) and… I’m out of ideas. And time.

By the way, booting Windows 8 shows a rock solid display capable of very, very high framerates without any tearing at all, so the hardware is ok. I’ve always used nVidia products and hearing all the ATI horror stories I could not believe that setting up such apparently simple confiuguration would be such a nightmare. Any suggestions?

Before you ask, here’s my lspci output

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM86 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus PRO [Radeon HD 8850M / R9 M265X] (rev ff)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
08:00.0 Network controller: Intel Corporation Wireless 3160 (rev cb)
09:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)

and my X log

Additional info: the tearing only happens on the desktop background. That is, playing video full screen or maximizing a window eliminates the tearing. However, the tearing is still there in the background. If you cycle by the windows using ALT+TAB, the background is flickering and tearing even if the window thumbnails are displayed correctly.

I suppose you tried the advanced options on special effects settings, like Native x Raster, experimental vsync tearing(?) prevention, different OpenGL versions, etc?

Also it’s not clear if you got fglrx working?

Can you disable one of the video cards in BIOS and use the other?

AFAICS there are 13.2 drivers here:

More info in the links below, although you’ve probably seen then:

There’s a setting in effects > advanced to suspend effects when in full screen window mode, I suppose it’s set. If not it would probably be something to note in an eventual bug report.

I did, with no changes whasoever. Then I realized that the tearing happens even at boot time in text mode, so it looks like more of a driver issue, either intel i915 or radeon, than an issue with some X setting. But please correct
me if I’m wrong.

The tearing does not appear if I maximize a window full screen (konsole or Firefox, for example), even if the window has a black background. It affects only the desktop background and the text mode consoles (CTR+ALT

Bruno, thanks for all the pointers. I tried these drivers, with no changes. The latest ones provided in the Lizards site grab the latest updates from AMD, and those refuse to install saying that my card is not supported.

Can you disable one of the video cards in BIOS and use the other?

I checked in Toshiba update and the BIOS is up to its latest revision. Looked around in the BIOS settings and did not found a way to disable either card. I don’t need the extra 3D power of the AMD/Raden, as I don’t intend to play games with the machine.

There are no drivers loaded at boot. So it must be a different issue. Hybrid graphic systems are a pain. Could simply be bad hardware.

You’re wrong on the first sentence: with KMS (kernel mode setting) enabled by default, drivers do actually get loaded at boot. Disabling KMS (nomodeset) solves the tearing problem, but makes the i915 driver unable to provide acceleration and you’re booted to a framebuffer device with no 3D acceleration. You’re right on the second, this is a pain. And wrong again in the last one: the same hardware works flawlessly under Windows 8

Not any full driver KMS is not run at grub screen only after. At grub not even the kernel is loaded. But maybe you meant some where else??? Grub is the very first thing that runs upon booting the system. Is that screen showing tearing??

Ah, yes. I don’t consider grub to be part of booting. No, tearing does not appear in the grub screen. Tearing begins to happen during the kernel start sequence, but well before any graphics are shown. Booting with nosplash makes the tearing start during the initial boot messages just after selecting the entry in grub. Unfortunately, it boots so quickly that I’m unable to tell when exactly is starting because the text messages scroll very quicky, but I assume that it is either loading the radeon or i915 modules that trigger it.

Just finished recompiling a kernel without the radeon module and the problem persists. Clearly it’s not radeon’s driver fault, but something with the i915 driver.

I also tested with a couple of live distros: both Mint and OpenSUSEGnome live have the exact same problem, which indicates a problem with the driver in general and not some custom distro specific customization.

Yup. Confirmed. I cloned the latest drm-intel nightly (4.1.0-rc8-21-desktop-test+), compiled and installed it and the problem goes away, even with the radeon driver also loaded.

However, some other parts in that kernel (notably WiFi) being a release canidate nightly don’t work as they should. What are my options here? Is there a backport of the drm-intel changes that can be installed in 12.3? Ideally, I’d like to avoid recompiling kernels myself.

There will not be any back ports to 12.3 it is out of support since January. :open_mouth:

Ooops… Sloppy fingers. I’m using 13.2. I’ve created a bug report here

A short update: OpenSUSE has kindly asked questions and posted suggestions on my Bugzilla entry that seem to point that 13.2’s i915 driver does not work correctly on this machine. Definitely, the mode driver is messing up the display in mode changes. The last experiment I made was to boot with 13.2 stock kernel adding i915.fastboot=1 to the boot command line. And faster it booted, and also by skipping the mode change it avoided the tearing and flickering.

However, the X mouse cursor was solid black, no matter which theme I selected in KDE control centre. But then, forcing a mode change by switching to a text console with CTR+ALT+F1 made the tearing and flicker appear again, both in text and graphics mode. But this time the cursor appeared correctly.

Another update for those that may run into the same issue: following the suggestions in the bug I opened, I tried installing a 4.0 kernel-desktop from OBS. Rock solid black background, not a hint of fickering or tearing, with smooth desktop effects and, very important, not a shadow of lack of compatibility or problem with the rest of the system, from which I’m writing this.

Have to say that OpenSUSE support has performed well above my experience with most other open source projects in this case. Hats off to the team for a polished product that is well taken care of.