bad bumblebee conf?

Hi All,

I’ve been working through my problems with my Nvidia960M on my Asus (see thread below) and kind souls on an Nvidia board

They have suggested that I’ve a bad bumblbee conf

Can someone please have a look? I can’t see anything obvious that stands out from the Optimus recommended procedures…

You should probably start from the beginning - explain what you’re experiencing with your hybrid graphics, and any steps you’ve tried as part of the diagnostic process.

Sure, from my earlier opensuse post I started with:
I recently got a new laptop to replace my ancient Asus A7k. Its a lovely ASUS ROG GL752VW-DH71.

I’ve tried to install Leap 42.2 several times without much success. I understand that it is an optimus platform. Accordingly I’ve following the bumblee instructions. I’ve tried both btrfs and ext4 filesystems for both home and root partitions. Neither has changed the end result.

During my latest install attempt, I got to the point where the NVIDA drivers (easy way) were installing but encountered soft-locks (this has been typical of every attempt thus far…very annoying) that wouldn’t go away for the last two rpms. I rebooted, and wasn’t able to login with my stated user id, and default kernel (hung at text login). Zo I thought I’d resume using debug kernel. I finished installing the rest of the rpms, and finished the bumblebee config steps (Perhaps not the best idea, but it was late, I was frustrated, and had little sleep). Now for debug and regular kernel and regular safemode, I boot, get to text login. This looks alive long enough for me to type 4 characters (i.e. root) as login credentials, then it hangs.

The only way I can login to linux at this point is debug, safe mode. By some small miracle I get a graphical login and can get into plasma.

When I run optirun --status, it tells me that X is inactive and discrete video is likely on. optirun glxgears tells me that secondary GPU driver could not be loaded.

Any suggestions would be helpful (please tell me I don’t need to reinstall again!). I’ve also tried ‘intel_pstate=disable’ and ‘nomodeset’ or ‘nouveau.modprobe=0’ after doing research within the forums. Unfortunately this hasn’t moved me any further.

I know I should be including various diagnostics, but its been awhile since I had to build drivers so bear with me. Let me know what is needed so I don’t waste anyones time

Note that I used this instructionset:

After working with someone on the nvidia site he suggested that I might be suffering this problem:

This line seemed to fix things:
GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/disk/by-uuid/fd4f92b1-b6e9-4bee-972e-6dc8f92fa47a splash=silent quiet showopts acpi_osi=! acpi_osi=“Windows 2009"”
so at least now I can boot into default kernel.

Thats where I’m at.

This ASUS thread re Linux installation issues will be of interest to you…

Better Skylake support might be gained from using a later kernel. For this reason TW might be worth a shot, or a distro with latest stable kernel.

Thanks for this! I don’t think i had come across this yet. So I guess it sounds like tumbleweed or a bit of patience is required until solutions propagate through to main releases.

Thanks again.