Bacula 5.2.12 Slow restore on openSUSE 12.2

Some background first.

After upgrading my server to 12.2 from 11.4, 12.2 would not see the XFS file system on my large RAID (33TB). File system was created on 10.x in 2008. I was getting a “Can not read superblock” error on 12.2. I put the 11.4 system disk back in and created a backup of the RAID. The backup was around 15TB (19 Tapes) and took 1.5 days. Bacula Version for the backup was 5.0.3 from

When I got 12.2 up and Bacula upgraded from Index of /repositories/Archiving:/Backup/openSUSE_12.2 I rebuilt my RAID and started the Restore.

The restore died at the start of tape 16, six days after the start of the restore. I first tried to restore missing directories, then I was able to find out how to start a restore at tape 16, but at the end I was still missing 54K files out of 1.7M. These restores went fast, just a few hours for around 2TB. I have restarted the full restore and am seeing Bacula slow down again.

Started the restore yesterday at 13:43. I did not due a status after I started the restore yesterday, this morning status shows the restore running around 65M (Bytes/sec=65,681,414) a second. The restores I ran to recover the failed job ran around 114M a second (Bytes/sec=114,403,893). Also I have been using xosview to watch the system load on the server. I went from 220M Net and 110 Disk to 75M Net and non constant Disk. When the first job failed it was down to 35M Net traffic, it was around 220M when it started.

I am also using a Virtual Tape Library between my server and Physical Tape Library, so all backups and restores are disk to disk transfers.

Does anyone know why Bacula slows down on such a large restore and how I can fix it.


Dave W