Backup steps if NVIDIA driver install fails

I have attempted to install nvidia proprietary drivers multiple times without success. System is opensuse 15.2 (fully updated), multiple desktops but mate most often used. Dual boot with windows 10. 32 gig memory, plenty of disk space. Graphics card is: GeForce GTX 1050 Ti. Current video driver, per hwinfo, is default system nouveau driver. Mesa-dri-nouveau is not installed (it is tabooed).

I have chosen to use the “easy” way to swap to proprietary drivers. I have reviewed all the details, I have efi and secure boot on. I am aware of the mok key steps.

But, I have done this many times before unsucessfully and invariably I have to reinstall opensuse when I get a blank black screen and after opensuse reinstall I am back at the default system video drivers. This is a painful process that takes weeks to sort out everything. I have no idea why this change has not worked. But I am trying again for the benefit of some software.

I am asking for some diagnostic and/or repair troubleshooting steps to take when and if I get the blank black screen again so I can recover my system. Older SBD: NVIDIA files give a list of troubleshooting steps but they relate to older versions like 13.2. I am not sure these steps are relevant with Leap system. Current SBD: NVIDIA files have little on blank screen repair.

I would like either some updated blank screen repair doc references or a list of steps to try. I will research these before I make the swap.

Thanks, tom kosvic

Is this a note book??? If so it probably is an Optimus configuration. If so you need to follow aditiional steps to insta suse-prime or bumblebee

Hi, Tom: I thought quickly of Clonezilla while reading your message: https://clonezilla.org/. Clonezilla was finicky a few years ago with btrfs, but has flawlessly backed and restored ext4 partitions. I use a separate data drive, so restoring the whole openSUSE partition takes about twenty minutes.

This computer is a desktop. ASUS x99 mobo. I assembled myself and have successful use for nearly 3 years.

I am familiar with clonezilla. I will do a clonezilla clone. I dropped btrfs and went back to ext4 during one of my reinstalls because I thought that might be involved in the nvidia driver problems.

I am looking for boot/login procedures to get past blank screen to be tried prior to reinstall.

thanks for comments.

Hi
If it gets the blank screen, have you tried booting to multi-user.target (eg runlevel 3, edit grub linuxefi line and add a 3), have you ensured once the nouveau driver is blacklisted, rebuild initrd? Then boot to multi-user.target install the driver, switch to graphical.target (runlevel 5) and reboot… Likewise if installing the rpm drivers it matches your running kernel version?

Hi Tom,
Can you login with console mode? Ctrl +Alt F2/Ctrl +Alt F3?

If you can, you can try logging in console mode and try to start X with the command

startx

and the error code should help us troubleshoot it.

Malcolm,

I don’t understand your suggestions. what is multi.user.target?. How do I boot to runlevel3? Nouveau has been blacklisted for months. What/where is initrd that I need to rebuild? I am doing easy install with yast. Not installing from rpm files. Is there some detailed doc that lists the steps you are suggesting?

thanks, I work with numbers. weak in system admin.

tom

SJLPHI,

thanks, bailout steps are what I am looking for just in case. I will take your step if trouble arises.

tom

Hi
OK, so installing the rpms via YaST Software Management, you can do this via YaST in a console too, no need for a desktop running.

So runlevel 3, multi-user.target are both the same no graphical session running, just a console session (commandline login) the one to use when getting into this sort of situation when only see a black.

When you have the grub menu on the screen, you can press the ‘e’ key to edit the menu, using the arrow keys can arrow down to the text starting with linuxefi, something like;


linuxefi /vmlinuz-5.8.15-1-default root=...... quiet

Here you can press the ‘end’ key add a space and enter 3


linuxefi /vmlinuz-5.8.15-1-default root=...... quiet 3

This will start the system up with just the console login, rather than graphical login (called runlevel 5, or systemd speak graphical.target).

At this point you should be able to collect output as to why the system is not starting the graphical session, eg check the nvidia kmp versions and the kernel version to ensure they match, or check the output from modinfo to see it matches the running kernel.

For example (I’m on Tumbleweed);


modinfo nvidia | grep filename:
filename:       /lib/modules/5.10.1-1-default/kernel/drivers/video/nvidia.ko

uname -r
5.10.1-1-default

Just because you get a black screen, does not mean you have to backup/restore the system…

Are you using btrfs and snapper? If so could rollback to a working snapshot, or at grub select advanced and boot from the earlier kernel which should be working…

Malcolm, thanks for more detailed steps. I wish I had done this during my other blank screen/reinstall adventures.

I want to write all this up and print so I have a reference if my screen goes black.

I can also get back to opensuse forums with my tablet now so I should not be just hanging out there staring at a blank screen.

tom kosvic

Hi
No worries,. now as with any backup (well restore actually), go test, test and test :wink:

Go reboot the system and find out where to add the 3, try it out. The changes at grub are not permanent, so if something goes wrong, just reboot and it will be back to normal. Then can come back and ask why X happened :wink:

Refine your process and test again until your comfortable on what to do :slight_smile:

If you feel really ambitious,
People should recognize that the problems they encounter aren’t the first time it’s ever happened and although technical documentation might exist, might not be easily understood.

Feel free to create a Wiki page of your own describing your experience and what you did to find success for both your own reference and for anyone who is in the situation after you… The signature at the bottom of my posts describe first steps to setting up your own free page(s).

If you think that snapshots might be a good option for you to recover you system from experimentation, accidents and other problems, you have several options…

TSU

I went and loaded nvidia proprietary drivers. Appeared to go ok but did not get asked about mok file on reboot.
Problem is I am in 1024 x 768 per randr command output.

Need to get back to 1920 x 1080. I am in mate desktop.

Nvidia server settings is now available. run in terminal says: nvidia server not running

I need some further instructions.

tom kosvic

Correction to above: nvidia settings says nvidia server not loaded.

HWINFO says nvidia drivers in place not nouveau as before.

MATE resolution adjuster shows 1024 x 768 but unknown monitor.

I will reload display through yast

need help to get back to where I was.

thanks