Backtrace from graphic driver

Hi.

I received new laptop today, installed OpenSuSE Tumbleweed and X won’t start.

Laptop is:
HP 15-bs Intel Core i5 8GB 1TB Radeon 530-4G

This laptop have Intel and AMD graphic card.

I cannot attach backtrace, because picture is in bad quality. Maybe could you suggest some tool to making framebuffer screenshot?

Can you turn off the AMD in the UEFI/BIOS settings ?
Does a Tumbleweed Live image work ?
Desktop used ?
Do you see the login screen, or not even that?

I don’t ran LiveImage, but use installer in graphical mode.
I have installed Plasma5, but sddm login screen doesn’t display.

I cannot disable graphic card in Bios.

In this laptop Radeon R320 or R350 card is used. I don’t know, which graphic driver should I use. On AMD page is information that graphic card R4000 or below should use open source driver. It’s true? Should I install closed-source driver? I have read that open source drivers is best choice for two graphic adapter configuration.

Sorry. Radeon graphics adapter have number 530.

I have installed amdgpu_pro and still the same problem here.

Please do try a live image. The laptop btw has both Intel and AMD graphics, as per your first post. Try adding ‘nomodeset’ to the GRUB entry.

When I use nomodeset, no backtrace is preset and X tries to load framebuffer module. It doesn’t start complains that no matching configuration for screen 0 was present.

I have started kwin_wayland, xwayland and plasmashell on framebuffer! But I still would like to solve this problem.

I tries KDE-LiveCD-amd64 and everything worked fine, but normal installer also worked in graphical mode.
I remember, in previous version of OpenSuSE, installation was divided into two step, so installer reboots into next step of installation. In my case that’s don’t happens. Does OpenSuSE Tumbleweed installer still should reboot into next installation step?

I must write: I have ran full KDE session, using kwin_wayland with framebuffer switch, xwayland switch. I’m also using startkde (or kdestart). I play Hero Academy without problems and it works perfectly, but I don’t suppose I have graphics acceleration.

Because I can work on framebuffer, I will wait until you fix my problem, download installation media and reinstall system - you must have machine to make tests.

One question: It is possible everything will works out of the box on LiveCD installation?

Don’t know where you remember this from, but the only reboot the installer does is at the very end, when the install is done, to boot into the installed system. No reboots before that or between steps. What has happened in the past was that zypper / rpm stack was updated and available through the Update repo. That would trigger a reboot after the install of the updated zypper / rpm stack. But the installer itself only triggers a reboot when done.

I will put backtrace somewhere, but don’t known how. If I don’t upload backtrace, there’s no reason to wait until you fix problem.

Have a look at the logs, f.e. Xorg.0.log, journalctl

And, I’m not going to fix anything, don’t have the knowledge :smiley: .

I decided to play Civilization VI, so I installed system from live cd. I noticed installer downloads a lot of packages, especially libdrm_radeon, libdrm_amdgpu, libdrm_intel, etc.

After rebooting into installed system, the same backtrace is displayed and X doesn’t started. I blacklisted some modules. My /etc/modprobe.d/99-local.conf look like below:


#
# please add local extensions to this file
#

blacklist amdgpu
blacklist amdkfd
blacklist amd_iommu_v2


I reboot system and still the same problem. Modules are loaded, but I blacklisted it.

I don’t write this, but lspci hangs.

I have disabled AMD graphic by adding this to grub command line:
rd.driver.blacklist=amdgpu rd.driver.blacklist=amdkfd rd.driver.blacklist=amd_iommu_v2

Adding this code into /etc/modprobe.d/99-local doesn’t work:



blacklist amdgpu
blacklist amdkfd
blacklist amd_iommu_v2

So Instead working on framebuffer without acceleration, I works under X with intel acceleration only.

I discover I had acpi problems - maybe it’s a related bug.

Message saying:


AE_AML_NULL_RETURN_VALUE Missing or null operand ...
AE_AML_NULL_VALUE, error while creating Arg0

I have found this message on Linux Kernel Mailing List: https://lkml.org/lkml/2018/7/27/1063 . My laptop displaying the same errors here. Is it related to AMD graphic driver? Is there possibility to use two graphic card (optimus?) in future?