Backintime stopped working on Leap 15.3 - only for me?

Hi all,

I’m using Backintime for a very long time now, nearly a decade. Rock solid, tested restoring files and folders a couple of times.
Wanted to make my first backup after zypper dup to 15.3, fails (reproducible) somewhere at the end of the snapshot. Reported here and here
My question: I’m the only one affected? Or same for others? Who is using Backintime on Leap 15.3?
I’m a little nervous without backups, currently :slight_smile:


THANKS to Tejas Guruswamy ( !!!

Summarized, for all who are liking and using Backintime:

  • Backintime 1.2.1 on TW and Leap 15.3 stores temp. snapshot runtime data, e.g. logfile, below ~/.local/share/backintime
  • Backintime 1.1.24 and earlier on Leap 15.2 stored this somewhere else, no issue
  • As a result, ~/.local/share/backintime folder MUST be added to Backintime’s EXCLUDE list if you want to INCLUDE $HOME (~) to snapshots

I’m not using that software, so it does not affect me. However, I would like to thank you for reporting this – both the bug report and the forum post.

I support this.

But I find it strange that the product, knowing where it will write it’s log, doesn’t implicitly add it to it’s exclude list. Maybe together with a remark in the log or elsewhere.

I agree. However, perhaps this will be fixed in a future release.

I am using backintime with leap 15.3 with no issues. Have been using this for probably 10 years. It even restores a single file, a directorory, or more. So many other backups do a backup but no one ever tests their restorability which is lacking in many. Only comment is that it does not do incremental backups as well as advertised. I have lots of disk space and don’t keep many backups so this is no issue.

Just did update to 1.2.1 No problem.

Add /run/* to the exclude list to avoid backing up your backups from an external drive. I run it as root all the time. Restores to /home get ownerships properly treated.

tom kosvic

I use backintime also for years and have no problems.

Hi Tom,

why no incremental backups? Exactly this is the main reason why I’m it using for years now? Are you maybe using file systems without hard links? I started years ago with snapshotting to an usb hdd with NTFS, and this was a performance nightmare. Reformatted to ext4, voila, solved.

Kindly a remark to all “no problems” replies: My issue happens only if you include your home dir (~) recursively in your snapshots, as now, starting from Leap 15.3 / backintime 1.2.1, backintime started to store it’s intermediate log file to folder ~/.local/share/backintime. This intermediate log file will be moved to the snapshot’s root dir at the backup location.

In reference to others prev comments:

~/.local/share/backintime/takesnapshot_log is only 2.5k file on my machine so I don’t worry about it.

I do not know what is meant about filesystems without hard links with reference to incremental backups. Please amplify. Perhaps, I can get more incremental backups. But as I said, I have lots of storage on external disks and only keep 2 or 3 backups so doing full backups is not really an issue.

I too have ext for all partitions. btrfs seemed like more potential problems than it’s benefits.

tom kosvic