[B]rt73 usb device not working prorperly (suse 11.1)[/B]

I recently installed opensuse 11.1 (Gnome) - unfortunately the wireless connection is very fickle. I am using a ‘Cnet’ wireless usb dongle which uses the rt73 chipset - it seemed to work fine on Ubuntu 8.10 but I have had the same problem using fedora 10.

Most of the time, I can see my wireless access point (but not always). Some of the time, when I attempt to connect, it gets stuck finding a dhcp address. The rest of the time, it connects, although usually the connection is very on/off - eg updating, the average speed was something ridiculous like 300 b/s, however the max speed was about 60 kb/s. Occasionally, the connection also works fine and downloads at an average speed of 60 kb/s.

The connection strength varies between about 30 and 50% - I don’t think it is an issue since it worked fine on Ubuntu 8.10. I also have a windows laptop which works fine using the same access point - I don’t have any wireless security enabled either.

Has anyone else encountered the same problem? I have spent a while trying to get it to work but have had no success - eg. using the traditional ifup method of connecting rather than using gnomes network manager etc makes no difference.

Any help would be greatly apprecaited!

I have just upgraded to opensuse 11.1 with KDE 4 and 3, and I have had the same problem with my wireless Edimax EW-7138ug usb dongle.

The wireless kept on dropping the connection to the access point and when it did connect, I got really slow transfer speeds.

After messing around with the kernel drivers I found that if I removed the rt2500usb driver from loading in the kernel, then the usb wireless worked.

So I did the following :

  • Started up YaST control center and went to the ‘Network Settings’, I then made sure that the wireless setup in the ‘Hardware’ tab is assigned to the module ‘rt73usb’.

  • I then edit the file /etc/modprobe.d/blacklist using sudo:

sudo vi /etc/modprobe.d/blacklist

and added the line at the bottom of the file

blacklist rt2500usb

This will remove the kernal module rt2500usb from loading.

  • I then just rebooted the computer to test out the wireless connection.

Hopefully this might work for you too :slight_smile: