[azrock led controller] taken as a gaame controller

Greetings !!

I’m a big fan of retrogaming and emulators and so on…

I recently switched my configuration to a motherboard supporting AM4 processors.
The chance I hadn’t is that this motherboard has a “led controller” that is very beautiful but that messed up all my emulators “dolphin-emu”, “mgba” and so on…

The “led controller” is taken as a “game controller” in Yast and all the values are set to -32768… as a result: all the characters are moved to the left upper corner ^^

I did not yet disabled it at BIOS/UEFI but I wonder if it is possible to remove this device (blacklist) from the ones taken as “game controller”, but I did not find yet
how to tell Linux to black list “Azrock game controller” from the “game controller” list ^^

Thank you to find some time to read and try to find a workaround ^^

Hmm When you switched did you run mkinird to discover the new hardware???

nope… linux seems to adapt itself to new hardware without any problem (maybe thanks to udev)… all the hardware seems to work properly but the “led controller” is seen as a “game controller”… I hope that
concerning the game controller probe they have not seek like “lspci | grep controller” to determine there was a “game controller” ^^

i just have to say that I have some “warning messages” at boot… i will take a picture one day, as my system works, all my services are running… they are not important
I will give my config details to opensuse if I take the time tonite to do so.

right now I’m at work.


here is the main issue, the system AND most of the emulators even if I play mostly via keyboard – like MAME with which I got no troubles – are using “game controller” as default device for control :{


another view of the lack in most of emulators to DISABLE the analog controller from the list.


…as you can see… it is not very comfortable to play with such an issue :{

It never hurts to run mkinird and it maybe will fix things

mkinitrd… I will try but here I don’t want the “game controller” to be set as I have NO game controller, the only “controller” I have is a led controller that could be disabled from BIOS/UEFI, I will try first from UEFI.
And if it doesn’t work I would like to blacklist this “led controller” to be detected.

mkinitrd doesn’t do such tings I think. There is no --without option but it does use modprobe.d I really don’t know how to find a workaround here.


This is all I have to try “disable” the “led controller” that is mistaken as a “joystick” :^

Have a look down in the Sysfs directory, /sys/<path_to_device> there should be an enable entry and if you cat it, it has a 1?


cat /sys/devices/pci0000\:00/0000\:00\:1b.0/enable

If so as root user, echo 0 > <the device/enable> does it change to 0, is the device now interfering?

This is all I have…

sirius:/sys/devices/pci0000:00/0000:00:01.2/0000:01:00.0/usb1/1-10/1-10:1.0 # ls
0003:26CE:01A2.000A  bAlternateSetting  bInterfaceNumber    bInterfaceSubClass  driver  ep_81     power      supports_autosuspend
authorized           bInterfaceClass    bInterfaceProtocol  bNumEndpoints       ep_02   modalias  subsystem  uevent
sirius:/sys/devices/pci0000:00/0000:00:01.2/0000:01:00.0/usb1/1-10/1-10:1.0 # more b*

I don’t know if authorized is similar with *enable *(it is set to 1).
Seeking infos about bInterfaceClass to change it to something different than “game controller” ^^



Looks that way, so echo a 0 to it and see if that helps :slight_smile: