avidemux sound problem

I have a problem with avidemux-qt sound: when a vob or flv file is loaded, the sound works in about 2 second pulses. This does not happen with an mp4 file. I use pulse audio and so far all other audio applications are working OK. If I play those (faulting) clips with vlc or kaffeine, they work fine.
I did proceed with a conversion of one of those faulting files right through to an iso (via devede) and the sound was bad.

What do you mean with that? That you have sound or you have any sound but you have only for 2 seconds?

If I open a vob or flv file in the editor, the movie plays fine, but the sound plays in about 2 second sections - 2 seconds on and 2 seconds off repeating all the time.

You have Gstreamer as main?

It is also good to read this VLC and .mkv files.

It is not for avidemux-qt it is for VLC, but it is better to check it. It has a interesting link there “MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf”

Read it. It is very useful.

I used mmcheck vers 2.3 and had quite a bit of updating to do as the packman repositories have changed. I re-installed avidemux qt4, deleted config file, still the same problem. I tried avidemux gtk and it had the same problem. I then changed back to qt4, as it looks nicer. I checked the same clip with vlc, kaffeine, totem, smplayer and xine and it plays OK. Not sure where to go now. The only thing that is different with my setup is that I downloaded “tumbleweed” kde 4.6.rc2 - could this have an effect on avidemux?

Mmmmm I thing Yes because tumbleweed is not so stable and has problems. I know that tumbleweed is not for “normal” users, tumbleweed is a bit different. So try with your openSUSE 11.4 to check avidemux-qt.

Read this HowTo: upgrade openSUSE 11.4 to Tumbleweed