Avahi-Discover confirms service discovery not working.


I have a number of printers that support several discovery protocols: SLP, mDNS/Bonjour & avahi. I have no reason to suspect that they are not working as intended.

However, after a number of clean installs of 13.1, SOME workstation refuse to detect these printers using any of the above protocols. They can however see & use the printers if provided with a name or IP address (DNS resolution is working?).
OTHERS, can detect all of the printers using any of the above protocols.

Unable to find a simple SLP browser (please tell me where/how the Yast2 SLP browser works - yes, I’ve seen https://doc.opensuse.org/products/draft/SLES/SLES-admin_sd_draft/cha.slp.html), I have installed the Python-avahi-browser.

This conforms that on the good workstations, it finds numerous service, but the suspect workstation — nada, naught, nix, nothing, null, zero, zilch, zip!


Regards, Martin

  1. Are using Network Manager? Try using traditional ifup.
  2. Or add you name to ‘avahi’ group.
    Either may work :wink:
  1. Are they all connected within the same segment of a LAN?

  2. Firewall config issue? The firewall has allowed services including ‘Zeroconf/Bonjour Multicast DNS’

Thank you all for all the helpful suggestions,

All, apart from the user group membership, I had tried and eliminated as not the cause of my problem. For completeness, commented below:

  1. Firewall. Off in all cases.
  2. NetworkManager/ifup. No effect, I am leaving all workstations on ifup - just my preference.
  3. Same LAN Segment. Yes and Wired/Wireless has no influence.
  4. User Groups. No effect - In or out of the Avahi and/or Avaih-Autoip groups.
  5. DHCP. All workstations are given their network parameters (hostnames, routes, gateways etc.) from the same DHCP server.

Any other suggestions or test that I can run to add some information to the above list would be very welcome.
Also, any thoughts on how to run the Yast2 SLP browser? If I try to run the command (as documented in the link given in my opening mail), I get this:

gzunder:~ # yast2 slp
No such client module slp
The search path follows. It does not include the current directory.
Run 'yast2 -h' for help on usage

However, the Yast2 GUI says that the SLP client is in /usr/share/YaST2/Modules. So, I try:

gzunder:~ # yast2 /usr/share/YaST2/modules/SLP.rb
gzunder:~ # 

Apparently no results (on all test workstations)!!

Regards, Martin

If you are in front of the machines and printers, try power-cycling one of the printers, and have the CUPS web interface open on one of the ‘problem’ workstations. Maybe the printer will be discovered more easily at that time. I had a similar (but temporary) experience when setting up my new openSUSE 13.1 install to connect to my network-attached work printer. Soon after it was power-cycled, the printer broadcast was captured by Avahi/CUPS. Other than that, I’m not sure what to advise. (I am considering installing CUPS 1.6 or 1.7 when I get time as significant changes have been made with 1.6, although this should not be impacting on your current situation.)

What’s New in CUPS 1.6 - CUPS.org

What’s New in CUPS 1.7 - CUPS.org

Thank you for all your suggestions. But unfortunately, that hasn’t worked either.

Never mind. I guess that it will either get better on its own … Or not! Ho Hum :\

Best regards, Martin