Autostarting kbluetooth4 in KDE3 sessions?


Following a thread on these very forums, I finally made bluetooth work on my OS 11.1 laptop (disabling KDE3 bluetooth and upgrading the KDE4 bluetooth framework). Now, since I can’t stand KDE4.x, and need bluetooth in KDE3.x: how do I make kbluetooth4 to autostart in every KDE3.x session? I’d prefer a GUI/YAST method, if at all possible; editing runlevels manually and such is WAY too scary for me… (shiver)

Thanx in advance!

  • JosipBroz,
    it autostarts just fine here as part of the saved session. As long as the bluetooth adapter is plugged in, that is.

Else go to “Personal Settings Configure Desktop”, Advanced, Autostart and add it there.


Thx, will try that.

One funny thing, though:
my KDE3 bluetooth applet (which doesn’t work and stays grey all the time) keeps autostarting in every KDE3 session, although I have now several times disabled it: whenever i close it, it diligently asks me whether I wish it to start again with the next session. I consistently answer NO, but the stubborn applet keeps reappearing with each and every KDE3 session - a funny behaviour for an applet that doesn’t work at all, just stays idle and grey doing nothing.

On the other hand, the KDE4 bluetooth applet which does work, insists on getting started manually; and when I close it, it doesn’t ask me whether I wish it to start again in the next session - it just silently exits (or sometimes simply crashes on me).

  • JosipBroz,

I noticed similar behavior with the KNetworkmanager applet. I decided to uninstall KDE3 components when they misbehave.