Automount Video DVD

What do I need to be able to get a Video DVD to mount and play.

I am pretty sure all the right packman packages and libdvdcss2 are installed according to the sticky post for Leap 42.3 Multimedia.

I’m running under Gnome.

I cannot check at the moment, but please check that you have installed:
especially the latter that seems to be missing from the guide.

You are right, the latter was missing, but unfortunately, that seems not to solve the problem. My Video DVD is not mounted after inserting it.

Do you mean “not mounted automatically”?
Maybe you have to configure “how media should be handled” in Gnome:
> open Gnome Settings (upper right corner of the screen, the “tools” button);
> go to “Devices”, then “Removable Media” (scroll down if not shown);
> select the drop down menu for DVD video and check “Videos” (or another player that you might have installed).

Anyway you should be able to manually mount and/or play an inserted DVD; if not so, please show the result of:

lsblk -p

It is not mounted automatically, whatever program I want to start with it

harvey@linux-lueh:~> lsblk -p
/dev/sda      8:0    0 223.6G  0 disk 
├─/dev/sda1   8:1    0     2G  0 part [SWAP]
├─/dev/sda2   8:2    0    40G  0 part /usr/local
└─/dev/sda3   8:3    0 181.6G  0 part /home
/dev/sr0     11:0    1   6.8G  0 rom  

Apparently the DVD is recognized somehow (assuming it is /dev/sr0) but not mounted at the moment.
Try to see what Gnome Disks says about that DVD (with the video DVD inserted, of course).
As already written, I’m not able to test or confirm at the moment; I might be able to do so in the next few days, so stay tuned or wait for somebody else to confirm this problem.
I recall witnessing a similar problem, see Bug 1028142 or Bug 1020034 but I cannot say if what you see has a similar root cause.

Thank you for your help!

Gnome Disks shows the CD/DVD Drive with 7.3 GB, read-only, with ‘Unknown’ contents.

I tried mounting it manually and after about 20 minutes (might have been more), it did indeed get mounted. Showing the 2 directories by Nautilus, for example, (AUDIO-TS and VIDEO-TS) was quick, or for that matter by a player (e.g. VLC, MPlayer). But listing the files could also be very long-winded. And, who knows, if I waited for another 30 minutes the film might play…whatever. Not much fun!

That looks somewhat similar to Comment #7
Feel free to open a new bug report, possibly quoting the above. I will join to help testing as soon as possible.

Sorry, I cannot confirm your problem. With a fairly standard Leap 15 Gnome install, with codecs switched to Packman and:

(and related dependencies)
libdvdcss2-1.4.2 (available from )

installed, a commercial video DVD auto-mounts to /run/media/<username>/<title of movie> and auto-plays with Videos/Totem when instructed to do so.
Gnome Disks shows: “Contents UDF (version 1.02) — Mounted at /run/media/…”

Maybe the DVD you are using has an odd or broken format?

I have precisely the packman packages you listed above, and I doubt if the DVDs are broken. The 2 DVD’s (containing full length films) worked on a Macbook very well. They don’t work on my 2 different Linux configurations. (Laptop and Desktop). In fact, if I wait for about 5 or 6 minutes the DVDs are indeed mounted. Opening one of the relevant video files in the VIDEO_TS directory also requires several minutes which then runs intermittently from frame to frame with long waits (minutes rather than seconds) between. I also have other DVDs containing videos shorter (ca. 20 minute) cartoon films. These run as expected normally.

I am beginning to wonder if my disk/swap partitions are well configured for running large films. Could that be relevant? On the desktop, swap is 2.2 GB, root partition 43 GB (24 GB free), home has 195 GB (106 GB free)

If you have at least some DVD that play successfully your systems are likely basically sound. But not all DVDs are created equal, I use 4-5 different discs from different vendors to test compliance and occasionally one or two are not recognized on faulty systems while the others play…
Since Gnome Disks shows “Unknown” contents I wonder if your “faulty” DVD uses a format that might be “special” in any way, possibly being a “multi session” disk, with software alongside video contents or the like.
Gnome Disks shows the correct size (apparently) so I guess that the disk drives and the basic disk drivers are OK.
Please show the result of:

lsblk -o +FSTYPE /dev/sr0

(assuming that your DVD drive is sr0) once the DVD finally gets mounted and please specify if this is a commercial video DVD or if you have burnt it yourself.

The DVDs that are giving me trouble are commercial ones. (But only the 2 linux systems are troublesome)

harvey@linux-zeln:~> lsblk -o +FSTYPE /dev/sr0
NAME MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT                              FSTYPE
sr0   11:0    1  6.4G  0 rom  /run/media/harvey/DAS_DOPPELTE_LOTTCHEN 

This is the result from the laptop, in this case. Neither DVD gets mounted on the desktop within a reasonable time, whereby there is no problem with data DVD/CDs or a self-made video DVD.

Could it be a problem with the drive itself? I have seen similar on DVD drives that are just a bit off-track, or with dirty lenses.

Yes, I also had this thought, too. But I have been checking on two different configurations (laptop and desktop) and with several different DVDs. Although the behaviour is not identical in each case, it is similar enough to eliminate that as cause, at least on the laptop. There the two commercial DVDs get mounted but will not play. On the desktop, the same commercial DVDs may, perhaps, not mount at all, but if they do, they don’t play, whereas other commercial DVDs (e.g. 20 min films) or self-made DVDs/CDs (Data, Audio/Video), pose no problems at all.

I’m just guessing here
have you set or changed the region code of your dvd device
I know linux ignores region code but windows demands it if you had a windows running that dvd it might have set some sort of bit in the dvd bios
you should check with the drive’s manufacturers cos a lot of DVD devices do get flashable bios updates
I use to do this in the past as some updates included updated info about DVD R- and R+ devices
under linux if a device is not mountable either the DVD disk is damaged or the DVD reader is dying there shouldn’t be any software issue mounting the drive
you do need libdvdcss2 to play region css encoded (commercial) disks tho

The output looks pretty “normal”, but invoking the command as normal user reads data from the disk cache; to read from the disk itself try to issue the same as superuser, e.g.:

bruno@LT_B:~> lsblk -o +FSTYPE /dev/sr0
sr0   11:0    1  7,7G  0 rom  /run/media/bruno/THE_movie_label
bruno@LT_B:~> sudo lsblk -o +FSTYPE /dev/sr0
[sudo] password for root: 
sr0   11:0    1  7,7G  0 rom  /run/media/bruno/THE_movie_label **udf**

and see if one of the working DVDs shows any difference.
The very long mount times make me wonder if there is something in the format of those disks that is not (yet) recognized by libblkid1 or possibly some odd protection technique not overcome by libdvdcss2.
Not being able to reproduce here, I cannot go much further than that.
I would suggest to open a bug report, but if that is a corner case I doubt that they can do anything good without the “suspect” DVDs.

Since I don’t know what the region code is nor how to change it, I guess it must still be OK.

I did a search and came up with this : on that DVD’s back cover I see “Diese DVD ist kopiergeschuetzt!”.
Maybe they use a protection technique that allows playing the disk in DVD-video mode (with decoding within suitable DVD drives) and not reading the disk as a “data-DVD-ROM” with software decoding as Linux systems usually do via libdvdcss2.
That might explain why Gnome-Disks lists that disk as “Content Unknown”, but that is beyond my knowledge so I can only guess here.
BTW that cover doesn’t show any “Region Code” protection, so maybe region is not an issue here.

Aha…should have twigged that one! Thanks for the tip.

All DVDs I have been using to test this behaviour are of FSTYPE udf

The two commercial DVDs that don’t play (or even mount (easily)) are ‘kopiergeschützt’. But I’m not trying to copy them, I only want to play them! That’s what I bought them for!