Automount Stopped Working


This has me baffled and I’ve been trying all sorts of way to diagnose and solve the problem but have made to progress so far:

**Sometime in the last two weeks devices stopped being mounted automatically. **>:(

Previously, when I connected a USB drive or inserted a memory-card into the card-reader, it was mounted automatically and the file manager automatically opened with newly mounted folder. This is exactly what is configured in the Removal Drive and Media configuration:

As shown, the media is set to be mounted when plugging in (USB Drive) and inserted (Memory-Card). Plus, it is supposed to open a window to view the content.

However, now, whatever I plug in is recognized and appears listed in the Devices sidebar greyed out. There is the option to mount it from there, which works but
it no longer happens automatically.

There were no hardware changes to my system since this worked but the following updates occurred:

Even though a number of them seemed potentially related (deive-mapper, libdevmapper1_03, lvm2, etc), I don’t know which was the previous version so I switched
it to the main repo one which I know used to work but it doesn’t. I reverted most of the list above to the original ones shipped with the OpenSUSE 15.2 release but
the problem persists.

It is possible that one of the updates above changed configuration that is not reverted when installing the old version but I can’t figure out what. I went through the
troubleshooting section of On-Demand Mounting but did not get it working either. Even running automount manually with the verbose flag does not show any errors,
it just silently ignored any drives that are plugged in order cards that are inserted. Did all the stop, start, reload, rebooting, etc and nothing comes up. The status is
shown as active:

systemctl status autofs
* autofs.service - Automounts filesystems on demand
   Loaded: loaded (/usr/lib/systemd/system/autofs.service; enabled; vendor preset: disabled)
   Active: active (running) since Sun 2020-10-18 16:41:56 EDT; 24min ago
     Docs: man:automount(8)
 Main PID: 1839 (automount)
    Tasks: 3
   CGroup: /system.slice/autofs.service
           `-1839 /usr/sbin/automount -p /var/run/

Oct 18 16:41:56 vega systemd[1]: Starting Automounts filesystems on demand...
Oct 18 16:41:56 vega systemd[1]: Started Automounts filesystems on demand.

File auto.master had not been touched and in fact matches exactly a previous backup. It is mostly comments except for one line"


Found an old thread (5yrs old) from Tumbleweed with a similar problem but couldn’t figure out how to use it to solve my issue.

Any ideas how to fix the automount or how to diagnose the issue?

Please help and let me know if any additional information would be useful.

Thank you,

  • Itai

I more or less stopped reading this post not far from the start because you apparently are talking about a dekstop, but failed to tell which one.

If “brasero” then, GNOME …


Honestly, I don’t think this has anything to do with a desktop other than the configuration dialog to change those things via a GUI rather than text. That GUI in the
original post is from Thunar which is the File Manager in XFCE.

AFAIK, autofs is a generic daemon that detects when a drive is hot-plugged or media is inserted into a drive and automatically mounts it to a created mount-mount.

The desktop just happens to choose the icon and where to display it, as well as the file manager but even if there we no desktop at all, autofs should work.Note the
documentation on this does not mention a desktop either.

If the desktop does make a difference, please let me know how. Again this has puzzled me for several days now and perhaps I am not solving the issue because I
have failed to understand the problem. Note that none of the packages that have updated have anything to do with XFCE either.


  • Itai

That’s funny I have no idea why it chose Brasero. The desktop is XFCE and, yes Brasero is installed but I use Xfburn to burn disks which I haven’t done in a long time,
so didn’t even pay attention to those settings.

  • Itai

When I see “Gnome” somewhere in the begin of a new thread, I will refrain from going into it any further because I have no knowledge. But when I first have to solve a puzzle if there is somewhere deep inside the story a hint to what is used, I think of that as non-productive. As a mere member I would simply skip the thread because of too much riddles for me. But as a mod I feel a certain responsabillity to get as much help to those asking questions as possible and thus try to get a clear statement about what they use asap.


The “autofs” automatically mounts paths which could be set-up as a boot-time system mount in /etc/fstab.

  • Therefore I doubt that, the GNOME auto-mounter is using “autofs”.

The Desktop environments are normally use FUSE – “Filesystem in Userspace” – to handle the mounting and dismounting of removable media by users …
[HR][/HR]You may have to get into the GNOME dconf-editor to check if, a setting hasn’t been changed with the recent updates.
[HR][/HR]What happens with another user?

  • Create a new (blank, clean) user for testing purposes and, see if that user also has this removable media issue.

I was typing my reply assuming the GNOME Desktop when you added this entry …

  • Doesn’t really affect the issue – I suspect that, XFCE also uses FUSE to handle removable media from a user’s perspective …

There are different mechanisms that have somewhere the word “automount” connected to it.

  • Some people connect it to the fstab option auto/noauto, which lets mount -a skip the entries with noauto.
  • Automount in Unix/Linux has always been the feature of mounting “when needed” as defined in /etc/auto.master and assoiciated configuration files. This automounting has indeed nothing to do with any GUI or DE. The GUI users does not even notice it happens. BTW there is now a new implementation of this type of automount by using systemd.automount, which configures it in /etc/fstab (no auto.master, etc. needed).
  • GUI users often call automount when the desktop signals spontanious connected mass-storage with file system(s) to them: this may be for you, what do you want with it. When the user then indeed signals back it wants to use the file system, it is mounted for him somewhere and made available through e.g. his file manager. IMHO there is not much auto here then in any other action initiated by the user. I am not sure if this usage of the term “automount” comes from MS Windows and traveled with former MS Windows users into the Linux world.


That is what stops happening. Until about 2 weeks ago, when a USB key or memory-card was attached or inserted, the device was automatically mounted.
Yes, XFCE gave it an icon and added it to the file-manager but that is after the mounting happened. The problem seems to be with something that should
be happening before.

What used to happen is something mounted these devices to:


What process normally mounts devices there? My guess from a few online searches was automount.

There are instructions for added pre-defined devices to the config but this is not what I need since I work with hundreds of memory cards and frequently
need to transfer files onto a new USB key that someone brings. There is a system that is meant for this but somehow it stopped working.

We can see later if XFCE reacts or not when the underlying is fixed but for now, I need help figuring out why devices stopped automatically mounting.


  • Itai


While this is KFCE and I’ve shown the settings above, I also checked the Gnome settings in dConf and both ‘automount’ and ‘automount-open’ are enabled
just like what I see when I created a new user…

What happens with another user?

…which for some reason works! :question:

Any idea how to make it work for my user? Any files or configs to compare and copy settings from?

Just double-checked and it still doesn’t work for my user, after working for the other new user, so it must be somewhere in the per-user config but it’s like
looking for a needle in a haystack!


  • Itai

Found it!

After a recursive diff between the new user and existing user .config folder, the setting in:



<property name="misc-volume-management" type="bool" value="true"/>

Value has to be true above.

This corrects the behavior and takes precedence over the previous setting shown in the original post of this thread.

  • Itai