Automount NTFS USB Disk with write accessrights

Hi all,

I’m using openSUSE 11.0 and want to use a NTFS 320GB USB Disk with it. At the moment I plug in the device and can see it automatically mounted at /media/Volume.
But I don’t have writeaccess to it and I need it!

I did some research, but I didn’t find any information about this issue.

I followed the information at the site
→ Automatisches Einbinden externer Festplatten mit NTFS Schreibunterstützung

but I didn’t have any success?!?!?! :’(
I know the description is for V10.3, but I’m new and naive and thougt the difference from 10.3 -> 11.0 isn’t to big. :sarcastic:

With the command:
ntfs-3g -o rw,gid=users,umask=0002 /dev/sdb1 /mnt

I can it mount writeable!

Is anybody out there who had the same problem and can give me some hints to solve my problem?

Many thanx in advance

Sorry my bad english.
sudo ln -s /sbin/mount.ntfs-3g /sbin/mount.ntfs

More information here.

thank you for your answere, but I don’t get it running.

I tested your symlink, but there was no difference.

I get a Dialog with the messages what I like to do ‘Start Dolphin…’ ‘Look for Pictures’ or ‘Do nothing’.
When I select the Dolphin entry I get the message:

org.freedesktop.Hal.Device.Volume.Unknown.Failure: TODO: have to rethink extra options

I have no Idea, what I’m doing wrong.
When starting with ntfs-config, I can do a mount with full accessrights.
But I would appreciate to do the stuff with the automount.


try to edit file /etc/fstab
add there line with options for your hdd,
or if the line is already there simply add to options rw,users,uid=<your user id(usualy 1000 for the first user)>


>dmesg | tail
sd 7:0:0:0: [sdb] Assuming drive cache: write through
sd 7:0:0:0: [sdb] 625142448 512-byte hardware sectors (320073 MB)
sd 7:0:0:0: [sdb] Write Protect is off
sd 7:0:0:0: [sdb] Mode Sense: 34 00 00 00
sd 7:0:0:0: [sdb] Assuming drive cache: write through
sdb: sdb1
sd 7:0:0:0: [sdb] Attached SCSI disk
sd 7:0:0:0: Attached scsi generic sg2 type 0
usb-storage: device scan complete
NFS: unknown mount option: notcp - ignored

I see the upper messages when I plug in the device.


I don’t think you are doing anything wrong. I know you stated you are running openSUSE-11.0, but I’ve only seen this error on 11.1 beta. Hence it reads to me that you are running openSUSE-11.1 beta, and this is not working with the beta software. Did you add “factory” to your repos to cause this?

You can still manually mount the drives to read/write (which is very quick to do) but you will need to spend the time to learn and understand the linux commands.

Thanx oldcpu,

I checked the repos entries, and I didn’t find an entry with factory.

Today I can’t check the behavior, since I havn’t the drive with me.

I tested the manually mount, and it works propperly, but the automount is i my ‘problem child’!

Kind regards