Automount external FAT32 drive at bootup?

I’ve been searching on google for a while now to solve the problem with my external FAT32 drive not automounting at bootup and I get stuck on this command:

“UUID=09EB-9EDD /media/elements reiserfs users,defaults 0 0”

The answer I get is:

“bash: /media/elements: is a directory”

What have I missed with my command? Is it a command?

Peace of the lotus.

Try this format:

/dev/disk/by-uuid/09eb-9edd /media/elements reiserfs users,defaults 0 0

Sure the UUID isn’t longer than that?

“ls -l /dev/disk/by-uuid”

gives me:

“total 0
lrwxrwxrwx 1 root root 10 2008-10-12 02:43 09EB-9EDD → …/…/sdd1
lrwxrwxrwx 1 root root 10 2008-10-11 23:52 0dbc6ad9-8a0e-47d2-8205-88dac5a3bf79 → …/…/sda3
lrwxrwxrwx 1 root root 10 2008-10-11 23:52 0f923c4b-9db6-4f07-91de-fd31f466452e → …/…/sda1
lrwxrwxrwx 1 root root 10 2008-10-11 23:52 a37df392-de9f-4464-9910-8bee091772f2 → …/…/sda2”

Where sdd1 is my external FAT32 drive.

“/dev/disk/by-uuid/09eb-9edd /media/elements reiserfs users,defaults 0 0”

gives me:

“bash: /dev/disk/by-uuid/09eb-9edd: No such file or directory”

and when i change “09eb-9edd” to “09EB-9EDD” which must be the correct name I get this from “/dev/disk/by-uuid/09EB-9EDD /media/elements reiserfs users,defaults 0 0”:

“bash: /dev/disk/by-uuid/09EB-9EDD: Permission denied”

even though I’m loged in as root.

Thank you very much for your help, I realy appreciate it.

Best regards…

Are you trying to execute that line as a command? It’s not a command. You should put it in /etc/fstab.

When I write “/etc/fstab” I get:

“bash: /etc/fstab: Permission denied”

and when I write “edit /etc/fstab” I get this:

“/dev/disk/by-id/scsi-SATA_Hitachi_HTS7220071108DP1C10DJG7LGHP-part1 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_Hitachi_HTS7220071108DP1C10DJG7LGHP-part2 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_Hitachi_HTS7220071108DP1C10DJG7LGHP-part3 /home ext3 acl,user_xattr 1 2
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0”

Where should i put “/dev/disk/by-uuid/09eb-9edd /media/elements reiserfs users,defaults 0 0”? I tried to put it on a new line under “/dev/disk/by-id/scsi-SATA_Hitachi_HTS7220071108DP1C10DJG7LGHP-part3 /home ext3 acl,user_xattr 1 2” but it disapeard.

Hmm, you’d better add that mount spec using YaST > … > Disk partitioner then, if you don’t know how to use a text editor.

I tried to put the line there again and save (ctrl + s) but when i open “edit /etc/fstab” again it’s gone. So therefore I tried to open “etc/fstab” in openoffice, but when I try to edit it there I get the message “object not accessible. The object cannot be accessed due to insufficient user rights.”. How can I be logged in as root when I edit something in openoffice?

I saw your new post now. The line can’t be used in the partitioner. Do you know wich options to change for my drive under edit in the partitioner to get it to work?

Best of regards and peace of the lotus.

Sure you can put it into the partitioner, you may have to put the various components in separate boxes though.

I did put in that line in /etc/fstab using vi. I saved and I rebooted but sadly the drive didn’t automount. What does “reiserfs” stand for? Do you have any more sugestions?

Best of regards…

Swerdna came up with this beutifull line “/dev/sdc1 /media/elements vfat user,check=r,umask=0000,utf8=true 0 0” that works perfectly and lets me get write permission and use å,ä and ö for the drive.

The only problem is that my drives name “sdc1” sometimes changes to “sdb1” or “sdd1” so I want to use the drives uuid instead and came up with this line “/dev/sdc1 /media/elements vfat user,check=r,umask=0000,utf8=true 0 0” wich doesn’t work. Do you have any idea of how to fix that line in order to make it work?

Best of the best regards / Autonym

reiserfs is a Linux filesystem. You must have cut-and-pasted that line from an Internet web page without understanding its meaning. I took your word for it that you had a reiserfs on the disk, but you really don’t. Your filesystem type is actually vfat, a Windows filesystem.

The fact that the drive names may change is why the mount by uuid method exists. Go back and change that /dev/sdc1 in the line to:


You missunderstood me. The threads name is “Automount external FAT32 drive at bootup?” so I’ve always been 100% sure I have a FAT32 drive. I did do the changes you sugested, just typed the wrong line when I was to explain to you. But that line didn’t work so one has to make some changes to it. Have any idea?

Best of regards!

Ok I missed that. I should have spotted that your line didn’t correspond to your thread title and that you didn’t really understand what reiserfs meant.

You’ll just have to figure out whether that UUID link exists at boot time, and if not, why not.

I got it to work with this line:

“/dev/disk/by-path/pci-0000:00:1d.7-usb-0:1:1.0-scsi-0:0:0:0-part1 /media/elements vfat user,check=r,umask=0000,utf8=true 0 0”

So now I’m happy! Thank you so very much for all help.

The best regards!