Automount CDROM

After 4.3 update Automount of CDROM does not appear to be working anymore .
Inserted several disk and can’t find mounted drive to access CDs .
Noticed it when I burned a CD with K3B and tried checking data after burning , so CD can burn okay , see it in ‘dmesg’ , in YaST it shows drive is present , Device Notifier use to show drive when CD was inserted , do I have something set wrong in KDE 4.3 ?

No one , any help .

you can try to add a new user and see if, when signed in as that new
user, if it works as expected…


How do your Preferences look in “Personal Settings -> Hardware -> Storage Media -> Notifications”?

Unmounted CD-ROM
Open in New Window
Copy CD with K3b
Do Nothing

Mounted CD-ROM
Open in New Window
Do Nothing

Created a new user account , no joy .

Hmmm , nothing there that pertains to ‘Storage Media’ , just have 3 entries , Power , Network , and Bluetooth Management Backend .

Was curious , booted into Winders and the drive works there , tried my wifes com that has SuSE 11.1 as well , Personal Settings has the same 3 entries , put same CD into hers and up pops the Auto Notification , hmmmm . KDE4.3 “release 155”

In ‘My Computer’ it does not show device when disk is inserted either , tried it in the other com and device should show CDROM when disk is in drive and My Computer is opened .
I do believe this to be a Software issue not a drive issue , that is why I have placed it in this section and not Hardware .
/dev/disk/by-id/ata-FUJITSU_MHV2060BH_NW02T6225MFY-part6 swap swap defaults 0 0
/dev/disk/by-id/ata-FUJITSU_MHV2060BH_NW02T6225MFY-part7 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-FUJITSU_MHV2060BH_NW02T6225MFY-part8 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-FUJITSU_MHV2060BH_NW02T6225MFY-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-FUJITSU_MHV2060BH_NW02T6225MFY-part5 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

As the guys have already said, it could be your notifications. If you put the cd in the drive, it should at least automount and appear in /media.

So where are these ‘notifications’ at , they are not where the ‘guys’ said .
It should appear in ‘My Computer’ as well , when disk is inserted , but it don’t !
Automount is HAL and fstab controlled right (KDE looks to them for device info) ?

In ‘Device Actions-System Settings’ I get a error when trying to set up ‘Open with File Manager’(there are 3 action settings) , it says , ‘It appears that the device conditions for this action are not valid.If you previously used this utility to make changes, please revert them and file a bug .’ , could this be the problem ?
Of course I have not used the utility in question to make changes .
Will fill out another bug report to KDE and see what they say .

My cdroms got buggy after the last update. I’m at kde 4.3 release 158 on 11.1. Virtualbox no longer sees them. I put that down to forgetting what to do after I update the kernel.

But, I put a couple of CDs in the drives and Dolphin takes forever to read them. The info icon says it will take DAYS to read the CD. Then they get weird. They claim 0 bytes in the files. If I click on a subfolder, the files disappear and won’t come back.

I learned that cdroms no longer show in fstab, so that is not even an issue. The point is, I can see and mount the cdroms, but they stopped working.