Automatic WLAN password without tears - and without KWallet

Hi all!

This works with openSUSE 13.2, leap, and tumbleweed - I’ve tried it out on all of these systems!

I’m one of those guys who likes to keep control of the passwords used.
So I don’t like KWallet.

Further, I wanted openSUSE to connect to a known WLAN without asking for any password - a thing that android smartphones don’t have any problem with.

I did quite some installations of openSUSE, and partly it worked, partly it didn’t.

Now I had an installation of openSUSE that I didn’t want to overwrite, but I disliked the nasty dialogue asking for the WLAN password on every boot.

I spent some hours of time to find out how I can get rid of that.

The first thing to do is to disable KWallet manager in your KDE settings.
And if you do this as the first thing after a fresh install then you won’t have problems with WLAN passwords asked repeatedly.

Here’s how I fixed this for an installed openSUSE for which I didn’t do that:

Disable KWallet in you personal KDE settings.

Use YaST to set up network as a ‘wicked’ service.

Then, as root, delete everything in ‘/etc/NetworkManager/system-connections/’.

Then use YaST again, to set up network as to use ‘Network Manager’ again.

The next time you connect to your WLAN, using Network Manager, you will be asked by the corresponding applet for the password.
But not in a separate dialogue, and not employing KWallet, but directly.
And the password you give then is stored, and you will never be asked about it again.

Just fun that it finally works as simple as on my android smartphone!

Good luck everybody

Just enter a blank password the first time kwallet asks. It won’t ask again