Automatic wireless setup/configuration after boot


How could I make wireless work automatically after boot please? The commands I have to issue are:

ifconfig ath0 up

iwconfig ath0 ap any essid “dlink” (I’d rather have roaming essid capability)



André Luiz

In YaST > Network Devices > Network Settings you should edit/configure your wireless device (it’s probably wlan0) to automatically start up at boot “with Network Manager”.

This has been the biggest disappointment for me with recent opensuse. NetworkManager does not work.

I just upgraded 11RC-1 to GM and the networkmanager icon loads and I can see my wireless network, but it will not connect!! I end up shutting it off and running ifup. That stinks when you’re roaming.

Why in the world this has not been fixed is beyond me. It worked beautifully in 10.3.


Yes, it does not work :(. In addition, I still need to do the following commands sequence:

linux:/home/andreltr # ifconfig ath0 up
linux:/home/andreltr # iwconfig ath0 ap any
linux:/home/andreltr # iwconfig ath0 essid “network name”
linux:/home/andreltr # dhclient

I’ve made a simple script to do these tasks but I’d prefer they be performed automatically at boot. In addition, I’d rather have a roaming essid. Thanks for any help,

André Luiz

NetworkManager works perfectly for me in 11.0 and 11.1. I control 3 wireless and
one wired device and I use it in several places.

The key phrase, for me anyway, was “upgrade.” There must have been settings left over in my /home because once I blew that out and did a clean install, NetworkManager began working again.

What should I do then please? Upgrade and/or “blow” my home directory? if so, how to please?


André Luiz

The reason to do an install but leave your /home intact is to save your documents, settings and other applications that you have installed. I have always used this method to save my data from one version to the next and was happy to see I had no problems.

But the upgrade to 11.1 was different for me. I tried several times to install and leave my old /home. Each time the install failed. What you need to do is copy your documents and other important files to a separate medium. Then, reinstall 11.1 but when the partition scheme is offered make sure it formats the /home partition. Remember, anything that is there will now be lost forever.