Automatic Update doesn't work after 11.2

Please go to Yast - Software Management
search for: libdvdcss
make sure it is installed, when it is next go to Software Repositories
Delete the libdvdcss and or VideoLan repo

Next Open Software Management
Filter ‘View’ by repo
On your top left section of the screen you will see Repositories, look for and select Updates. Scroll the list. Blue text on the version numbering shows updates. (This view method is for kde - Please tell me you use kde)

Or try Yast - Online Update (NOT Online Update Config!)

Try as root zypper update yast2-ncurses-pkg
It did the trick for me in 11.1

Similar situation in 11.2 on my desktop.
Aplet for update shows red notice , activation of aplet does nothing.
Manual update works.
This is same in any desktop Gnome, KDA of Xcfe.
Main four repositories active.

Have you tried to install "zypp plugin " for the updater ?
It’s named “kupdateaplet-zypp” in your yast2 installation software

After you did that, change the updater configuration for “zypp” instead of KpackageKit.

Personally, after that the updater works… in a certain way , it does install the updates but there is an error message in the end about permissions…weird isn’t-it? :sarcastic:

It may be the problem with permission settings. Check it

It’s simple, kupdate is broken and can damage your system as it did to mine twice! Remove it and use zypper update or Yast update.