Automatic login

I want, when I boot up, to load and log-in automatically a default user. I get a login in screen with the option to login as root, I do not want this. How do disable the option to login to X as root and just load as me/default user?

There should be no option for root at login
or have you logged in that way before?:open_mouth:

I may have accidently >#startx from root terminal once or twice, but I do not make a habit of being in GUI as Root!

PS when I first had openSuse, if I logged in as root, there was a default desktop covered in fizzing bombs, which is an excellent thing, I must look into getting this back… dunno what happened to it, just another one of those things that seem to change with no user intervention! (grrr those ****ed elves again!!!)

Woa, auto login for root is bad dude.
Even normal users should not have auto login

Which is why I am asking how NOT to have it, and to autologin as me, default user

I don’t recommend auto login - Period.

Bad, Bad.

For me it is what I want, I can make tea whilst booting… My PC is at home, only I and rarely my girlfriend use it…

it’s also better to have it that way for if and when graphical issues arise, but no matter.

Could this be it
http://thumbnails24.imagebam.com/5911/e0829459106375.gif](http://www.imagebam.com/image/e0829459106375)

TY mate, could well be… but no, only my user name is here :frowning:
While we have this page open…
I notice I have two of everything… this a prob?

http://i127.photobucket.com/albums/p145/wakou/etcsys.png

I’m puzzled, why anyway if you enable auto-login would you get logged in any other way than as user?

Me too, but I get a log-in screen with “stephen” and “root” as possibilties… I want it just to autologin as stephen, as I never want to login to GUI as root.

At this page:
ImageBam - Fast, Free Image Hosting and Photo Sharing

type your username in the empty field and apply (Bit of a guess)

Already there Caf mate! (See post above openSUSE Forums - View Single Post - Automatic login), any idea why all categories are listed twice?

But I don’t see your user name - neither the page/section I was pointing to.
Sorry, am I dumb?:shame:

No not at all, I was just showing the everything twice aspect…

http://i127.photobucket.com/albums/p145/wakou/etcsys1.png

So is this checked for you
ImageBam - Fast, Free Image Hosting and Photo Sharing

Yes:

http://i127.photobucket.com/albums/p145/wakou/etcsys4.png

It’s a puzzle to me for sure, not having ever pursued such a issue before. I suspect the duplications are a result of starting a root login.
I’m sure it’s solvable - but not with my limited knowledge.

I’ll keep it in mind and remember you should I come across a solution.