Automatic login problem

openSUSE 11.2+kde+kdm

systemsettings>login manager>users> set autologin but it doesn’t work.

I am to type useraccount and password every time.

Where is the kdm.conf?

I reach this settings at:

The green KDE-menu (lower left in panel) > Systemsettings > Advanced tab > Logon screen > (root password) > new window.
And there the tab Ease of use.
(the wording may be a bity different because IItranslate back from a non-enllish environment).

This seems to be very different from what you have.

Is this of any use?

The enable auto login is checked from Convenience tab but still i am to type username and password to log into kde.

I don’t know why.Probably it’s a bug.

Better tell more then less because we can not look over your shoulder!

When you say it is checked, I assume that the correct user is also chosen?
And in the list at right, for password-less login, do you use that. I do not know if that helps, but it is worth a try.
I will not try this for you because I hate automatic login.

I do not think it is a bug because, while it is not a very sensible thing to have, many users have it switched on.

Autologin can be set in YaST’s ‘User and Group Management’. Select ‘Login Settings’ from ‘Expert Options.’

Alternatively you can make changes to Autologin in YaST’s /etc/sysconfig Editor’; just search for “Autologin”.

As to KDE’s Login Manager. It conflicts somewhat with openSuSE, as it sets similar things in an apparantly slightly different way, and in the end generally loses out.