autologin fail after snapshot 20190202

Autologin to KDE Plasma worked fine until TW update 20190202. Now graphical login screen is presented and re-appears after entering password…repeatedly.

New user works as expected.

Booting to runlevel 3 and

WINDOWMANAGER=/usr/bin/startkde startx

launches Plasma as expected.

Seems like a simple configuration change, but I’ve chased it through bootlogs, journalctl, etc. No change.

Any suggestions for how to sort this out?


When you get that login screen, see if you can login to Icewm (instead of to Plasma).

If that works, try rebooting, and see if you get an autologin to Icewm.

If both of those happen, then there is probably something in your user configuration that is causing the problem.

same behavior with Icewm…login screen, enter password, login screen returns. Ctrl-alt-F1 allows for terminal login,
WINDOWMANAGER=/usr/bin/startkde startx starts Plasma as expected.
Seems correct that this is a configuration issue, any ideas for where to look?

I did a diff between working new user account and failing existing account. Nothing obviously related to the login issue.

As far as I know, Icewm uses very little of that configuration. So you won’t need to look very deep.

It could be something in your shell startup file (probably “.bashrc” and “.profile”). You could try temporarily moving those to a subdirectory as a test. It could also be “.Xauthority”. You could just remove that (with your terminal login), and it will be recreated when needed.

Maybe also check that your home directory is owned by you and readable/writable by you.

.bashrc, .profile, .Xauthority moved to TEMPdir. Autologin worked. Thank you.

Now to find the offending content in those files.

Thanks again

Check ownership oof those files.They should not be owned by root!

No root ownership of these. The offending file was .bashrc, which had a command that no longer was valid. Resolved that issue and good as new.

Thanks for the help.

I’m glad it is now working for you. And thanks for reporting back.