Autologin and saving settings (Plasma)

I installed openSUSE with the Plasma desktop a few days ago. I enabled autologin since I had an encrypted disc. I logged out and selected Waylan at the login screen. Then I adjusted the display scaling. No matter how many times I tried, after a reboot, I was on X11 and scaling reverted to 100%. Is there any way to fix autologin so settings are saved? Settings are saved with no problem since I turned of autologin.

I do not use auto-login, but a logical approach looks to me:

  • Switch off auto-login
  • Login using Wayland so that Wayland is stored as the one to use for that user.
  • Switch on auto-login for that user.

I have done that but as soon as I turn on autologin, I’m on X11 and scaling is back to 100%

Did you make sure that wayland is chosen for autologin in systemsettings5?

Workspace-> Startup&Shutdown->Login Screen (SDDM)->Behaviour->with session “…Wayland”

I did not. I logged out to choose Wayland.

For autologin you need to set it in systemsettings5. There is a dedicated dropdown menu for it.

1 Like

Thanks. That seemed to work. I have a 4k monitor on this laptop. I should have gone with HD. I need 250% scaling to see everything properly with my bad eyes.