autofs nfs '-hosts' not working after update

After updating to autofs-5.0.8-19.8.1.x86_64, I find my NFS mounts are no longer available via autofs. I have two NFS shares on my network. Both can be mounted manually (mount -t nfs server:/path). Previously, both could also be accessed on /net using autofs (using the “/net -hosts” entry in auto.master). After the update, I now get “No such file or directory” under /net (on the client).

Also, I notice if I issue “service autofs status”, I get

Mar 19 21:53:37 gregpad automount[15428]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
Mar 19 21:53:37 gregpad systemd[1]: Started Automounts filesystems on demand.
Mar 19 21:53:39 gregpad automount[15428]: get_exports: lookup(hosts): exports lookup failed for naspad
Mar 19 21:53:39 gregpad automount[15428]: key “naspad” not found in map source(s).

(gregpad is the name of the client; naspad is the name of one of the servers which has an NFS share). I don’t know if this was happening before the update.

Currently, I have NIS (yp) installed but it’s not enabled. /etc/hosts lists the client and server, and this setup seems to work for other commands (e.g., mount, showmount).

Thanks in advance for your insight/ideas!

Any chance you tell us on which version of openSUSE?

This is opensuse version 13.1 (x86_64)

Are you using “Traditional” or “NetworkManager”?

Perhaps autofs comes up before the network.

Searching on google brought up this similar problem from an arch user:

The workaround suggested in that post worked: in auto.master, replaced ‘/net -hosts’ with
/net /etc/ --timeout=60

Not knowing much about autofs, I don’t know if there is a downside to using this workaround.

Hi Miuku, thanks for your reply. It’s using NetworkManager.

> Perhaps autofs comes up before the network.

I don’t get it (am out of my depth here regarding networking/services), can you elaborate? And, how could I check?

Well, you need to open bug report, otherwise it is not going to be fixed. Ironically, one problem this update was supposed to fix was with -host map …

This is just guesswork because I don’t use autofs myself but think about it like this; all services start in a certain order, it’s possible that autofs is starting before your computer has an IP or an active network interface, thus it tries to mount the drives but… no network.

Perhaps that’s why the time out works - the system waits for NetworkManager to get an ip and for the interfaces to come up.

But as I said, this is completely speculation and I haven’t actually looked at it.

I filed a bug report, per arvidjaar’s advice.