Autofs - local domain name not set


I have a problem connecting NAS disk according to your instructions here:
I use OpenSuse 13.2 64bit KDE

For the third night with the tormented, it took me a while to understand
how it works, and whenever I had thought that it must work no result. There is still mapped folder is empty.

If you use the manual mapping, it works without no problems. mount -t cifs //Diskstationn/video /home/darina/Videa -o username=Ales,password=mojeheslo,uid=1000,gid=100

The first problem was that my manual mapping worked only with the IP address, called NAS not, but I solved it by adding a name to the IP address in the hosts, then he worked the above link. Title I needed because of the above discussion, if I understand it correctly.

When it all now start the process and check the autofs, I see this error: Local domain name not set
A passed through her away can`t get. I think that because I’m not working, but I do not know how to get out. The entire listing is here:

autofs.service - Automounts filesystems on demand
Loaded: loaded (/usr/lib/systemd/system/autofs.service; enabled)
Active: active (running) since Sun 2015-01-11 09:05:30 CET; 3min 38s ago
Docs: man:automount(8)
Process: 1383 ExecStart=/usr/sbin/automount ${AUTOFS_OPTIONS} -p /var/run/ (code=exited, status=0/SUCCESS)
Main PID: 1396 (automount)
CGroup: /system.slice/autofs.service
`-1396 /usr/sbin/automount -p /var/run/

Jan 11 09:05:30 linux-yw6t automount[1396]: lookup_init:139: lookup(yp): map auto.master: Local domain name not set
Jan 11 09:05:30 linux-yw6t automount[1396]: [1B blob data]
Jan 11 09:05:30 linux-yw6t automount[1396]: [1B blob data]
Jan 11 09:05:30 linux-yw6t automount[1396]: [1B blob data]

Nothing would be wrong in auto.master I found, after all there is to add only one line
what and where to be mapped. :frowning:
Can you please advise me why I do not work?

Here I send my check for modified files.…uo5jHJD2a?dl=0

I’m not part of the domain. I have a PC connected to the modem, as well as the Synology NAS. Modem is a DHCP server, which distributes IP addresses.
For NAS Synology I have a fixed IP address and I set the shared directory, which in Windows normally, mount in Ubuntu and its clones also without a problem (there again I have other problems - hair net, dysfunctional 5.1 sound, so I now openSUSE), where again I can not **** such as playing movies from NAS. Mapped via SMB it is easy, but unfortunately, it does not play movies. VLC is a mistake: "VLC is unable to open the MRL 'I film copy from NAS to hangout (it can be used without any problems) and then play it goes. But that’s not the solution. Functional mapping through the terminal I can now also, but to make it functional and automatically at system startup I can not. As already seen, network folder is protected by a username and password.

Thanks so much for your help, I really do not know your advice.

Sorry for English, English can not I use Google translator, but I hope you understand my problem.



I found that if I delete + auto.master, bug local domain not found disappears.
Unfortunately, there is still mapped folder "/ home / Darina / Videos’ still empty.

I tried

auto.master file content is:
/home/darina/Videa /etc/auto.cifs --timeout=60**

auto.cifs file contents is:
**Diskstationn -fstype=cifs,nounix,noexec,username=Ales,password=mojeheslo,uid=1000,gid=100 ://Diskstationn/video
And even that did not go through, still the folder /home/Darina/Videa is empty. :frowning:

In doing so, this notation for handheld mapping works beautifully:
**mount -t cifs //Diskstationn/video /home/darina/Videa -o username=Ales,password=mojeheslo,uid=1000,gid=100
Any idea why it does not work, where am I missing, what am I doing wrong?

I just solved it via fstab mount. :slight_smile:
//Diskstationn/video /home/darina/Videa cifs username=Ales,password=mojeheslo,_netdev 0 0

probably wise to have a credentials file for your username/password

mkdir /secure_dir
cmod 700 /secure_dir
chown root /secure_dir
and then in fstab

//Diskstationn/video /home/darina/Videa cifs credentials=/path/to/credentials/file,_netdev 0 0

If your the only user on the system then shouldnt be much of a problem :stuck_out_tongue:

Thanks for the tip, I’ll try.