Autodesk Maya 2014 - libssl.so.10 error

Hello to everyone who reads this post in the opensuse community.

I’m facing problems with Maya 2014 on opensuse 12.3 ( 64-Bit)

I’d installed Maya 2012 and it lanched fine except that when I opened some works it did’nt showed up every polygon so I decided to go to the autodesk page and get Maya 2014.

Now the problem is that I can not get to install it because of this :

michael@linux-3qos:~> maya
/usr/autodesk/maya2014-x64/bin/maya.bin: error while loading shared libraries: libssl.so.10: cannot open shared object file: No such file or directory

  • If theres a solution like a symlink or soft link or whatever they call it I will appreciate it. I was a Mac user but have some attraction to linux and if I can get Maya, 3DCoat and Blender working very stable I can begin developing games and graphics for the linux world. Thanks in advance.

It’s Maya 2014 that I’m trying to install. Maya 2012 installs and starts fine except for opening files that gives me problems.

But Maya 2014 can’t be launched because of the libssl.so.10

I wish I could launch the darn thing…

Hello and welcome here.

You say you installed Maya. But as I can not find Maya in the standard repos, you most probably do not have it installed in the openSUSE standard way (YaST and/or zypper from the standard repos). Thus it would be nice not to let people here guess and search on what you did, but provide information on where you found it, in what form and what you did to install it.

There is no libssl.so.10 on openSUSE AFAIK.

But you could try to symlink it to libssl.so.1.0.0:

sudo ln -s /lib64/libssl.so.1.0.0 /lib64/libssl.so.10

or, if Maya is a 32bit app:

sudo ln -s /lib/libssl.so.1.0.0 /lib/libssl.so.10

Maybe it runs then…

Hey mjapox, welcome here.

Game development on linux, very nice !. Blender is available as a part of the distro. About the symlinks: I wouldn’t know any other solution than the one provided.

The symlinks should work, since libssl.so.10 is part of openssl-1.0.0/1.0.1 on Fedora, see here: libssl.so.10()(64bit RPM DEB Download
But on openSUSE openssl-1.0.0 (libopenssl1_0_0 is the exact package name, version 1.0.1e on 12.3) only contains libssl.so.1.0.0

So those two should be the same, just with different names. (the Maya package seems to be for Fedora)

Maya is a commercial 3D Imaging and Animation program. My guess is that it will never appear in the repos, unless openSUSE goes bonkers and starts “one-clicks-with-payment” :smiley:

rotfl! Great!! Thank You so much for the replies.

  • Here’s what’s happening, I’m a Full Sail University Student. So every work has to be donde in Maya because of the Maya Binaries. We import then everything done in Autodesk Maya to Mudbox, 3D-Coat and Zbrush. We also use Blender but, Blender does’nt provide MEL (Maya Embedded Language) Scripting.

How you can get the software and a legit license? Easy

  1. Click this link to download the software with the manual and additional packages:

http://trial.autodesk.com/SWDLDNET3/2014/MAYA/ESD/Autodesk_Maya_2014_English_Linux_64bit.tgz

  1. You can get your license from their student page at Autodesk Education Community

  2. Register and choose Autodesk Maya 2014 and either choose Windows or Mac OS X. Either license will work with Linux.

  3. Follow the Manual that came along with the Autodesk Maya and let me know how your libraries are working.

-:stuck_out_tongue: Please, if anyones get’s this to work, We, not me only, but the studio will be very happy to migrate completely to opensuse. We need to get rid of Microsoft’s Windows operating system.

We are looking forward for SuseCon this year.

I will reply later to let you know how the symlinks provided worked. I’m on way to my computer to test it out and will be replying once I’ve tested it.

Hope it works.

How I got running “Autodesk Maya 2014” inside Opensuse 12.3 64-Bit today !

First you need to know that for 12.3 you will need the following libraries :

libpng12.so.0
libtiff.so.3
Symlink of libssl.so.10 to libssl.so.1.0.0
libcrypto.so.10

I’ve uploaded those libraries to my Google Drive to make the setup easier for me and others in the community.

Here’s the link to the libraries : https://docs.google.com/file/d/0B-CK43cIim3pUlppeS1tV3FkcXc/edit?usp=sharing

Fire up the terminal. For this example I will be using “michael” as the user. Supposing the Autodesk Maya2014 is in your Documents, first we will “su -” command for root permission :

su -

password: ( then input your password )

Then we will have to navigate to the where the Maya installation folder is with the “cd” command :

  cd /home/michael/Documents/Autodesk_Maya_2014_English_Linux_64bit

Then we will make the setup run with the “./” command like this :

./setup 

You should have your autodesk license from the http://students.autodesk.com/ web site and continue with the full installation.

After every library has been installed along with the maya setup itself you should will type inside the terminal:

maya

It should activate online and open application.

Now, here’s the catch…

I did that sort of tutorial post so that everyone can install Autodesk Maya2014 on they’re systems and tell me if it crashes after launching.

The application opens with a pop-up that I know it’s normal because it’s a student version and once you press the Continue button it crashes.

The terminal shows this :

maya encountered a fatal error

Signal: 11 (Unknown Signal)
Fatal Error. Attempting to save in /tmp/michael.20130602.1700.ma
QWidget::setWindowModified: The window title does not contain a ’
[li]’ placeholder[/li]

Please if anyone gets around this let me know.

My computer specs are:

Asrock H55M-LE
Core i7 870
8GB DDR3 1600mhz
Nvidia GTX 550 ti

  • Note* On this machine I swap hard drives and I have Autodesk Maya 2014 installed on Windows and it runs. After making the Opensuse instalation on the new HDD I just installed, all I did was update the system and install the nvidia drivers. I will try with the default nouveau drivers and post back on the results.

Some comments:

That’s included in openSUSE, the package is called “libpng12”. You should use that.

libtiff.so.3

There is a libtiff3 package available for openSUSE 12.3 here:
software.opensuse.org: Install package graphics / tiff3

Symlink of libssl.so.10 to libssl.so.1.0.0
libcrypto.so.10

libcrypto is also part of openssl, so you should also try to symlink it like libssl:

sudo ln -s /lib64/libcrypto.so.1.0.0 /lib64/libcrypto.so.10

Where did you get those libraries from? Maybe they cause the crash.
Not sure if doing the above helps though, but it could.

And according to the message you posted, apparently some debug information got saved to /tmp/michael.20130602.1700.ma.
Could you upload that file to SUSE Paste or similar and post a link?

The output indicates something could not be writen to /tmp. Since you installed the NVIDIA drivers, make your user a member of the “video” group. Check the permissions of /tmp.

I’m using KDE and can see that I’ve got the arrows too. Perhaps I should have suggested using KDE as a sixth option :).

libpng12.so.0
libjpeg62-62.0.0-15.5.1.x86_64.rpm
libtiff.so.3
Symlink of libssl.so.10 to libssl.so.1.0.0
libcrypto.so.10

I did a fresh install and re-confirmed libraries needed for anyone that wants to try Maya out and run it. Just double click them and Yast will install those for you or you can use the terminal with the “rpm -i” command to install.

OK, I will try that out.

OK, I will upload it in a few minutes.

Thank You So much wolfi323 and Knurpht.

I did what Knurpht told me to and it worked.

I want to let you know that I posted the same problem to the Autodesk Area incase anyone else comes around with the same problem with snapshots.

Here’s the link : Area :: Discussions

To solve the last problem I did what Knurpht mentioned

I went to Yast Control Center -> Security and Users -> User and Group Managment

Then double click the user and click the Details tab and check the " Video " box at the Additional Groups Section and click OK.

Once Again Thank So much.

Well, actually this shouldn’t be necessary anymore.
Could you please post the output of:

ls /dev/nvidia*

Background: The current systemd package makes sure the user can access /dev/nvidiactl and /dev/nvidia0, so you shouldn’t need to be in the video group anymore.
But it is possible that your card is at /dev/nvidia1 or higher.
Testing packages have been created that should fix this as well in that case, but so far nobody has tested them who has /dev/nvidia1 or higher.
So it would be great if you could test them if that’s the case!

:XHow do I test this? I’m finding my way around Linux still so some stuff are not known to me.

I just use my instincts! :Pjaja!!

I did that code on the terminal and this is what I got :

https://docs.google.com/file/d/0B-CK43cIim3pSEJhTFRXOEc2ZGc/edit

  • I also want to tell you that Iḿ very happy now with my OpenSuse Computer. As you can see in the above link, every software needed for CGI and Game Development is running at itś best. I did some benchmark and compared to Windows Direct X11 it wins the race. I also have a MacBook Pro Late 2011 and with this computer now set-up with Houdini server it really is a blast to work in the studio enviroment! That’s my status of hapyness jaja! rotfl!