auto (pam) mounting AD home folders / simple AD login


I’m testing out opensuse’s (11.1 i686 GNOME) AD integration features as I’d like to have Linux used in our school outside of the server room but I need a fully-working prototype before that can happen. After a significant bit of wrestling with Yast and various config files I now have AD login/ authentication working but I’ve been unable to get AD users home folders to auto-mount correctly.

Under Yast/ Windows Domain Membership/ Expert settings I have left the UID/GID and WINS options at their default values as I don’t think they’re relevant to what I’m trying to do but I added an entry to the ‘Mount Server Directories’ list with these values:

Server Name: server (I’m presuming I could put any name in here or must it match the DC’s DNS/ realm name?)

Remote Path: //

Mount Point: /home/SERVER/%(DOMAIN_USER)

Options: user=%(DOMAIN_USER) (The default)

User Name: (Left Blank as I want home folder mounted for all users that log in, right?)

I have noticed that even if I uncheck ‘Create Home Directory on Login’ a home folder gets created under /home/SERVER/%username anyway and so thats why I have used ‘/home/SERVER/%(DOMAIN_USER)’ for the mount point even though I’d rather just use /home/%username as the local mount point. Can I do that instead?

If I log in as an AD domain user then I open nautilus and go to ‘smb://’ I can see all the home folders and I know pam is mostly working as I can access files with my users home folder but not other users but this folder isn’t being auto-mounted under /home/SERVER/%(DOMAIN_USER). Any ideas?

Finally, after having added the suse box to the domain I get an extra drop-down on the gdm login screen that lets me choose if I want to log in locally or to the AD domain. However, it doesn’t matter whether I choose local login or domain login from this menu as I still have to login like ‘server\user’ for the username. I would like it if users had no need to prefix their user name with the domain name when logging in at all or at least no need to do so when they choose the domain from the menu. Can this be done?


If there’s any more info or settings I’ve used that anyone might need to know to diagnose my problem I’ll gladly provide that info to get this resolved. I forgot to mention that I have disabled the suse firewall whilst I was joining the domain and trying to get the home folders to automount.

Once I have this working my intention is to write a super-easy to follow guide for the opensuse wiki on how to achieve this which will take the user step-by-step from a fresh opensuse install to joining an AD domain with users home folders auto-mounted.

I think that the lack of such an ‘idiots-guide’ to this process is a major reason why we’re not seeing a higher number of Linux (suse) machines as members of the worlds still mainly Windows dominated networks. As you all know, most MS admins know little or no Linux arcana and are unwilling or unable to spend hours reading multiple (massive) man pages to get this going. I have previously wrote the user guide for the JackLab Audio Distribution, which is now part of the opensuse wiki.

I have also tried these, more straightforward settings:

Server Name: (Again, I’m presuming I could put any name in here or must it match the DC’s DNS/ realm name?)

Remote Path:


Mount Point:



user=%(DOMAIN_USER) (The default)

User Name:


If I’m setting up automounting a share on a per user basis as in this example, should I prefix the username (test) with the domain ie server est here or not?

Using these settings I get the same result as trying to use the username variable as used in my original example settings in that if I log in as server est then I open nautilus and go to ‘smb://’ I can access files within // and not other users but again this folder isn’t being auto-mounted under /home/SERVER/test.

I’m presuming this is a YasT/pam problem and not samba mis-config or an incorrect setting on my w2k3r2 server?

I have same problem, when I specify Mount Server Directories in Yast. After reboot Mount Server Directories are empty…and no shares are mounted… I use opensuse 11.2

Any help?


Good news! We now have automounting of AD home folders 95% working, I could just do with some help or advice in getting the final step sorted so that it works as we desire. Once we have this fully working we should get it documented on the opensuse wiki as obviously Novell can’t be bothered explaining to us how this is supposed to work.

My problem previously was that I didn’t know what to plug into the Yast/ Windows Domain Membership/ Expert settings as its largely undocumented but I now have a much better idea:

Server Name = IP address of AD server

Remote Path = smb share name of share containing users home folders

Local Mount Point = /mnt

Options = user=%(DOMAIN_USER)

User Name = leave this blank

By using the above settings I can log on to the domain and the AD smb share gets mounted under /mnt and I am also able to access the AD users home folder within that and only the logged in users but thats my current problem- I don’t want to see every single AD users shared drive under /mnt and have to navigate to the correct folder, I just want that users personal folder to be mapped directly to /mnt or whereever I specify as the local mount point instead of the root of the smb share. Anyone know how to achieve this final step as cleanly, easily and elegantly as poss?

Very nearly there now!

A couple of remarks:

  • I would never use /mnt for mounting network user folders, mount them in /home/USERNAME instead.
  • There’s simply not enough information in your posts to help you.

Please give more info about the whole contruction


I don’t understand what difference it would make where I mount the share- I would’ve thought the only only thing that mattered is that you don’t mount it in a dir that may conflict with an existing mountpoint. I can’t see mounting it under /$randomdir making any difference- in fact I’ve already tried mounting under /home, /home/USERNAME, /home/%(DOMAIN_USER) and a host of other variations and its not helped.

Have you got this working yourself? What else do you need me to tell you?