Auto mute on EeePC 1201T does not workH

Hi there,

was trying to disable the internal speaker of my ASUS EeePC 1201T when pluggin in headphones without success. I have read many topics here about this and none has helped yet.

According to ‘lspci’ I have a

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

And here’s the contents of /proc/asound/pcm

00-00: ALC269 Analog : ALC269 Analog : playback 1 : capture 1

So I looked in for a match and I found one. These are

  basic		Basic preset
  quanta	Quanta FL1
  laptop-amic	Laptops with analog-mic input
  laptop-dmic	Laptops with digital-mic input
  fujitsu	FSC Amilo
  lifebook	Fujitsu Lifebook S6420
  auto		auto-config reading BIOS (default)

Since kmix only says that I have a “analog” output I set model to “laptop-amic” but again without success. Now I don’t know what to try.

Any suggestions?

Something I have found out, that I was able to select the output device and set it to headphones. But open the systemsettings and changing it seems to be a bit odd.

Thats a good start. You need to restart alsa after applying that setting.

If it does not work, keep trying each of those options one by one, restarting alsa and testing after each (stopping only if you get one to work, or after you have tried all).

If you wish more suggestions you need to provide more information.

What is the output web/internet address provided at the end when running the diagnostic script (with asus connected to the Internet) :


be certain to select the share upload option.

Also, what is the output of:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
uname -a

Thanks for your answer!

It works now. I changed mode to “auto”. First it didn’t change anything. But after re-login into KDE it worked.

Thank you. :slight_smile:

Congratulations on getting this to work.

And thank you for sharing your solution for your ASUS EeePC 1201T auto mute.