Auto Mounting partitions on boot hd

So I’m starting a new topic as I should have and apologize for any confusion, so my previous post here I asked about auto mounting, let me explain my situation.

This is a fresh 12.1 install w/Gnome 3/64 bit on a notebook with 1 primary internal sata hd, and the partitions I want automounted is on what I assume is hd0. There are several different partitions that I want automounted that are on the same hd, and after checking fstab and going through yast and such I’m not really sure how to proceed. When I boot/restart I go to file manager and see the drive isnt mounted by right clicking, so if I just click it it tries to mount, and asks for a password, so I know it isnt automounted…

I tried enabling a couple services like autofs for example and something for gnome fallback mode but none of that got me anywhere, and I will gladly list them again as I think I need to go in and disable them for now anyways.

If I connect a usb drive before during or after boot time, it auto mounts properly, so I assume automounting is entirely possible, even though that probably doesnt relate to my problem.

What should I run to post the layout of my drive?

Please open a terminal and post the result of the following

cat /etc/fstab
su -
fdisk -l

Tell which of the partitions in the fdisk output you want automounted.

> cat /etc/fstab
/dev/disk/by-id/ata-ST95005620AS_5YX0A613-part5 swap                 swap       defaults              0 0
UUID=7c123884-0518-4472-891a-188bdf036212 /                    btrfs      defaults              1 1
/dev/disk/by-id/ata-ST95005620AS_5YX0A613-part7 /boot                ext4       acl,user_xattr        1 2
UUID=77c064c7-6079-4494-99f6-dab5460dcfac /home                btrfs      defaults              1 2
/dev/disk/by-id/ata-ST95005620AS_5YX0A613-part4 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf6f6f6f6

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    29296639    14647296   83  Linux
/dev/sda2   *   706458375   976768064   135154845    5  Extended
/dev/sda3        37488640   604037119   283274240   83  Linux
/dev/sda4       604037120   706451455    51207168    7  HPFS/NTFS/exFAT
/dev/sda5       714860433   723262364     4200966   82  Linux swap / Solaris
/dev/sda6       723262428   739648664     8193118+  83  Linux
/dev/sda7       739649536   739969023      159744   83  Linux
/dev/sda8       739971072   823861247    41945088   83  Linux
/dev/sda9       823863296   976766975    76451840   83  Linux

Partition table entries are not in disk order

For now the one I need most is sda3 which if ext4 if it matters:
/dev/sda3 37488640 604037119 283274240 83 Linux

If I knew right off how to pull up the uuid I’d post it here, but I have to learn that. In the mean time I was wondering if “Partition table entries are not in disk order” had any valuable meaning in terms of boot speed/disk performance and if I might be better off starting over so I can create a new layout, but that will have to wait regardless.

You do know that all you have to do is click on the device in file manager and after entering your password it’s mounted?

OK. You need to create a mount point in the root tree
Become su -
And do this

cd /
mkdir /myfiles

But you can add this line to fstab

/dev/sda3  /myfiles ext4       acl,user_xattr        1 2
chown <yourusername> /myfiles

Hi, thanks for your response. I totally realize I can just enter the password, even from file manager as I mentioned above, but that’s the problem. I had become accustomed to ubuntu automounting everything by default, and if I don’t click the drive and enter my password FIRST in file manager or devices etc, I have to let my media player rescan 30+ thousand tracks, every single time, so I would prefer to have it auto mounted.

I’ll do as you suggested and post back with my results, and thank you, deeply, for your assistance.

Hi I wanted to say thanks again. This has already saved me a lot of trouble, and your tutorial was an excellent plus.

Your tutorial mentions partitions being created in /media sometimes, and I was wondering if I were to set a /media/sda3 for example, would this make the device appear in ‘devices’ in the file manager as it does when it isn’t auto mounted, like the other partitions do?

It’s not a big deal as I already created a bookmark so I just see it, but I was wondering what the difference is/other ways of auto mounting, for example in gnome 2/ubuntu it auto mounted automatically and the partition would appear just like any other device, if that makes sense, but it’s just a ‘looks’ thing.

Is usually best reserved for automounts, Eg: USB flash drives and the like.

Typically a partition like this should not be set to be auto mounted by the installer, when you install the system. If Ubuntu does this, I’m surprised.
I know in Mint the device would be in the Places part of Nautilus, but you still need to enter a password to have access.

If it’s working now, I would leave it

Is it possible that in Mint gnome-keyring is responsible for not needing a password to auto mount?

Is the keyring used in suse 12.1?, if I installed the gui for it(forgot the name) perhaps I could play around.

The outcome I had wished for is achieved, I just have a feeling this will be confronted sometime soon as OpenSUSE is gaining popularity.

It’s not that Mint doesn’t require a password. It does. Same as SUSE. (It’s just you mentioned Ubuntu as not requiring)
Once you add them in fstab, it’s completely different.

Advice is. Don’t fiddle.

Not to be a stickler but I mentioned Ubuntu, and in essence I meant Mint, as I never directly used Ubuntu, so I was only refering to Mint not requiring it, which I could very well prove. I used mint for 2 years, and decided to switch to SUSE. Sorry for that confusion.

The question isn’t weather mint CAN, it was why does it, as I know for a fact my install of mint doesn’t require me to do anything BUT it could be directly related to the following change I made,

first entering a password into the keyring, and then setting the keyring password to BLANK.

SO, could it be possible to achieve that result in suse, by setting gnome-keyring to blank, even if totally unadvised?

As this would also give the desired result, but I also wonder how the keyring is handled in suse in general.