Auto-mount Windows Partition

See post #17, follow it as I suggested.

Well, FAT/NTFS partitions don’t store any Linux user info, so you have to tell the system via mount options who the owner is.
With the default mount options (see the fstab line I posted earlier), all files/folders should be owned by root, but have rwx permissions for all users.

Again, this has nothing to do with where the mount point is located. Otherwise it wouldn’t work for ext either, don’t you think? :wink:

But you’re right that YaST uses a fmask/dmask that would only allow read access for users. Sorry, I somehow thought it has been changed in 13.1.
Well, just click on “Fstab Options…” and clear the “Arbitrary Option Value” text field (or at least remove/change the fmask and dmask options there), and you get the default options (with read/write access for all users).

yes, /tmp is in the root directory of the drive, so you should be okay. The path should be /tmp and the path you are creating would be /tmp/***yourlabel

Just start by following the directions as I posted. If the multiple mounts you have created cause any conflicts, we will sort it out after we see the results.

Thank you. But when mounting as indicated there is the same error -3002. Should I continue anyway or abort?

Configure it to not be mounted first, then click OK and leave YaST.
Then try to configure it again.

In your case, YaST mounted it to /usr/local/ (which you shouldn’t really do in your case as that is a system directory) and /windows/C which caused the latter one to fail.
And maybe check /etc/fstab and remove the entry manually.

Yes, but (without looking first) I presume those options are different for NTFS than for native linux partitions. I do know I have to mount with the ntfs-3g line in some special occasions, such as this:

mount -t ntfs-3g /dev/sdb2 /usr/00_mount

Yes. You are currently getting conflicting mounts. Try what wolfi suggests (ie: not mounted), and if that doesn’t work, look in /etc/fstab and remove any lines that refer to that partition.

Then, try again.

Thank you! Now YaST does its thing and no error message, will now reboot and see if it mounts.

Once again thank you all for your help, every day I like the openSUSE community even more.

Bad news guys, I still get problems on startup and can’t edit /etc/fstab, how can I edit it as root?

EDIT: managed to open KWrite as root from terminal, I start to like the CLI…

Yes. As I said, ext partitions do contain all necessary informations about the file owner and Linux permissions, so setting those options is not reasonable.

I just checked, and YaST uses this by default for an NTFS partition:


You would have to change those fmask and dmask values (use f.e. fmask=113 and dmask=002) to give write access to users.
Or simply remove all of that, the default mount options are good enough and give full permissions to all users.

I do know I have to mount with the ntfs-3g line in some special occasions, such as this:

mount -t ntfs-3g /dev/sdb2 /usr/00_mount

You have to use the “ntfs-3g” filesystem, as only this one implements full write support.

The in-kernel “ntfs” filesystem only supports reading.
It does have experimental write support, but nowadays with ntfs-3g you really should not use it any more.

  • This is a complete rewrite of the NTFS driver that used to be in the 2.4 and earlier kernels. This new driver implements NTFS read support and is
    functionally equivalent to the old ntfs driver and it also implements limited
    write support. The biggest limitation at present is that files/directories
    cannot be created or deleted. See below for the list of write features that
    are so far supported. Another limitation is that writing to compressed files
    is not implemented at all. Also, neither read nor write access to encrypted
    files is so far implemented.

By using his User account to create a directory in /tmp (I chose that location, because it was the only place outside of /home that I found, at least in as short a time as I could, that the User could create a directory without going through a lot of hoops), his User owns the directory and the permissions.

Mounting an NTFS in there, those permissions cascade through the subfolders.

This allows him, and not other users (in case there are other users he doesn’t want to change things in the NTFS directory), to manipulate the directories and files in that partition.

If he wants to give everyone the full permissions, he merely would need to create the directory in any of a number of places as root, then issue:

chmod 777 -R directoryname

and those would be the cascading rights.

You have to run a text editor as root, by using kdesu, gnomesu or sudo.

kdesu kwrite /etc/fstab

You could also run a file manager as root and open it from there.
In KDE you already have an entry in the K-menu for that: System->File Management->Dolphin (Super-user mode)

Menu => System => Terminal => Terminal - Super User Mode

No, they don’t.
The mount point’s permissions have nothing to do with the permissions of the actual files/folders in the partitions.

The user who mounts the partition has to have access to the mount point though, but when automounting on boot that is root anyway.

If he wants to give everyone the full permissions, he merely would need to create the directory in any of a number of places as root, then issue:

chmod 777 -R directoryname

and those would be the cascading rights.

No, as I wrote already, NTFS doesn’t have any idea about Linux user names and permissions.

PS: A showcase:

wolfi@amiga:/> sudo umount /windows/C
wolfi@amiga:/> cd /windows/C
wolfi@amiga:/windows/C> ls -ld
drwxrwxrwx 2 root root 48  8. Dez 2011  .
wolfi@amiga:/windows/C> sudo chmod -rwx .
chmod: .: new permissions are ----w--w-, not ---------
wolfi@amiga:/windows/C> ls -ld           
ls: cannot access .: Permission denied
wolfi@amiga:/windows/C> cd ..
wolfi@amiga:/windows> ll
total 0
d----w--w- 2 root root 48  8. Dez 2011  C
wolfi@amiga:/windows> sudo mount /windows/C
wolfi@amiga:/windows> ll
total 40
drwxrwxrwx 1 root root 40960 18. Apr 14:38 C

Well that’s much more elegant than what I did:


And then manually selecting the file from the KWrite window.

So I’ll stick to what you suggest if I have to edit text files as root.

Now rebooting, will keep you informed.

I stand corrected. Thanks.:shame:

I have always mounted my NTFS partitions manually after logging in, using Dolphin. I also unmount NTFS partitions that way.

For some reason, I do not like having my NTFS partitions mounted full time. That is why I am having some confusion with it.

In that case KDE (well, udisks2 actually) sets the mount options accordingly.
You can type “mount” in a terminal window to see the actual mount options used.

But if there is an entry in the fstab, this is respected also by udisks2.

Well guys this has been an unmitigated disaster. Not only was I unable to mount the new partition, but in fact I screwed something up and couldn’t even access as user. Some problem with mounting the / partition (sda5).

So right now I am formatting my / partition and reinstalling openSUSE.Will have to redo all the hacks required to configure it as I like, but that way I will remember them better and learn them well. Thank you very much for your help anyway.

You could boot from the installation medium and enter Rescue mode, or add “init=/bin/sh” to the boot options (press ‘e’ at the boot menu, search for a line starting with “linux”, append that and press ‘F10’ to boot.

You could then fix your /etc/fstab to make the boot working again. Just put back in there what you posted before.


Looking at the thread, though, it does get confusing, and my own mixup on a couple things did not help.>:(

But, before taking such a drastic action, you could have come told us and waited to see if we agreed you should do that, and wolfi’s response might have been good enough to get it all back.

However, on the bright side, the more times you install and work with things like this, the less problems you will have in the future. :\