AUTO Login help

I have test machines that boot to RunLevel 3. I need to run a script, and am considering auto-logon. The auto-logon option with in yast2 users only effects the GUI logon.

Is there a way to auto logon to a command line console while in init 3?


Be warned that I haven’t personally tried this myself, but theoretically, it should work. Back up inittab before proceeding (and anyone here who knows a better way, jump right in).

In /etc/inittab, locate the line:

1:2345:respawn:/sbin/mingetty --noclear tty1

Change it to

1:2345:respawn:/sbin/mingetty --autologin <username> tty1

Make sure that you’ve already set the default runlevel to 3 (CLI, instead of graphical). See “man mingetty” for more info.

I will give it a shot and let you know how it worked. Thanks for the advice.


Failed. There is no option for autologin. Looked at MAN Pages.

Any other Ideas?


What version of SuSE are you running? When I enter “man mingetty” in a terminal, I get a list of all options, one of which is “-- autologin.”

Incidentally, I just tried it on my Opensuse 11.1 installation, on my laptop, for tty4 (virtual terminal 4). I used

1:2345:respawn:/sbin/mingetty --autologin stephen tty4

… and it worked just fine. After rebooting, when I entered “CTRL-ALT-F4,” I was already logged in to that terminal.

Now, I realize that’s not the same as booting into CLI mode, but it shows that the arguments are at least correct.

This on a SLES (SuSE Linux Enterprise Server) 64 bit system. The odd thing, I looked a my MAN page for OpenSuSE 11.1, and saw the same thing you did. And it worked. But for SLES, its not. In a way I can understand for security reasons, but I need it.

I think I am back to playing with the RC Scripts. Just means more complexity to my process.


Try one more thing: open up your inittab and see what getty is being used (agetty, maybe?). There should be a man page for that.

4:2345:/sbin/mingetty --autologin <username> tty4
i tried ,but i didnot got theb answer.
this code working only 64 bit…,my o.s is 32 bit…
give me the replay…

thank’s you