"Authentication is required to refresh the system resources",

hi all:

i have 13.2 and recently start getting this annoying pop message “Authentication is required to refresh the system resources” and asking for root password. it seems to be requested by a package called “The PackageKit Project” and it had been discussed in this forum: < https://forums.opensuse.org/showthread.php/487442-Authentication-is-required >. from that discussion, supposedly the bug had been supposedly fixed, it seems the bug creep back somehow.

user@host:~> egrep “(SECURITY|POLKIT_DEFAULT_PRIVS)” /etc/sysconfig/security



user@host:~> grep system-sources-refresh /etc/polkit*
grep: /etc/polkit-1: Is a directory
/etc/polkit-default-privs.restrictive:org.freedesktop.packagekit.system-sources-refresh auth_admin_keep_always
/etc/polkit-default-privs.standard:org.freedesktop.packagekit.system-sources-refresh auth_admin_keep_always:no:yes

user@host:~> sudo grep -RA1 system-sources-refresh /etc/polkit-1/
/etc/polkit-1/rules.d/90-default-privs.rules: ‘org.freedesktop.packagekit.system-sources-refresh’:
/etc/polkit-1/rules.d/90-default-privs.rules- ‘auth_admin_keep’, ‘no’, ‘yes’ ],

user@host:~> loginctl
2 1000 mlu
3 1000 mlu

2 sessions listed.

user@host:~> pkaction --action-id org.freedesktop.packagekit.system-sources-refresh --verbose
description: Refresh system sources
message: Authentication is required to refresh the system sources
vendor: The PackageKit Project
vendor_url: http://www.packagekit.org/
icon: package-x-generic
implicit any: auth_admin
implicit inactive: auth_admin
implicit active: yes


No, that bug should be fixed. And your polkit rules/security settings are ok as well.

But your user session seems not to be registered with logind, causing missing permissions.
What does “loginctl” say?

Let me guess: you are using autofs, right?
Logout and login again, and the issue should not happen again.
Or wait a few seconds before logging in the first time.

There is a problem with autofs.service delaying the start of systemd-logind, so it is not ready when you first login and the session cannot be registered.
Removing the line “Before=systemd-logind” in /usr/lib/systemd/system/autofs.service should “fix” it.


well, as far as i know of, my system uses the default file system (btrfs).

this popout only happens when i login via remote desktop, not on local machine.

That’s irrelevant here.
I was not talking about any particular file system anyway.

autofs is a system service that allows you to automatically mount stuff (including remote folders, removeable media, and so on).
But enabling it can lead to those problems at the moment.

this popout only happens when i login via remote desktop, not on local machine.

This is no bug then. These are the default security settings.

If you are logged in via remote desktop, you do not have the permissions to refresh the software repositories, install updates, or even mount removable media.
Only a user logged in locally may do that.

A workaround would be to override the security settings and allow that specifically in /etc/polkit-default-privs.local:

org.freedesktop.packagekit.system-sources-refresh yes

Or disable “Apper Monitor” in “Configure Desktop”->Startup and Shutdown->Service Management to get rid of those messages.

thanks. that worked very well.