Ok so Im somewhat new to Linux and new to this forum…

Im currently trying to let Windows 2003 and Suse 10.3 work with the same user database (the Windows active directroy). To realise this Im working with the help of the following document:

I can edit the needed config files, I can join the domain using the net ads join command etc. All working well.

The trouble starts when I have to “configure PAM to use Kerberos first and local accounts seccond”
In this document I follow they use the command authconfig (bash authconfig --enablekrb5 --update). When I try this I get the error "command authconfig not found.

Now in this document they use Fedora Core 5, so this is probably the problem. As I am determined to use Suse 10.3 I started google-ing my issue. Sadly, I cant find any satisfying solution.

So my question to you is:
How do I configure PAM so that it will use Kerberos first instead of local accounts?

A reply would be realy apriciated, an answer would be **** awsome. Anyway thanks for your time :slight_smile:


A warm welcome here !!

Could it be ‘pam-config’ ? On 11.2 it looks like it is. Do a ‘man pam-config’ to see if it is what you’re looking for, it has a ‘–krb5’ option. Just a guess.

authconfig is a RHEL and Fedora thing. It manipulates pam modules and nssswitch.conf. I don’t know of an equivalent tool off the top of my head. Maybe YaST can do it?