August 26 update breaks networking

To end my part of the story (hopefully), I switched back to network manager and reboot: still working. I then updated kernel-firmware and reboot: seems still OK. So my conclusion is I don’t understand, but it works. If usefull, I could try to downgrade the updated packages and see if the problem occurs again after updating. Let me know.


the parameters in my reply were exactly as specified by lwfinger

I tried this but yast says I am using network manager, and network manager has no settings for ifup.

Now every thing is working with the latest kernel-firmware, so go figure?

In Yast/Network devices/network setting, yast first says
*Network is currently controlled by NetworkManager and its settings
cannot be edited by YaST.

To edit the settings, use the NetworkManager connection editor or
switch the network setup method to Traditional with ifup.*

Then, after presssing OK, you can choose the network setup method in “global settings”, either network manager or traditional. I ticked the latter and then the problem was solved. Maybe one of the updates disabled some configurations wrt DNS (but why, I don’t know) and it was reset by changing to traditional and then back to network manager. Anyway, everything works fine for me as well now. I learned at least one thing : backup system before updates to avoid blindness.


I installed the upgrade at 0827. Did found out that I had problem at my main server and no network to I-net but I fixed it the next day.

Worst was that I also run the update on my VM- web/mailserver and I dident see it until this morning, internial Lan worked but not i-net… Works fine after a zypper dup today. I learn something again :).


Did you notice if YAST had created a new network adapter, so you had two of them and the other one was unconfigured? (That’s not really even a word but eh… )


After the update today nic’s:
On my main server lo, eth0 and eth1
On my VM, lo, eth0 and eth1
On my main DE lo, enp3S0

What I didn’t write was on my main DE (run the update there as well) that my connection to my Brother MFC7360N was lost/deleted !!! The Connection to a HP G85 Officejet with jetdirect worked a-ok.

Anyway problem is solved (I hope :)).