audio/video problem at vlc/kaffeine/smplayer

hi again

the problem now are:

1-when i open smplayer, i have sound, but no video: its a transparent window with the player logo, but the file is running

2-i try the same thing at vlc: the first time it works wonderfully; then, if i open another file (in any way) it gives video, but no sound at all and the message “Potential ALSA version problem:
VLC failed to initialize your sound output device (if any).
Please update alsa-lib to version 1.0.24 or higher to try to fix this issue.”; it gives another error messages at the konsole, i can put them here if it helps
i tried to update the alsa-lib but didn’t found it

3-after these i tried the same files at kaffeine: the player just didn’t open them, and did nothing at all, just stayed there, no error message, nothing

the files are .avi and .mkv
i reinstalled the players from all the ways i know, with no results

thanks in advance :slight_smile:

Multi-media and Restricted Format Installation Guide - openSUSE Forums
You should check you have done as instructed here

Don’t forget to do:
zypper update

After following the guide.

i’m totally lost here…vlc starts to play sound normally if i forward the video and rewind
the guide confused me even more, and now when i play the sound test it says my reproduction device doesn’t works and reverts to the hdmi device which isn’t plugged

i mean, where is the problem??

Please post result of

zypper lr -d

What version of openSUSE and KDE or Gnome?

From the Guide, did you stick to the advice about repos?

openSuSE 11.2 KDE 4.3.5

zypper lr -d

| Apelido | Nome | Habilitado | Atualizar | Prioridade | Tipo | URI | Serviço

–±----------------------±----------------------±-----------±----------±-----------±-------±--------------------------------------------------------------------------------±-------
1 | openSUSE-11.2-Contrib | openSUSE-11.2-Contrib | Sim | Sim | 99 | rpm-md | Index of /repositories/openSUSE:/11.2:/Contrib/standard |
2 | openSUSE-11.2-Java | openSUSE-11.2-Java | Não | Não | 99 | rpm-md | Index of /repositories/Java:/packages/openSUSE_11.2 |
3 | openSUSE-11.2-Packman | openSUSE-11.2-Packman | Sim | Sim | 99 | rpm-md | Index of /suse/11.2 |
4 | repo-non-oss | openSUSE-11.2-Non-Oss | Sim | Não | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
5 | repo-oss | openSUSE-11.2-Oss | Sim | Não | 99 | yast2 | Index of /distribution/11.2/repo/oss |
6 | repo-update | openSUSE-11.2-Update | Sim | Sim | 99 | rpm-md | Index of /update/11.2

OK did you do this:
http://tinyurl.com/yejwull

So is this more of a sound problem?

i didn’t knew i could do that :slight_smile:

i did it, but the problem remains the same

a reboot resolves…but only for the first file, from the second on, got no sound

Have a look at this
SDB:Audio troubleshooting - openSUSE

It reads like your multimedia application is seizing the audio device and not letting go of it.

What happens if you close the application, restart your alsa sound driver with:

su -c 'rcalsasound restart' 

and then restart your mixer (kmix for kde, alsamixer for gnome) and then try again with the application.

One can often tell what application has seized or is using the sound device by checking the open files with lsof. For example:

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

If one runs the above line at different times, when one’s sound is working and not working, one can learn better as to what the output means, and be better able to " point one’s finger " at the offending application that has seized the audio device. Do NOT post the output of that here. YOU need to run it when sound is working and when it is NOT working, and then compare the outputs and figure out yourself what application is seizing your sound device (if that is the problem). Again, do NOT post the output here.

caf4926 Have a look at this
SDB:Audio troubleshooting - openSUSE

i got the following outputs:

cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel

cat /proc/asound/cards
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xd2300000 irq 16
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xd2210000 irq 19

i can’t see any codec here; there is no “sound” item at yast>hardware

oldcpu
What happens if you close the application, restart your alsa sound driver with:
Code:
su -c ‘rcalsasound restart’

su -c ‘rcalsasound restart’
Senha:
bash: rcalsasound: comando não encontrado (command not found)

oldcpu
sorry, i didn’t understand what do you mean with the last commands

reminder: all of this is happening at VLC, if i play one file and hit “stop” then try to play ANY other file at the same vlc or amarok, the file will run fine, but without sound

reminder: all of this is happening at VLC, if i play one file and hit “stop” then try to play ANY other file at the same vlc or amarok, the file will run fine, but without sound

When you say you hit Stop. Are we to understand you mean you stop play but DON’T close VLC?
If so, this is your problem.

You need to close VLC.

If you playback movies with enqueue in smplayer
Close it
When you re start it will play from where you left off.

yes, i close vlc, and i check the “only one instace” option always

for example, i open a file by: right click>open with>vlc
then i watch 1min, and close vlc
so when i choose the same file, or any other file (at any other player), it still run, but without sound; the notification area gives a message error related to my sound device (can’t copy it here) and VLC gives a message related to can’t initialize output sound device

I take it the same happens with other players like smplayer?

@oldcpu can help you with this as it seems to be sound issue. Possibly you just need to confirm the default device in System Settings > Multi-Media

My backend is XINE and everything under device prefs is Pulse Audio.

I take it the same happens with other players like smplayer?

no, the problem with smplayer is the video; it plays the sound, but instead of video, i see my wallpaper and the smplayer logo, like if was a transparent window

Possibly you just need to confirm the default device in System Settings > Multi-Media

Confirmed.

My backend is XINE and everything under device prefs is Pulse Audio.

Mine too is xine. The prefered device is HDA ATI SB for everything, because i send the image to the hdmi and the sound to the subwoofers. Pulseaudio isn’t installed (please say it isn’t the problem)

Pulseaudio isn’t installed (please say it isn’t the problem)](http://forums-opensuse.provo.novell.com/editpost.php?do=editpost&p=2172923)

No it’s probably not.
I never used to have it, but since I installed Gnome along side kde, I think that is how it arrived.

You seem to have some strange things happening. The transparency in smplayer I have never seen before.

If you turn off desktop effects what happens then with smplayer.

I can not help but think you made a mistake. The application “rcalsasound” comes with alsa. Hence it is on your PC and you typed it wrong.

Note you MUST operate as a regular user. If you are trying to run these videos as root, then that is likely a cause of your problem.

So try again, when the problem occurs, as a regular user:

su -c 'rcalsasound restart'

and note you MUST operate your desktop as a regular user. NEVER operate your desktop as root.

To prove that rcalsasound is on your PC, just type:

whereis rcalsasound

and it will confirm that application is ON your PC.

Its not that difficult. Please read it again.

Note that when an application plays a video, it MUST open files associated with the sound driver and sound device. One can check to see what application is opening those files, by the “lsof” command EXACTLY as I gave it.

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

So please read my previous post again and try again. … ie run that when sound works, and store the output. Then run that again when sound does not work, and store the output. Then compare the two!

Its not that difficult.

gabriel@linux-f1rf:~> whereis rcalsasound
rcalsasound:

i think its not installed…

Note that when an application plays a video, it MUST open files associated with the sound driver and sound device. One can check to see what application is opening those files, by the “lsof” command EXACTLY as I gave it.

i got the output before and after the error message: actually, the only command that doesn’t return “no such file or directory” is the /dev/snd; also i can see two more entries when the sound doesn’t work

btw, i changed the wallpaper and the problem with smplayer video is gone, only the sound issue remains

Try this in a su terminal

zypper in alsa