Audio via HDMI/DisplayPort - any chances making it work?

I occasionally use a DisplayPort->HDMI cable to connect my laptop to my AV-Receiver, however I only get the picture to the AV-Receiver, but no sound. I read that not all DisplayPort->HDMI cables support sound, so I tested Windows7 on the same machine and it transmitted sound over that cable just fine. So I conclude that it is a Linux driver problem.

So I generally wonder whether this can be made to work easily or not. Does anyone here have experiences with this topic, especially with nvidia graphics cards managing the display port? (I did find older posts about HDMI audio, but they were all concerned with ATI graphics.)

pavucontrol / phonon do list a “High Definition Audio Controller Digital Stereo (HDMI)”-device, but sending sound to it does not do a thing. Furthermore, my dell laptop only has a displayport, but no HDMI connector.

Well, I have the same problem with Asus Aspire One 753 (Intel HD graphics, HDMI output - direct, no converter needed). I noticed that last week when I wanted to play a video on TV. I also selected HDMI output in pavucontrol but no sound at all.

Has anybody managed to have sound output via HDMI in openSUSE-11.4?


I also have an Acer with nvidia graphics card and never managed on 11.3 and 11.4 to get sound from HDMI output. It is a nvidia problem I guess because HDMI sound works great with my other Acer laptop equiped with a simple Intel graphics card.

At the moment I am working with the same problem on an AsRock 330 with nVidia ION and 64 bit KDE opensuse 11.4.

I can tell where I am now:

  • nVidia driver v. 270.41.06 installed The Hard Way ; no HDMI sound in nouveau driver
  • Found hdmi device with aplay -L and tested it has sound with speaker-test
  • Confige Desktop -> Hardware -> Multimedia -> Phone and prefer 'ed NVidia, HDMI Audio Output in all category

I have sound in all KDE (Notifications, dingles …), but Amarock complains and falls back to analog audio, and no sound in FireFox 4.0 playing Youtube videos

I think I miss something with asound, but I dont know what - please help.


Sound in Amarok was easy:

Forgot to chooice XINE in Confige Desktop -> Hardware -> Multimedia -> Phone -> Backend

I found a solution in #24 of:
Blocked sound channel

inserting a local .asoundrc in my user home directory.

Also enable channel S/PDIF 2 in alsamixer/kmix (ealier channel ICE958 2 in 11.2), and disable PulseAudio.

I don’t know if this the “right” solution, but now I have audio from FF/Flash and VLC via HDMI in my TV.


I will try that tonight.