Audio stops playing when switching to console from Xorg

My Audio stops playing when switching to console from Xorg. When I switch back it continues playing. Is it supposed to be like this? Any way I can make it play continuously ?

I’ve already checked the Howtos and this forum for this problem but havent found anything similar.
:slight_smile:

On 08/31/2011 11:26 AM, ryanrpv77 wrote:
>
> My Audio stops playing when switching to console from Xorg. When I
> switch back it continues playing. Is it supposed to be like this? Any
> way I can make it play continuously ?

-=welcome=- new member, but please explain what you mean by “switching
to console from Xorg” because i just:

-in openSUSE 11.4 with KDE4 started
http://www.youtube.com/watch?v=YJ6UVHoqoKk

-pressed Ctrl+Alt+F1 (to open a console)

-listened to the music while i logged in

-started top and noted that “plugin-contain” and “firefox” are the
number one and two users of CPU (as expected, with Flash playing)

-pressed Ctrl+Alt+F7 to get back to type here…

no problem…cool music, huh?


DD Caveat
openSUSE®, the “German Engineered Automobile” of operating systems!

let me explain again … (for the slow ppl)

Im running openSUSE 11.4 i586

The system boots up (runlevel 5) [now at login screen]
I login with Gnome or KDE (whichever i feel like using)
I run VLC, Play my music. Its plays perfectly as long as im in working on Display :0
When I switch to Console 1 (tty0) using Ctrl+Alt+F1 (whether im logged into tty0 or not), the music stops playing. (almost like the Xorg server goes into suspend mode)
When I switch back to Display :0 using Ctrl+Alt+F7, the music continues from where it stopped.

Btw, does all your replies come with sarcasm ? or am i misreading ?
It also looks like you misunderstood my question. :\

On 08/31/2011 04:46 PM, ryanrpv77 wrote:

> let me explain again … (for the slow ppl)

!!!

> Btw, does all your replies come with sarcasm ? or am i misreading ?

since i had to guess what operating system and version, and what desktop
environment and version, and what audio source and version, and what you
meant by “switching to console from Xorg” (and wondering if it was on a
local machine, or via remote desktop, VNC or whatever to a distant
machine) i don’t think there was one drop of either sarcasm or
slowness in my documented demonstration of the fact that my audio does
not stop when coming from youtube when switching KDE<>console…and now
that i also know your source of audio i can say that it also doesn̈́’t
stop when playing an mp3 in vlc 1.1.9 while switching…(because i just
did it)

so with the more complete info available i directly answer

Q: “Is it supposed to be like this?”
A: No.

Q:“Any way I can make it play continuously?”
A: should be already, so something must be broken in your system.
but what exactly i have no idea as i’ve never seen this particular
problem before, ever…

> It also looks like you misunderstood my question. :\

the lack of information in your post left a lot of unknowns in my mind.


DD
Caveat-Hardware-Software
openSUSE®, the “German Engineered Automobile” of operating systems!

On Wed, 31 Aug 2011 14:46:03 +0000, ryanrpv77 wrote:

> let me explain again … (for the slow ppl)

When people ask clarifying questions, it’s in order to help you and
because something wasn’t clear. Don’t engage in personal attacks, just
answer the questions so the best help can be given.

I recognise that you may not have intended to engage in a personal
attack, but as this is a written medium and we don’t have the context of
body language and other social cues - and you’re new here and as such
don’t have a history that allows for those of us who have been here for
years to be able to tell if you’re just kidding around or not.

Not everyone who helps here comes from an IT background - the openSUSE is
very diverse, and it’s important to understand that just because
something is clear to you doesn’t mean it’s clear to everyone who may try
to help.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

If you want to continue listening to your music, why not open a terminal window on your desktop? Don’t want the window there? Take a look at yakuake.

operating system? I’m sorry, I thought this was a forum for OpenSUSE.
Why would i listen to music on a Xorg server remotely?
Your first reply post was unneccessary, you could have just asked.

Thank you

Thanks, my system is a new installation with no customizations so I don’t think anything is broken.
I’m using VLC 1.1.11 i586 to play music.

My system specs:

Intel H55 “Hunter Cove”,S1156, 6CH Audio, Gb LAN, HDMI+DVI+VGA - ATX,
Intel ® i5-650 DC Clarkdale 3.20 GHz 4Mb Cache 32nm + IGP (733Mhz)
MSI R5670-PMD1G Radeon HD 5670 1GB GDDR5
4GB RAM
Samsung Syncmaster 20" B2030 LCD, 1600x900 max res
OpenSUSE 11.4 i586 KDE & GNOME

You’re right, my apologies. i just thought the way he replied was unneccessary
I’ll try to provide more info next time.

Thats a good idea, but when I’m on the desktop (xorg) I log in as a normal user, when i switch to the console(tty0) I login as root.
I know you can use ‘su root’ from a terminal on the desktop, I only use this method when I have to make a single minor change to something, otherwise I will use the root account on tty0. I will also use tty1 and tty2 to read documents at the same time as working. Also its quicker to keep a document open for reference on the other consoles and work on tty0 (eg man pages, …). It will be nice to have music still playing in the background while working on the other consoles.

soooo … any more ideas ?

On Thu, 01 Sep 2011 07:36:03 +0000, ryanrpv77 wrote:

> You’re right, my apologies. i just thought the way he replied was
> unneccessary

When someone takes the time to try and duplicate your issue, and isn’t
able to, that seems like a relevant response. I’m glad you understand
now. :slight_smile:

> I’ll try to provide more info next time.

That’s usually a good idea - none of us up here know anything other than
what the one asking the question tells us. :slight_smile:

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On Thu, 01 Sep 2011 07:26:03 +0000, ryanrpv77 wrote:

> operating system? I’m sorry, I thought this was a forum for OpenSUSE.

It is. Are you running openSUSE 10.1, 11.1, 11.3, 12.1 (pre-release),
Tumbleweed, Evergreen - which version? That matters.

> Why would i listen to music on a Xorg server remotely?

Unknown, but because you didn’t provide a lot of detail to go on and left
it to the readers to guess, that certainly would be a valid guess without
more information.

> Your first reply
> post was unneccessary, you could have just asked.

That’s what he was doing - but by providing an example that was perhaps
unlikely. Again, we only have the information you provide to go on.
Different people have different ways of saying “you haven’t told us
enough to help you”.

This post of yours has included information that is kinda critical to
helping you work out the issue - the hardware you’re using, the version
of openSUSE you’re using, which DEs you’ve tried this with, and the
version and release of software you’re having trouble with.

Otherwise, your original post essentially boils down to “my thing’s
broke”. (Yes, I actually had someone ask that exact “question” once
with no additional detail.) For someone who’s willing to help, that’s
really not a lot to go on - and most people will just skip to the next
message, but DD took the time to answer and tell you that you needed to
provide more detail. :slight_smile:

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 09/01/2011 05:47 PM, Jim Henderson wrote:
> but DD took the time to answer and tell you that you needed to
> provide more detail. :slight_smile:

i told him more than just that, i also included:

-pressed Ctrl+Alt+F1 (to open a console)

-listened to the music while i logged in

which should clue the quickest the music did NOT stop when switching
from KDE to a full screen console on openSUSE 11.4

the OPs system is, no doubt, broken.


DD
Caveat-Hardware-Software
openSUSE®, the “German Engineered Automobile” of operating systems!

On Thu, 01 Sep 2011 17:00:55 +0000, DenverD wrote:

> On 09/01/2011 05:47 PM, Jim Henderson wrote:
>> but DD took the time to answer and tell you that you needed to provide
>> more detail. :slight_smile:
>
> i told him more than just that, i also included:
>
>

> -pressed Ctrl+Alt+F1 (to open a console)
>
> -listened to the music while i logged in

>
> which should clue the quickest the music did NOT stop when switching
> from KDE to a full screen console on openSUSE 11.4

Indeed. :slight_smile:

> the OPs system is, no doubt, broken.

It does sound like there’s a problem, that’s for sure. Tasks that should
continue in the background not continuing in the background is a problem.

The only thing even remotely close to this that I’ve run into on my
system is having the sound quit when DPMS turns off my monitor. But
that’s because the speakers are in the monitor, and the monitor turns
them off when the monitor goes to sleep (which is in fact an entirely
different problem to OP’s problem here).

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

mmmm… I’ll have a look at my DPMS settings and get back to you guys.

(appreciate the help) :slight_smile:

I can confirm this issue. I have exactly the same problem. Opensuse 11.4 with pulse audio ALSA emulation.

I had a look at the DPMS settings, played with the settings and the audio fault persists. After changing afew audio settings I messed up the sound server and had to do a re-install cos i didnt know how to fix it. I now have OpenSUSE 11.4 x86_x64 installed instead of the i586 version.

I checked to see if the same fault occurs with the x86_x64 version. It does. However, I did realize this is not a fault.

When I log into KDE or gnome as user ‘testuser_1’, play my music with vlc, it works fine. Then when I switch to console 1 (tty0), the music immediately stops playing. (exactly the same as described before). Then login at console 1 (tty0) as user ‘testuser_1’ the music continues playing, but if i login at console 1 (tty0) as ‘root’ the music does not continue to play. So to have the music playing while working in tty0 you have to be logged into Xorg (and playing music) as the same user. Obviously has something to do with access permissions to the sound driver.

I now login at the consoles as ‘testuser_1’ and then ‘su root’. Music still playing fine when switching consoles.

Problem solved lol!

On Mon, 12 Sep 2011 09:26:03 +0000, ryanrpv77 wrote:

> ryanrpv77;2380560 Wrote:
>> mmmm… I’ll have a look at my DPMS settings and get back to you
>> guys.
>>
>> (appreciate the help) :slight_smile:
>
> I had a look at the DPMS settings, played with the settings and the
> audio fault persists. After changing afew audio settings I messed up
> the sound server and had to do a re-install cos i didnt know how to fix
> it. I now have OpenSUSE 11.4 x86_x64 installed instead of the i586
> version.
>
> I checked to see if the same fault occurs with the x86_x64 version. It
> does. However, I did realize this is not a fault.
>
> When I log into KDE or gnome as user ‘testuser_1’, play my music with
> vlc, it works fine. Then when I switch to console 1 (tty0), the music
> immediately stops playing. (exactly the same as described before). Then
> login at console 1 (tty0) as user ‘testuser_1’ the music continues
> playing, but if i login at console 1 (tty0) as ‘root’ the music does not
> continue to play. So to have the music playing while working in tty0
> you have to be logged into Xorg (and playing music) as the same user.
> Obviously has something to do with access permissions to the sound
> driver.
>
> I now login at the consoles as ‘testuser_1’ and then ‘su root’. Music
> still playing fine when switching consoles.
>
> Problem solved lol!

Glad to hear you got it solved - it does sound like a bug to me, but I’m
not quite sure how to describe it as such. You might consider reporting
this through bugzilla and see what the developers have to say about it.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

HI,

I can say I had no issues like that with openSuse 11.4.

When I upgraded to 12.1 (x86_64), I found that music stops playing while switching to a console (CTRL+ALT+F1-6) and when swtiching to a different KDE user (CTRL-ALT-F8-11).

Music, audio from movies, from firefox, etc, everything being outputted on the audio device seems to “depend” on which user is “active”.

For sample: say I’m on userX on first KDE session (CRTL+ALT+F7) and I’m playing amarok:
if I switch to 1st console (CTRL+ALT+F1) I can hear no music.
After I log into the 1st console as the same userX, I can hear the music on the 1st console too, and when I log off (CTRL+D), the music goes off again!

Another example: say I’m on userX on first KDE session (CRTL+ALT+F7) and I’m playing amarok;
if I switch to a new KDE user session (say for userY), no sound is heard:

  • not the music being played by userX;
  • not the “KDE welcome sound”, which is somewhat “queued”: if I switch to 1st console (CTRL+ALT+F1) and I login as userY, I can hear the “KDE welcome sound” (and yet no userX’s music)!

that’s strange, isn’t it?