Audio stops after a brief time of playing through VLC

I’ve added this packman repo: Index of /suse/openSUSE_11.4/ and installed all the necessary libraries and tools required as mentioned here using zypper: Restricted formats/11.4 - openSUSE Community Wiki

When I try to play any movie in VLC I’m able to hear the audio for some time usually 3-4 mins and then audio totally stops though the video continues to play. A random seek or a seek forward/back also cause similar issue almost immediately. I switched the output module in VLC preference to different settings: default, SDL, Unix OSS, Alsa but the same issue persists. The audio recovers if I just enter the Audio settings menu in VLC preferences and click Save (even without changing anything) but after the same 3-4 mins or by seeking, the audio stops.

I disabled Pulseaudio for my sound card(s) in Yast->Sound, and I even kill the pulseaudio process but it somehow starts itself up again when I change anything in VLC audio preferences or even simply click Save without any changes.

I’ve made sure all the multimedia related packages are installed from the packman repo whenever possible (I still observe there are few packages which do not exist on the packman but the openSUSE 11.4 repo alone eg. phonon-backend-gstreamer, phonon-backend-xine)

I plan to use this box for primarily playing movies stored on my mdadm raid array. It would be really helpful if I can get past this issue. Let me know if you need info from my side. Thanks.

Here is the rpm query output for the multimedia related libraries:

rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' MPlayer '*vlc*' | grep -v avahi | sort
banshee-1-backend-engine-gstreamer-2.0.0-0.3.2-x86_64 -> openSUSE -> -> -> -> -> -> ->
gstreamer-0_10-plugin-crystalhd-3.5.40-3.1-x86_64 -> openSUSE ->
gstreamer-0_10-plugin-gnonlin-0.10.17-5.1-x86_64 -> openSUSE -> -> -> -> -> -> -> -> -> ->
kdebase4-runtime-xine-4.6.0-4.9.1-x86_64 -> openSUSE
libavc1394-0-0.5.4-2.1-x86_64 -> openSUSE -> -> -> -> -> -> -> -> -> -> -> ->
libgstfarsight-0_10-0-0.0.22-4.1-x86_64 -> openSUSE -> -> -> -> -> -> -> -> -> -> -> -> -> -> -> -> -> ->
PackageKit-gstreamer-plugin-0.6.14-0.2.1-x86_64 -> openSUSE
phonon-backend-gstreamer-0_10-4.4.4-3.1-x86_64 -> openSUSE ->
phonon-backend-xine-4.4.4-3.1-x86_64 -> openSUSE -> -> -> -> ->
xinetd-2.3.14-152.1-x86_64 -> openSUSE ->
xine-ui-32bit-0.99.5-231.1-x86_64 -> openSUSE

If you do not mind trying one more thing I have a bash script file called mmcheck here in message #75:

MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf - Page 8

Would you mind downloading and running mmcheck through its many steps and let us know if anything does not pass the test. In particular if you have any troubles loading any additional packages said to be missing in mmcheck. It is getting late here in Austin, so it may be morning before I get back with you.

Thank You,

Thanks James, I had already followed all the steps mentioned in the “Check you multimedia problems in 10 steps” thread, anyways ran the script and it didn’t detect any problems.

I somehow noticed this thread: Sound to multiple output devices with pulse? - Page 2 and installed pavucontrol, pavumeter, padevchooser as well as pulse-audio plugin for VLC (didnt know one existed till now :|), configured such a way that my HDMI audio card on my nvidia board as the default output and also enabled simultaneous ouput as mentioned in the above thread.

I ran VLC yesterday to watch 3 tv shows (each roughly 20 mins) and didn’t experience any audio problems surprisingly :smiley:

Thanks for your reply James :slight_smile:

If you experience any further problems try setting the audio to UNIX OSS audio output
In Prefs > Audio > Output mode

I had tried that initially when I had problems, but didn’t quite solve the issue. Thanks for the suggestion anyways, will give it a try if I see it again.

One thing I noticed was that the volume up and down keys didn’t quite control the audio level when the output mode was set as Unix OSS (I guess since the volume up and down keys are tied up with pulse audio and control only the volume of the audio output coming through that alone)

I had a similar problem. Audio would cut out in VLC after a few minutes, and might cut back in later. I installed the vlc pulse audio plugin, switched vlc to use pulse, and now it seems to be working.

Running Opensuse 11.4 with VLC 1.1.12

I had such an issue with VLC stopping playing audio every now and then. I found I had to somehow “reset” the audio device either by opening the preferences dialog, or by reselecting it from the Audio / Audio Device menu. Of course that only temporarily fixed it, it stopped again after a few minutes.

I installed the “VLC Audio Out for Pulse Audio” package (vlc-aout-pulse), selected Pulseaudio in preferences as the default audio-out device and FINALLY I can listen to music uninterrupted!

NOTE: All this on openSUSE 11.4