audio problems - alsa, phonon,dell inspiron with ICH7

I have a couple of audio problems that are bugging me.
The first one:
I have two backends for phonon: Xine and Gstreamer. :

Xine has the following devices listed:
http://img217.imageshack.us/img217/5807/soundwithxinebackend.th.png](http://img217.imageshack.us/i/soundwithxinebackend.png/)

And GStreamer has the following:
http://img718.imageshack.us/img718/1347/soundsettingsx.th.png](http://img718.imageshack.us/i/soundsettingsx.png/)

Almost everything works good with Gstreamer except that I cannot skip through song length in amarok(cannot do Fast forward or rewind). I have some looong songs (non-stop remixes) and I want to play at different positions.

If I select Xine backend, skipping works, but I get a new problem. The PCM slider (which I use as the main slider to work for both Master and LFE (subwoofer) I have) won’t work. It won’t respond to PCM slider. and The master channel works only if I lower the volume all the way to a little value (around 5%-10%). from withing amarok. If I don’t use PCM slider, I cannot lower or raise the volume with one slider. I have to do it manually for both LFE and Master. (See the working sliders below):

Second problem.
My kmix will show these sliders everytime my computer boots.and everytime it works.
working sliders:
http://img442.imageshack.us/img442/7921/mixerworking.th.png](http://img442.imageshack.us/i/mixerworking.png/)

But each time I “logout” and log back in, I get these sliders instead. I tried creating a new user, but the problem persists.
And the problem is that I do not get any sound at all, regardless of sliding every single sliders all the way up.

not_working sliders (which I get ONLY but everytime I logout and log in):
http://img532.imageshack.us/img532/6640/mixernotworking.th.png](http://img532.imageshack.us/i/mixernotworking.png/)

Here is my alsa-info:
http://www.alsa-project.org/db/?f=4112602fb5f862c86259fff92b70d0ff313210b4

I don’t know, but it looks like you have two sound cards, an Intel and a Sigmatel (my brother used to work for Sigmatel as an accountant). Or, you have an HDMI output and an analog sound chip as well. What sound options do you have in your BIOS setup? Do, you really have two sound cards? One on the motherboard and one you installed yourself? In most cases, you would want to disable one of them some how if you can.

Thank You,

Hmm. I really don’t know if I do have two sound cards. This is my Dell Inspiron E1705/9400 Laptop, with ICH7 sound card. (I believe so).

As I am not an expert, I really am not sure about that. But My laptop has two speakers in front, and a subwoofer in the bottom. I do not have HDMI interface but i have digital video out and s-video out. For audio, I can see one mic, one linein and a headphones out on one side of my Laptop.

head -n 1 /proc/asound/card0/codec*

yields:


==> /proc/asound/card0/codec#0 <==
Codec: SigmaTel STAC9200

==> /proc/asound/card0/codec#1 <==
Codec: Conexant ID 2bfa

I guess, Conexant is for modem?? (not sure :frowning: )

Give me some advice please.

Have you looked into the sound hardware function in YaST? Open YaST, Select Hardware then the Sound Icon and see if more than one device is shown. If it shows two, I might disable the one that shows up second by deleting it. Real hardware that is present, but not configured will not be used by the alsa sound system. You can always go back later and reconfigure it if it does not help to be removed.

I might also suggest you consider disabling pulse-audio and only use alsa. To disable pulse audio you open up a terminal session and enter the command su and then your password. Then enter the terminal command “setup-pulseaudio --disable” which will leave only alsa sound working. Pulse has created problems for lots of folks around in the forum.

Thank You,

I have only one sound card listed in yast (sound):
82801G(ICH7 Family) High Definition Audio Controller

and I do not have pulseaudio. I am using Alsa only.

And I found one more thing. Notice the “default” on the device listed on audio preferences with GStreamer backend in those photo? That is the one which works. If I use HDA Intel (STAC92xx Analog), It has the same problem with both backend.

Now my question is how do I create the “default” device, or may be I can copy it from GStreamer Backend to Xine backend?

I want to compare the default device and the HDA Intel device. PCM works with default but not with HDA Intel.

Can anyone help please? some pointers…I don’t even know where those configuration files are for those devices.

At last, solved it. it is a bug:
https://bugs.kde.org/show_bug.cgi?id=194902

solved by creating a file .asoundrc in home directory, (can also create /etc/asound.conf instead of .asoundrc for systemwide effect.)
with the following contents:


pcm.softvolPhonon {           
    type softvol              
    slave.pcm "default:CARD=0"
    control {                 
        name "Phonon"         
        card 0                
    }                         
    min_dB -51.0              
    max_dB 0.0                
    resolution 100            
    hint {                    
        show on               
        description "My Soundcard with extra Volume Control"
    }                                                       
}   

:slight_smile:

Just a quick question though, anyone know how to add mute to PCM? or Phonon (slider) in this case?? I still cannot mute with one key! :stuck_out_tongue:

To set the Mute button if you are using KMix, put your mouse over the icon tray speaker, select it and then press the mixer button. In KMix, goto Settings and then Configure Shortcuts. Select the Mute Function on the Left with your mouse, a small window opens up. Select the Custom Bullet, then Select the “None” button which changes to “Input”. Press the keyboard Mute button or other custom key stroke and it will be set for the “Master” setting. My mixer also offers to mute each individual input instead or with a different key stroke. Check it out, I am sure you will get the hang of it.

And, I also am happy to hear you did find the solution to your problem, good troubleshooting on your part.

Thank You,

It did not work. I tried that with PCM before,and now as per your instructions, but when i press mute button, nothing happens.

I remember that PCM slider never had mute button before also.BUt I clearly remember that on 10.3, when I pree mute button, it turned my PCM volume to 0 and when I press mute button again (unmute) would restore the value to whatever it was before.

CAn anyone come up with solution to do the same?

Or how can i make both front and LFE mute (when I mute one of those)? That will work too.

I think that was how opensuse 11.0 handled it!!

Please let me know if anyone have any ideas.

Open up your shortcuts for the mixer, do another screen capture and show us what you got for choices. The shortcuts is where you do it. Since you seemed to have two different mixers, perhaps you have to do this for each to get the one that is working. None the less, shortcuts is the only place I know of where you can map keyboards inputs to sound functions. I have not tried to use the same shortcut for two channels, but you could see if it might give you an error message if you try.

Thank You,

Thank you so much for your concern but I think you do not understand my problem. I have no problem mapping shortcuts. I would do that with keytouch if kmix or any ‘K’ apps could not do that. But it is not my problem.

my problem is that There is no way that I can mute my computer using only one “key”, or “any mute check box”. I have to mute two checkboxes… One on the top of “Master”, and other is the second one above “LFE”, you can see that in my previous picture. I have to check those two boxes to mute my speakers. (because I have a subwoofer in my laptop) If I mute master, only front speakers are muted, the subwoofer is still singing, and if I mute LFE, only subwoofer shuts off, front speakers are still laughing…

And problem is "There is no that I can mute (check or use shortcuts) these two at once with one mute key on my keyboard :frowning: . If I map mute key to master it only mutes master, as i said, the subwoofer is still on. and vice versa…

As far as I can tell, you can not assign the same shortcut to more than one channel. If muting the master does not work, you might need two shortcuts to do what you want. Do you have analog outputs (6 or 8) to your speakers or is it a single digital or optical output?

Thank You,

This is my Dell Inspiron Laptop :stuck_out_tongue: I only have one 3.5mm (??) output for headphones.

In your two mixer pictures you show a control for Master,LFE,PCM & Digital. The LFE seems out of place. for a single headphone output. First, I might keep LFE muted and put the shortcut on Master and see if that works. Second, I might go to Settings, Configure Channels and see what else might be present that a single mute could work on.

Thank You,

Yes. There is no output for LFE. When i am using headphones, I can mute the sound with master. (since there is no LFE output, it won’t make any sound). but sadly i don’t use headphones all the times.

I have searched a lot, and look over settings, but could not found anything that can make LFE to mute tooo when i mute Master. (er. am not a expert :P)

But I do know that is possible, since that was how it worked in (10.x or 11.1 (forgot:P)) versions of opensuse. All I had to do was to set shortcut to mute master and the LFE would also get muted automatically when I mute master.

I know there must be someone in this community who knows how to do that. Just waiting for those eyes to catch this thread… :wink:

Oh … and I can’t just let LFE muted all the times… trust me when you are used to this sound you would not like the sound without LFE :slight_smile: .

BTW After enabling this xine-backend for phonon, (I love alsa)… this amarok baby produces a LOUD sound that I love. :smiley: I don’t even need external speakers… It’s sooooo loud enough for a small party in my apartment… :smiley:

In an earlier post you said you are not using pulse-audio when I suggested you disable it. Since it does get loaded by default, how do you know you are not using it? Did you already disable it or did you un-install the application? If you did not un-install it, then try the disable command and see what happens. Open up a terminal session, enter su - and then the root password. Then enter the command:

setup-pulseaudio --disable

Just do this for me one time and see what it does. It has fixed a lot of odd problems on systems and is not needed as long as alsa is loaded.

Thank You,

I threw pulseaudio out as soon as I installed opensuse 11.2 :smiley:

I has issues with it on 11.1, but i DID give it a try in 11.2 for a few days… and then I uninstalled it. rotfl!

OK, no pulse-audio but using GStreamer and not xine, hmmm. I found this statement in an article about the Linux sound system and it says…

“GStreamer slots into the audio layers above PulseAudio (which it uses for sound output on most distributions), but below the application level.”

Perhaps the problem, if you can not use xine is the absence of pulse-audio, God forbid. Perhaps we need to reverse course and reinstall pulse-audio!

Thank You,