Audio problems after I ....???


I used kaffeiene vlc and amarok without problems on 11.4 KDE
I had some issues playing streamed audio until I installed vlc
And when ever I played video via vlc there would be no audio until I clicked on Audio -> Audio channels ->stereo or left or right then there would be sound until I paused and restarted the video then I had to go via the above mentioned process again
I used mmcheck as per the instrcutions on
Everything was supposedly installed but the vlc error persisted

Then one night there was a power failure The pc died ie not a controlled shut down

Then when I switched it on again there was no sound
I used a

SB0570 [SB Audigy SE]
Driver snd-ca0106
for the last few years without problems

I activated the

K8M800-M2 (V2.0) onboard audio
Configured as sound card number 0
Driver snd-via82xx

and had sound again

then there was a power failure again and now I dont have any sound

If I test the onboard card via yast and sound then it plays a sound (piece of classical music)
but neither amarok, kaffeiene or vlc makes a peep Nor when the system starts up or shuts down

I dont know what to do!

MMCheck said all is ok and I did not change anything

How do I address this issue?

I recommend you install pulse audio volume control (pavucontrol) and use it to tune your audio for each application. I blogged a bit about pavucontrol here: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

Also look at your mixer and ensure the PCM volume is not muted.

Note YaST plays sound with root permissions, so it is not 100% indicative of what one will get with user permissions. One could always try adding their regular user to group ‘audio’, reboot and test, but my personnel feeling based on your description of the problem is this is not a permissions issue.

Sir oldcpu

I install pavucontrol as suggested

No luck. still sound via yast sound but nowhere else

speaker-test -Dplug:front -c2 -l5 -twav

froim SDB:Audio troubleshootingand there was sound, but i assume it has tto do with the root permissions you mentiuoned?
anyway kept on fiddling
[li]]YAST > HARDWARE > SOUND > OTHER > TEST and test your sound. If you have no sound then,[/li][li]YAST > HARDWARE > SOUND > OTHER > VOLUME and move your PCM and Master Volume up to about 75% and test your sound. If you have no sound then,[/li][li]YAST > HARDWARE > SOUND and select your audio card and delete it (which deletes the configuration, not the card). If you wish to ensure the sound configuration is completely deleted, you will need to delete the file /etc/modprobe.d/50-sound.conf (with root permissions). Then add the card, and configure the card. That will recreate the 50-sound.conf file. Test your sound. If you have no sound then close YaST and[/QUOTE][/li][/ol]

1 and 2 made no difference
I tried 3 just deleted the 2 cards via YaST, not the complete deletion (is that a word?) and I got the onboard card to work
the SB card stil does not work (via Yast also not)
Should I ty the Super delete? Or what do you suggest?

So you have onboard sound working , but not the SB card. It reads like there is an SB card misconfiguration in your PC’s audio setup. We need to see details of that to provide any suggestions.

Please with PC connected to the internet, in a terminal run the diagnostic script:


and select the ‘UPLOAD/SHARE’ option. That will check your audio configuration, summarize it, and upload it to an alsa pastebin site. When the script is complete, it will give you the location (a link) where that information is located. Please copy that ‘link’ and post it here so we can check the configuration.

Note also that pavucontrol works well with multiple audio devices. I tried to give examples of that in my blog: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

Oldcpu, sorry I took so long to respond but sometimes life interferes!Newer version detected: 0.4.61

To view the ChangeLog, please visit script has been downloaded as /tmp/alsa-info.yYZHXCs9Lb.Please re-run the script from new location.jandre@linux-0p2o:~> 

is what I getWhat does it mean

Please re-run the script from new location.
There is no upload/share functionthanks

The script always shows an UPLOAD/SHARE option if run with no arguments. but no matter, read what you posted to me. The output of the script was placed on your hard drive, right here: /tmp/alsa-info.yYZHXCs9Lb.

so copy the content of /tmp/alsa-info.yYZHXCs9Lb to a pastebin site such as SUSE Paste, press contribute, and post here the web site/URL this gives.


Slowly I am learning more and more!

(There was no upload option untlil I ran the script as SU)

thanks for the URL. I will look at it. But what you stated about no upload option unless script is run as ‘su’ does not make sense. I suspect you had a different (unknown to me) problem. I ALWAYS run this script as a regular user and NOT as SU and it works fine, exactly as I noted. Hence I think the problem you encountered was elsewhere.

I note this:

The script detects two sound cards:

!!PCI Soundcards installed in the system

00:0a.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)

But there are only mixer controls for the one sound card:

!!Amixer output

!!-------Mixer controls for card 0 [V8237]

Card hw:0 'V8237'/'VIA 8237 with ALC655 at 0xd000, irq 22'
  Mixer name    : 'Realtek ALC655 rev 0'
Simple mixer control 'Master Mono',0
  Mono: Playback 0 [0%] -46.50dB] **[off]**
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]

The dmesg is not showing:

!!ALSA/HDA dmesg

This makes me think that you do not have the sound blaster card configured in YaST.

Please post here the contents of the file /etc/modprobe.d/50-sound.conf AFTER you have the sound cards configured in YaST. And after configuring the sound card in YaST, please try again with the card that you wish to get working, being careful again to restart pavucontrol.

As requested

When I configure the SB card as well I have no sound at all. Neither card produces sound except the onboard one when I test the audio under yastI have also noted that everytime I reboot I must delete and reinstall the onboard card before it works


Please note this request:

Does that file not exist ?

Have you tried adding your regular user to group ‘audio’ to see if that helps ? (do you need help figuring out how to do that ? )

Instead of going in to YaST to configure audio each time, have you tried a simple alsa sound driver restart, by running with root permissions:

rcalsasound restart

None of those may be permanent solutions, but they may yield more information.

After running YaST, you provided this link from the diagnostic script: … what audio devices work with that script output ?