audio problem with vlc player

Here is a botheration with vlc media player. While it otherwise plays videos well, the sound stops if I stop the video and then restart the player. Smplayer does not have any such quirk behaviour. This is a OEM netbook with openSUE-11.4-Gnome OS. Being a netbook the ripped files of the videos are saved in /home/Movies . I have debian-squeeze on this dual boot machine and there vlc behaves fine.

What audio output mode do you have selected in vlc ? oss ? If not, have you tried oss ?

I have now added the videolan repo and have downloaded vic-beta from there and the media-player is behaving well. Incidentally, when I opened the Add/Remove Software window it showed that libdvdcss2 has to be installed to which I agreed. But does that mean that previously I did not have libdvdcss2 even though smplayer and vlc (from oss, I presume) was running ?

Try this

I’ve just switched from gstreamer to xine phonon and everything is ok. I dont like this solution, but it works for me.

So it doesnt work, problem is here again

What have you done to confirm its the identical problem and not a different problem with the same symptoms ?

Its because I have the same problem also in 11.4. In 11.4 I solved with mmcheck. Now also mmcheck doesnt work.
And here is the error message which I get with vlc:
[0xbd06d0] oss audio output error: cannot open audio device (/dev/dsp)

Is there any other audio application running at the same time using oss ? Did any other audio application using oss crash before ? Does vlc work immediately after a fresh reboot BEFORE you run anything else ?

do you have the rpms alsa-oss and alsa-oss-32bit installed ?

Why are just talking about/using OSS?? The OSS provided by Linux is an obsoleted API that is there only for compatibility with old apps. And in fact you are using ALSA anyway, but through an OSS compatibility layer.

And VLC doesn’t use Phonon. The Phonon backend obviously is not going to change anything.

Indeed that is the case wrt OSS API not being used. However an observation I have made, is that the alsa-oss compatibility layer still works better for vlc for some user’s hardware (I would say a very small number of users).

I have not seen your posts on the forum for a while [probably because I’ve been looking in different forum areas], and its nice to see you posting again ! :slight_smile:

after fresh reboot everything is OK, and sound from vlc is good. Now I realize that when I am watching vlc, amarok dont play anything. And when I listen amarok , vlc dont make any sound. So the problem is that I cant use more applications using oss. What shoul I do? thanks
And I have alsa installed.

IMHO if you wish to have sound playing with both amarok and vlc at the same time, you need to get both working with pulse audio.

I know how can I do that in vlc, could you tell me how in amarok?
And is it the normal behaviour, or the problem is in my hardware?

I don’t use amarok. … I vaguely recall that KDE3 amarok had a menu where one could select the sound engine, while KDE4 amarok relies on the sound system chosen by the desktop. So in KDE4 that would be via KMenu > Configure Desktop > Multimedia > Phonon. … I have no idea wrt Gnome. … and again, take that with a grain of salt as I do not use amarok.

Would be worth a bug report. Anyway notice that ALSA has two OSS compatibility layers. By default it uses the one in the kernel, that has the usual problem of not allowing two apps two play sound at the same time unless the the sound card does sound mixing in hardware. But if you run the app with aoss before (“aoss vlc”) it will use a compatibility layer from libasound that hasn’t that problem.
Also worth mentioning that Packman has the Pulse audio output splitted, in the vlc-aout-pulse package. That package should be installed automatically in systems where pulseaudio is installed but there is a problem with the repository generation and this doesn’t happen (looking at it…). So by default it doesn’t use PulseAudio directly but through the ALSA compatibility layer…

Is there any way to be aoss default for every application in system?