Audio (Music) CD playback Stuttering

Using 11.3 x86_64, when I play music off of any audio CD, there is a ‘hiccup’ or ‘stutter’ in the audio every few seconds while playback continues. This stutter sounds like the sound is just dropping out, or the playback is pausing, very briefly. This problem happens every time using Amarok, KsCD, Kaffeine. Files in various formats playback smoothly from an external hard drive.

On Amarok I know I choose the Xine backend.

The CD’s and the optical drive are not damaged in any way. The CD’s have no marks and play correctly on other CD players and using the same drive via Songbird and iTunes on Windows 7.

I am unsure how to even how to find out exactly what the problem is.

PC: Gigabyte P55a-ud4p (optical out)
intel core i7 860
driver" HDAIntel

This should NOT happen with a Core i7. What output audio mode is selected in xine ?

If you don’t know, install xine-ui, and when running xine go to its preferences and change permissions to “master of the known universe” (I know - its bizarre) and then restart xine and investigate your output audio mode. Does that help ?

Its possible you have KDE or Gnome with some pulse audio problems ? Take a look at step 7 here: SDB:Audio troubleshooting - openSUSE

I would firstly just copy a song onto your p/c hard drive and then play it. Assuming that it plays OK then this would rule out a problem with your system talking to component parts.

I had a similar problem two opensuse versions ago. Can remember that it was only a minor problem but it used to drive me crazy. I solved it by removing all ‘pulse audio’ rpm’s on my system.

Sorry for my absence, I was unexpectedly held up out of town, away from my pc.

@dth2: Although I am having some problems ripping & moving some flac files to an external hard drive, the ones that do copy play fine. For example, I ripped a CD I own onto my hard drive, and then moved it to the external, and all but 2 of the tracks moved fine, but tracks 1 & 9 refuse to move. But I’d guess this is a probably question for a different thread?
Also I tried deleting everything ‘pulse audio,’ except for “libpulse-mainloop-glib0” & “libpulse0,” due to about 500-600 dependency issues.

@oldcpu: I have xine-ui installed, but I do not see a ‘preferences’ menu anywhere in Xine 0.99.6. I’m not sure how to check the output setting via xine either, but ‘audio channel’ is set to auto, if that’s what you mean. I also looked at step 7 in the SDB page above, and the only file I see in /etc/pulse is client.conf.

I’ve downloaded vlc, phonon-vlc, phonon-backened-vlc, etc., and CD’s now play fine via the vlc player, but still not through Amarok, Kaffeine, KsCD. In Amarok I chose the vlc backend over xine, and my collection plays fine, but now I have no audio from CD’s on that player. It would be nice to get everything working, or even to figure out what’s wrong, but vlc player seems to work fine at least.

for xine right click on video window > settings > setup > gui > configuration exerience level and choose ‘master of the known universe’. Apply. Then close xine. and then restart xine. Then right click on video window > settings > setup > audio (or video) and you can select the driver to use.

I made sure that experience level in xine was changed to ‘master of the known universe,’ and my audio & video drivers are set to ‘auto’. I attempted to view the available options for the drivers, but each time the drop-down menu appears, my desktop freezes and I must restart my session. I also haven’t been able to produce a usable bug report for this.

I’ve seen such a freeze, but I find if I simply immediately select ‘xv’ instead of scrolling back and forth the bug does not appear.

Do you mean hit ‘xv’ on the keyboard, or select a driver immediately? If I selected a driver, I was able to scroll between auto, null, and alsa. Auto is the current setting, do you have specific driver in mind that I should be using?

I have a selection ‘xv’ for video.

For audio, you could try oss.

Just a update: I’ve still not been able to figure why CD’s stutter with any media player other than vlc. Thanks, oldcpu for your quick responses. If I ever figure it out, I’ll try to post an answer in case it helps anyone.


Hello seanthor,

Posts like yours make me want to think that multimedia stuff is pure voodoo … I have had the opposite experience … video ALWAYS stutters with vlc … and stutters less with mplayer/smplayer/gnome-mplayer.

If you have not already, please use the Yast Software Management tool to ensure that ALL your codecs,softwares,gstreamers,magic-spells,etc. are REALLY the latest versions available from the packman repository. Once you are sure … check again! While in Yast, you can filter by repository, click on packman, and in the right hand pain in the middle of the window will be a button that roughly reads “replace installed packages with packages from this repository” …

Best of luck!



I agree on the voodoo part. What a travesty it would be if it were simple to perform simple tasks, i.e. playing a DVD or CD, that you OWN!

I believe every package on my pc is up to date, I just checked again. I also double checked that vlc (from packman) is my best functioning media player for playing from any media source that is not a HD. But I wasn’t able to find the “filter by repo” option in YaST2, nor the replacement button you mention. Could you point me in the right direction, please?