Audio limited to 1 program at a time

I am running openSUSE 10.3, and this has been a problem on this machine since the initial install about a month ago.

Audio will only work with one application at a time, and once that application has audio, it will hold it until it has been shut down. (Eg, if a video is open but paused, I can’t watch youtube with sound, or start music on Amarok.) As soon as the app with audio has been closed, another program is free to take it (and in turn hold it as well.)

Another, likely related symptom: When clicking on the KMix icon from the task tray, the slider bar for volume, and the mute button, have no effect at all on the sound.

Any advice on this matter would be greatly appreciated. :slight_smile:

Recommended scripts have been run:

general pastebin - merritt - post number 1058780

tsalsa.txt - (beta)


uname -a
Linux kristen-desktop #1 SMP 2008/02/10 20:01:04 UTC i686 athlon i386 GNU/Linux

rpm -qa | grep alsa

cat /etc/modprobe.d/sound
options snd-hda-intel enable=1,1 index=1,0

5Dex.EZvOC6rBsDE:SBx00 Azalia

alias snd-card-1 snd-hda-intel

dP62.ARsxkZ5NWG0:Radeon X1200 Series Audio Controller

alias snd-card-0 snd-hda-intel

I don’t know what will cause this. But looking at your audio configuration, a few things I would recommend are:

a. install alsa-firmware and reboot. Test your sound I had thought alsa-firmware necessary for an ATI SB, but the fact you have sound suggests maybe it is not.

b. Try switching IEC958 to OFF (in your mixer) and see if that makes a difference. Switch back ON if it doesn’t help.

c. If a regular user loses sound all together (but root keeps their sound), be prepared to add your regular user to group audio, per this step in the audio troubleshooting guide:

Thanks oldcpu,

Unfortunately still having no luck. I installed alsa-firmware and rebooted, and I can see no change from that.

I turned IEC958 to Off, tested sounds, no change. Put it back to On.

I even went ahead and added myself to the audio group, just in case. No change there either.

Any other ideas?

Try this thread here seems there’s many different chipsets.

HDA ATI SB / INTEL Sound card problem [SOLUTION!] - Ubuntu Forums

So as we know ALC883/888

3stack-dig 3-jack with SPDIF I/O
6stack-dig 6-jack digital with SPDIF I/O
3stack-6ch 3-jack 6-channel
3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
6stack-dig-demo 6-jack digital for Intel demo board
acer Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
acer-aspire Acer Aspire 9810
medion Medion Laptops
medion-md2 Medion MD2
targa-dig Targa/MSI
targa-2ch-dig Targs/MSI with 2-channel
laptop-eapd 3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
lenovo-101e Lenovo 101E
lenovo-nb0763 Lenovo NB0763
lenovo-ms7195-dig Lenovo MS7195
haier-w66 Haier W66
6stack-hp HP machines with 6stack (Nettle boards)
3stack-hp HP machines with 3stack (Lucknow, Samba boards)
auto auto-config reading BIOS (default)

Now try the correct model or as that link try a few hopefully one will hit home.


I tried what you suggested without luck.
I went through every single option.
With 2 of the options, I got no sound at all.
With the rest, I always got sound, though always with this program-captured problem, as well as the KMix master slider still being useless.

So, two hours later, I’m still stuck. (Rebooting after every change was very time consuming!)

Any other possiblities here…?

Oh, by the way, I thought I’d give the error message that Amarok provides when I start it, with another program having audio captured:

xine was unable to initialize any audio drivers.

Still not having any luck with this problem, anyone else have any idea what’s wrong, or what to try?

Thanks in advance.

Can you advise which amarok and xine versions you have ? Its possible you still have some “crippled for proprietary codec” versions. Please paste here the output of running the following in an xterm/konosole:
rpm -qa | grep xine
rpm -q amarok
rpm -q mad

rpm -qa | grep xine

rpm -q amarok

rpm -q mad

package mad is not installed

Please install the application “mad”.
PackMan :: application mad

How did you install amarok? Did you force your amarok install? Because mad is a dependency of the packman packaged amarok, and it should not be possible to have mad not installed when the packman packaged amarok is installed.

I recommend you setup up your repositories for openSUSE-10.3 per the guidance here:
Repositories/10.3 - openSUSE-Community
and for now install only OSS, Non-OSS, Main Update, and Packman.

Note, for sound from multiple applications at a time, make sure all sound apps use the device name alsa or default and NOT hw or OSS or plughw:0,0 because these do NOT allow mixing.


I did as you suggested and installed package ‘mad’. Rebooted, and there is no apparent change.

Yes, I did have to force the amarok install, according to my repo setup. Amarok however is not the problem, when it has audio Amarok works flawlessly. This audio problem has been present since the fresh, unconfigured install of openSUSE, and I strongly suspect it to be because of an odd or uncommon piece of hardware (likely my particular sound card).

Thanks for the suggestion. :slight_smile:
Also, to the best of my knowledge (sound config is not my strong point!) all of my apps are instructed to use ALSA - although I don’t know if it is possible to configure the browser’s use of audio. (Ex: My not having audio from youtube, if a video or amarok are opened…)

Side note:
I had intended to build myself a brand new desktop for use at home, all the parts hand chosen and OSS-friendly. Unfortunately my budget is tight, and I got the offer of this system, with the 19" LCD, for $400 no tax, brand new. So my custom machine will have to wait a while longer. I know these pre-packaged computers often cause headaches, and I’m sorry to share it with you guys! Thank you for trying to help me, I appreciate it.

~ Kristen

Force is almost ALWAYS a bad idea. It can cause affects that no one can predict.

My recommendation is remove amarok completely. Which includes going into /home/user/.kde or /home/user/.kde4 and remove any config files.

Then re-install amarok and all dependencies from scratch, and this time don’t force.

Possible, but I suspect you did not realize that all players MUST have alsa selected (and not auto, or oss, nor esound, etc …) in order to mix. If so, it means your earlier assessment may not have been precise, and forcing amarok has added significant fog to the equation.

I have not forced the install of an app for years, and I have mostly bad memories of an inability to properly recover afterward (when I did force). Thats a verbose way of my saying I do not think I can help you now. Good luck, and lets hope someone else chimes in.

You have to precisely check each individual player’ config/properties, etc … … There is no other way that I know of.

my dear friend i am glad to say i got the solution for your problem… happened the same to me and im proud of myself because i solved it alone :DDDDD
its not the most elegant solution but it worked for me:

delete or rename the following file:


if somebody finds the explanation for the problem please write it here!