audio is gone!!

Hi

My soundcard worked fine till yesteday late night. All of sudden I was unable to play an audio anymore. When I up th volume, I hear a faint hiss and some crackle nothing else. Mute is Off.
Tried changing from pulseaudio to alsa no luck.

What could be wrong? This is opensuse 11
2.6.25.16-0.1-default #1 SMP 2008-08-21 00:34:25 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat alsa-dmesg.log
ALSA sound/pci/hda/hda_codec.c:3021: autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0)
ALSA sound/pci/hda/hda_codec.c:3025: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3029: hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3030: mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3038: inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x0, aux=0x0

cat lsmod-snd.log
snd_pcm_oss 68992 0
snd_mixer_oss 35584 1 snd_pcm_oss
snd_seq 83600 0
snd_seq_device 26516 1 snd_seq
snd_hda_intel 497580 5
snd_pcm 115208 3 snd_pcm_oss,snd_hda_intel
snd_timer 45072 2 snd_seq,snd_pcm
snd_page_alloc 28688 2 snd_hda_intel,snd_pcm
snd_hwdep 28424 1 snd_hda_intel
snd 96248 17 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore 26000 1 snd

cat proc-asound-cards.log
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfe024000 irq 16
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xfdffc000 irq 19

lspci:
01:05.1 Audio device [0403]: ATI Technologies Inc RS780 Azalia controller [1002:960f]
Subsystem: ATI Technologies Inc RS780 Azalia controller [1002:960f]
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 4 bytes
Interrupt: pin B routed to IRQ 19
Region 0: Memory at fdffc000 (32-bit, non-prefetchable) [size=16]
Capabilities: [50] Power Management version 3
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Address: 0000000000000000 Data: 0000
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

Should I open a bug report?

Totally frustratd >:([/size]

Please try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

If you can not get your sound working with that troubleshooting guide, please provide us some different information than what you provided already. So please, to provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Once I have that information, I believe I may be able to provide helpful recommendation(s).

Thank you for the guidance.

I will go thrugh the troubleshooting guide in a while…

However there is a basic problems with part of your request. You want end-users to download a script from some unknown site on the Internet and run it as root!! How do I know its not a malicious script? This is not in line with recommended security best practices and as a moderator you should not even be advising it - even though you may have an official standing in the forum - All the more because you are a moderator!

Perhaps OpenSuse should provide MD5 or SHA-1 signed debug script through package manager to help debug common problems.

My problem went away when I uninstalled pulseaudio and came back when I reinstalled it. Problem with plain Alsa is that Amarokapp tends to spit out a “could not initialze audio …” sometimes when I relaunch. Just FYI on the side, Ubuntu 8.0.4 did not have this problem, so it seems to me a Suse specific issue.

I will run the script when I find time to read it first.

No malice intended, but please find an alternative path to getting end-users run unsigned scripts for debugging purposes.

TIA
Regards

Thats a valid question, but in truth, its from a user who does not understand how and why things are done, the way they are done, with opensource Linux. Do you honestly believe a moderator with 5000+ posts, whose picture is pasted on the Internet, with contacts such that he can be charged with a criminal offense for malicious behaviour or with simple negligence, is not going to first check a script thoroughly BEFORE recommending it? If you do believe that, then I can not help you.

Some info:
User : Oldcpu - openSUSE

A simple google search would find a link to this opensuse team forum - Google Search

Some basic openSUSE Linux concepts:
Concepts - openSUSE

This is not correct.

Not only is the script I recommend valid, but future versions of alsa and openSUSE, commencing with alsa-1.0.17, will include a similar such script with the alsa driver.

I really do think you should spend more time learning about Linux and openSUSE, and learn why some of us allow our information to be made public. Why we do not hide behind pseudo names and why we spend countless hours as volunteers to help users.

openSUSE does have checks for rpms that are installed on repos.

But there are common sense limits to security. When a moderator gives a recommendation (such as running a script) then if they are wrong, there can be consequence back on the moderator. I recommend you ponder that a bit.

I myself would not run binary code from a user who had no posts to their credit, whose pseudo name could not be reliably tracked down to the real user, and whose code was binary and hence not decipherable. BUT if is a script that can be EASILY checked, where the user writing the script, and the user recommending the script, can be easily tracked down and charged with criminal negligence, then it is a completely different matter.

Like I mentioned above, spend some time learning why things are done they way they are done in openSUSE and indeed in Linux. Then judiciously apply solid considerations to concerns you may have.

Pulse audio is buggy. It is relatively new.

Glad to read Ubuntu worked for you. I watch IRC channel freenode #alsa a lot, and many Ubuntu users have a number of pulse audio problems. I dare say (in my experience) more than openSUSE users. I am glad to see that you are not one of the Ubuntu users with the problem. But I caution readers of this thread, that Linux is Linux, and each Linux has its problems. In most similar cases, IMHO it is pulse audio, and not the distribution.

Now that is sensible. If you wish, you can go to IRC freenode #alsa and chat with the user gnubian who wrote that specific script.

There is not a chance that I would follow this recommendation of yours in this specific case. I know the script source. I know the author. I know the script. I will not follow your well intended, but inappropriate advice.

I have helped over a hundred users by using that (and another script). Your advice, if followed, would lead to those users having no sound.

I understand your statement about no malice, but IMHO you need to learn why things are done the way they are done in Linux, especially wrt security, and you need to learn why many of us who support Linux, put ourselves in a position of some public responsibility, … a concept I think that is totally foreign to many MS-Windows and Mac users.

Enjoy your time in Linux.