Audio in some things, not others.

Greetings, all!

I have recently installed 11.3 onto a computer I just dropped a new mobo/cpu/memory into. At first everything worked great! (minus a few video streaming issues…but that is for a later date) Then, a few days ago, I let it do an update. Boy to I feel stupid now. I guess if it ain’t broke… So, now I don’t have sound in the browsers or for the video players…such as xine or games. I do however still have sound with Amarok and system sounds when it boots up.

I have deleted the sound device in Yast and let it re-install several times. I tried different setting there as well. Checked and rechecked then checked again the mixer settings. Made sure my group settings included audio…just in case. Now Amarok and the online video play at warp speed, and only Amarok gives me sound…garbled…but sound. The system keeps telling me when I reboot that “one or more sound devices were removed” and wants to know if I want it to ignore them from now on. I’ve answered yes and no several times.I’ve also tried updated the alsa drivers in the software management of Yast. Can someone please help me before my wife gets mad at me for converting this computer to Linux?

Here is some information that may help.

morbid@linux-jinr:~> lspci
Absolute path to ‘lspci’ is ‘/sbin/lspci’, so running it may require superuser privileges (eg. root).
morbid@linux-jinr:~> su
Password:
linux-jinr:/home/morbid # lspci
00:00.0 Host bridge: ATI Technologies Inc RX780/RX790 Chipset Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
00:09.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port E)
00:0a.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port F)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode] (rev 40)
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 41)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller (rev 40)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:15.0 PCI bridge: ATI Technologies Inc Device 43a0
00:16.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:16.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
02:08.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0)
03:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)
04:00.0 SATA controller: JMicron Technology Corp. JMB361 AHCI/IDE (rev 02)
04:00.1 IDE interface: JMicron Technology Corp. JMB361 AHCI/IDE (rev 02)
05:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600 GT] (rev a1)
linux-jinr:/home/morbid # lsmod | grep snd
snd_pcm_oss 53669 0
snd_mixer_oss 19415 1 snd_pcm_oss
snd_seq 68137 0
snd_seq_device 7834 1 snd_seq
snd_hda_codec_via 66727 1
snd_hda_intel 28461 0
snd_hda_codec 113025 2 snd_hda_codec_via,snd_hda_intel
snd_hwdep 7954 1 snd_hda_codec
snd_pcm 105589 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 26828 2 snd_seq,snd_pcm
snd 84348 10 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_via,snd_hda_intel,snd_hda_codec,snd_h wdep,snd_pcm,snd_timer
soundcore 9003 1 snd
snd_page_alloc 9569 2 snd_hda_intel,snd_pcm
linux-jinr:/home/morbid # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: VT1818S Analog [VT1818S Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
card 0: SB [HDA ATI SB], device 1: VT1818S Digital [VT1818S Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

UPDATE:* The “Warp Speed” for the video and audio was resolved after removing and then re-installing the audio driver and a quick reboot. But for some reason I had to reboot yet again to get the internet connection working again. This has happened to me a couple of times now. HELP!!!

Please check out our multimedia stickie: Welcome to multimedia sub-area

I give up! I’ve been screwing around off an on with Suse since Suse 9 Pro. If it is not one thing then it is another. Everything was working just fine until the update. I’m just going to try Ubuntu or give one of the other distro’s a whirl. Being sent off to read yet another list of things to do which don’t particularly apply, wasn’t exactly what I had in mind. I work hard, sometimes seven days a week for our business. I don’t have time to dick around with this anymore. I’d have my techies solve it for me, but they are all trained and certified in Microsoft. I had a dream to someday drop Microsoft from both the offices and our home. I’ve waited almost ten years now and although prettier, I can’t say that Novell has gained one bit of ground in giving me a hassle free operation. Actually, I think it has lost ground. The enthusiasm that once electrified the forums is dieing. The only positive result I can see is that you have influenced MS to do a better job with their OS’s. Were I a Microsoft fan I would say, “thank you”, but I am not. I am just saddened. Thank you for replying at least.

Sorry to read you are having such difficulty.

I’m leaving in a few hours for a 3 week vacation, with little to no Internet access, and last night I was very busy with my wife in preparations for our trip. I head out for our flight later today.

If you had skimmed thru that guide you would have noted the information you provided, which was good of you to provide, is totally inappropriate and unfortunately not helpful. The information requested in that stickie IS what is needed. I’ll quote for you:

If that that does not help you get your basic sound working, please post in this “multimedia” sub-forum, providing in your post the following information:

/usr/sbin/alsa-info.sh 

and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
.
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/alsa-info.sh --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.
.

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

In addition, many users make basic problems setting up their audio, and accordingly this is also in that stickie had you read it:

There is also guidance for new users here, in setting up their multimedia: Multi-media and Restricted Format Installation Guide

I understand your view that you do not have time, as I am also short of time in last minute preparations for my flight 1/2 way around the world to another continent. As you know I don’t get paid for this openSUSE volunteer service but it will cost me thousands of dollars if I miss my flight.

As for other distributions, I happen to like Fedora and I do recommend that as a good distribution alternative to openSUSE.

Good luck.

As @oldcpu is going away.
Let me offer to assist if you decide to work on it.

Ubuntu’s pretty good, worth a shot, and I also like Mint and Debian. Good luck if that’s the way you decide to go.

Thanks, all. Sorry, I get a bit frustrated at times. It was a bit embarrassing to talk my wife into a movie night after a very hard day at work, only to discover the sound died in everything but the system boot and Amarok. I just wanted to show her that Linux could replace Win7 for our entertainment system. I was so excited after I configured everything and had it working (almost) perfectly…until I made the mistake of letting it update while we prepared a light dinner first. (Sigh) Now the only thing that gives me sound is when it boots up and Amarok. I just don’t understand what would do that.

Oldcpu…I can’t say I envy your journey. The last trip we made was a couple weeks in Germany. The day after we got back after the hours upon hours of being cooped up in an aluminum can of recycled air, I was knocked down with 103+ fever. Since then we’ve not had the time to travel and even though we have booked several flights to different locations, we’ve had to cancel either because of work, or just not feeling like putting up with the BS of traveling anywhere.

I did see that the information I provided was not what you seemed to need. I was systematically going down the line following the instructions, but was constantly interrupted by one thing or another. Then when it downloaded some sort of list that for some reason it gave me an error when I tried to view it…I became a bit irritated. I, as well as everyone else, appreciate your volunteering to help us with our issues. Thus my thanking you for at least responding, to which I had received none at all from my normal sources. Have a safe trip.

Caf4926 and Swerdna, I thank you for your kind offer to assist me. I surly need it. I will go though the steps Oldcpu suggested and try to post it by this afternoon. I truly do not wish to try another distro, although I admit I did download Ubuntu and burn the iso to a disk. However, for some reason it could not read the disk. I tried three different ones and it was still a no-go. Perhaps it is a sign. :wink: Thanks again.

One of the first things I could think of when reading what you describe is the level of the PCM channel. Check that in your mixer. If you cannot find it, open a terminal window and run ‘alsamixer’ to see the level of the PCM.

Well, I didn’t get around to going though the steps. The reason is that the plasma something or another crashed, then KDE crashed, then it wouldn’t let me back in after I had to push reset on the computer. Each time I log in, it says that my audio devices were removed and wants to know if I want to have it ignore it from now on…or something like that. This happens on the two computers I have 11.3 on. The other computer…to which the audio works just fine…but its streaming from the network drive leaves a lot to be desired, also gave me the same issue with the crashing…without me doing anything to it.

As far as checking to make sure the PCM channel isn’t muted or is up. Let’s just say I’ve run though the levels of the mixer so many times with my mouse that Kmixer has filed charges of sexual harassment against me. :wink:

So, although I would love to conquer this problem and not let it beat me, but I think I will first give Ubuntu, and then Mandrake or something a whirl first. I need dummy-proof right now, not yet another challenge to overcome…although I love a good challenge…it is not wise to try to take on the “world” all at once. Again, thank you for your help, but I am declaring OpenSuse 11.3 the winner of this first round…for now.

I don’t suppose any of you happen to know how to get it to recognized my dvd of Ubuntu. I have read that some people are having to use a floppy to get it to work, but I don’t have a floppy. I know from past experience that it has no issue in running if I first ran the .exe in Windows…weird. Maybe I’ll just have to go to stage 2 and buy a copy of Mandrake or something… We will see. TC all.

Sorry. You want to install Ubuntu but your machine doesn’t recognise the CD?/DVD? when you boot it.

Yes, but I solved the problem. I only had a dual layer dvd available and the old machine I was using didn’t recognize it. I fixed it now and am running Ubuntu 10.10. I have to admit, I like it a lot. Everything works as it should. There are a few issues here and there, but considering this is an alpha version, I’m rather excited about it. I miss a few things about Suse, but what is most important to me is that it works and works reliably. Suse has the goddies, but It now needs to work on stability. I’ve had almost every release since 9 pro. Stability and reliability was always an issue for me. Thanks again for your help.

I too am trying to correct various sound problems. I wish there was a manual on properly configuring sound, which includes general settings and then for specific sound cards.

Anyway I had those pop-up notices you mentioned:

“…The system keeps telling me when I reboot that “one or more sound devices were removed” and wants to know if I want it to ignore them from now on.”

And after awhile I realized that I accepted some update which introduced a new repository. The repository was mentioned in those pop-up notices.

So I just went into YaST in the repository list and deleted it. That eliminated the pop-up notices for me.

Ah…that makes sense. Thanks. I’ll remember that.