Audio glitches with PulseAudio after recent fresh reinstall, old fixes not working

I recently had to do a fresh reinstall of openSUSE Tumbleweed. Reinstall was done using the 10/22/2019 snapshot ISO. I’ve been experiencing audio glitches (e.g. skipping/stuttering) in pretty much all programs that output audio. This is using PulseAudio.

Now, I started having this problem a year ago when I tried using Arch, and I fixed it by following the steps in the Arch Wiki. I think when I switched to Tumbleweed back in January, I applied this fix soon afterward. With that fix (adding tsched=0 to the line with load-module module-udev-detect within /etc/pulse/, I didn’t have any audio problems. However, ever since I reinstalled Tumbleweed the other day, I’m having the same audio glitches regardless of whether or not the fix is added. I don’t know if anyone else is having this problem, but I’m just frustrated that fixes that used to work aren’t doing anything anymore.

Does anyone have any idea on how to fix it? Or do I have to wait for an update?

Something that might be worth a shot - try setting the following in /etc/pulse/daemon.conf

realtime-scheduling = no

I found this recommendation here

A different suggestion as per this Debian wiki page…

high-priority = no
nice-level = -1
realtime-scheduling = yes
realtime-priority = 5
flat-volumes = no
resample-method = speex-float-1
default-sample-rate = 48000

Turning off realtime-scheduling seems to have worked. Thanks a lot! Here’s hoping it keeps working.

Thanks for the feedback. Keep us posted! :slight_smile: