Audio drivers working on LIVE OS versions, but NOT working after installation

This issue is becoming me mad. I have no audio, cause openSUSE doesn’t like for some reason my audio device.
But the curious thing is that if I boot with a live version of openSUSE (15.3 or Tumbleweed) audio works like a charm. Two audio devices recognized. But after installed from any of both mentioned live versions, no audio devices at all. It is a madness.

This is my hardware: https://linux-hardware.org/?probe=187edb6508

using

sudo -E ./hw-probe-1.5-149-x86_64.AppImage -all -upload

Any idea what’s happening?

Thank you

Have you gone into Yast-sound and see what is setup as device 0? test sound from there?? change defults. show lspci tell us what sound devices you think you have.

I think the non-oss repository is enabled by default on Live OS disks. Perhaps the driver you need is proprietary, and you disabled the Non-OSS repository when you installed? Check and see if the Non-OSS repository is enabled on your machine. If not, enable it and run a system upgrade. I’m fairly sure Zypper will automatically select the proper driver for your device and install it from Non-OSS (don’t quote me on that, you may need to search for it yourself). Of course, a FOSS driver is preferable, but for the sake of convinience you may want to use a proprietary driver for your audio.

Additionally, ensure ALSA and PulseAudio are configured correctly.

There could be many reasons. If you have not solved this, by the time you read my post, perhaps you could run a diagnostic script that provides LOTS of information, that will possibly point us to the solution.

If will to do so, then please as a regular user, open a konsole/xterm, with PC connected to the internet, and paste in this command (it runs a sound driver script):


/usr/sbin/alsa-info.sh

Select the “UPLOAD/SHARE” when prompted. Let the script run to completion. It runs various sound diagnostic commands, and puts it in one text file, and uploads that to an alsa sound driver site for sharing diagnostics. When the script completes, look in the konsole/xtrerm, and you will see the address where the text file was uploaded.

Please paste that address here. We will then go there, look at the info, and see if it points us to the problem.

Given this works on the live USBs, this is most likely a basic issue, such as pulse audio not configured correctly for your speakers (which can be done by installing ‘pavucontrol’ ). Note that pulse audio allows one to direct the play of multi-media from an app to different sound devices (often people have their audio playing on a non-existant device when they have issues, which can be corrected in ‘pavucontrol’ ) …

Also, for sound in some media files, in openSUSE one should install the appropriate files (replacing basic openSUSE files) for appropriate media playback. But at the moment - without further information - we need to resort to speculation in our recommendations.

Further to the above, based on what you posted, I think you may have Canon_Lake hardware ? If so, its possibly you may need to install sof-firmware (that is MY speculation). You can find that packaged in the experimental repos under:

https://software.opensuse.org/package/sof-firmware

Possibly something like this will help you install that:


sudo zypper ar https://download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_15.3/ multimedia
sudo zypper update
sudo zypper in sof-firmware
sudo zypper rr multimedia

Then reboot and test. However without my seeing the diagnostic script info, this is highly speculative on my part. It puzzles me that sof-firmware would be on the live USB devices … It has me curious and I may check that just for my own gratification.

Further to the above, its possible the v.1.8 sof-firmware that is in the experimental is not needed, and you get sound with the v.1.6.1-2.9 that is in the official openSUSE LEAP-15.3 repositories. In which case these commands could simply work (assuming/speculating this is an sof-firmware issue):


sudo zypper in sof-firmware

Then reboot and test.

First of all, I would like to apologize for not replying sooner. I was hoping that by starting this thread in the forum, I would automatically receive the reply messages, and that is not the case. I don’t know how to subscribe to the replies.

Secondly, thank you so much for ALL the replies. I thought the information I had provided was enough, but thanks to the command that user “oldcpu” suggested, I think I can provide more accurate information about it at “http://alsa-project.org/db/?f=6a7f0bc135df72433539c339008d89dd0601d559”.

On “what is setup as device 0”, after installation, only one line appears: “Not configured: Cannon Lake PCH cAVS”. However, in the “Live” version, an additional line is shown: “Not configured: TU106 High Definition Audio Controller”, and both audio devices work (in the “Live” version).

Regarding the OSS repository, it is enabled and operational. Remember that even installing from the “Live” version (where everything works) is after installing (from the “Live” or normal version) there is no audio.

Installing “pavucontrol” does not solve the problem. When launching “pavucontrol”, a window appears that only shows “Establishing connection to Pulseaudio. Wait …” forever.

About “sof-firmware”, as I already had the “Multimedia” repository enabled, I only needed to install that software. Unfortunately, after reboot, everything is still the same.

Seems it’s going the right way … I HAVE SOUND!!!

After reading the report that “oldcpu” teach me to get from ALSA, I noticed two things:

  • Pipewire is yet installed and active in Tumbleweed!!!
  • Pulseaudio was NOT working

So, after reading here and there in Internet, a tried:

rm -r ~/.config/pulse /tmp/pulse-*
pulseaudio --kill
pulseaudio --start

and restarted my PC. Even despite “Yast Sound” window continues showing EXACTLY some information than when sound was not working ("“Not configured: Cannon Lake PCH cAVS”) and is not showing the line “Not configured: TU106 High Definition Audio Controller”, despite I really don’t know what device it is. Even if I plug my PC thru USB-C cable to my HP monitor, sounds works too thru monitor speakers.

Precisely, I installed Tumbleweed instead of LEAP 15.3 thinking that the LEAP version did not recognize my audio because I had an older kernel or drivers, but I have the impression that it was not the cause, but a mismanagement of the openSUSE installation manager, since I believe that the LIVE version should work exactly the same before and after installing it.

Now, time to fight with Nvidia controllers … a new headache …

THANK YOU ALL

I’m glad to read it is working. The implementation of pipewire and integration with pulse audio confuses me.

I also thought your PC mixer configuration strange, but you have audio, so my observation is mute. This is what I noted:


Simple mixer control 'Speaker LO',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 0 **[0%]** -74.00dB] **[off]**
  Front Right: Playback 0 **[0%]** -74.00dB] **[off]** 

Speakers muted tends to prevent audio from playing.

But as noted - I am glad to read its working now.