Audio devices not detected on boot

I’m experiencing a major issue with my audio, after upgrading my motherboard and cleaning up some invalid sound cards left in the config by the old board: My audio devices are no longer detected on startup. Upon logging in, I have no playback or recording devices. I always need to open YaST2 - Hardware - Sound then delete and reconfigure the devices: This works without issue and immediately restores functionality to my cards, however it only lasts until I reboot again. How do I solve this so audio cards are detected on boot again?

I rebooted and used “systemctl --user restart pulseaudio.service” to restart pulseaudio right after logging in: It restarted, but the devices still do not come back.

A systemctl status check mentions that PA has loaded, but for some reason it seems to say that it’s disabled. I can see a user process for pulseaudio in KSysGuard.

mircea@linux-qz0r:~> systemctl status -l --user pulseaudio.service pulseaudio.socket
● pulseaudio.service - Sound Service
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: disabled)
   Active: active (running) since Mon 2019-10-28 19:30:08 EET; 5min ago
 Main PID: 3071 (pulseaudio)
   CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.service
           ├─3071 /usr/bin/pulseaudio --daemonize=no
           └─3073 /usr/lib/pulse/gsettings-helper

● pulseaudio.socket - Sound System
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-10-28 19:29:19 EET; 6min ago
   Listen: /run/user/1000/pulse/native (Stream)
   CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.socket

aplay doesn’t seem to list my integrated sound card either, just my USB webcam.

mircea@linux-qz0r:~> aplay -L
    Discard all samples (playback) or generate zero samples (capture)
    PulseAudio Sound Server
    Default ALSA Output (currently PulseAudio Sound Server)
    Microsoft® LifeCam HD-5000
    USB Stream Output
mircea@linux-qz0r:~> cat /proc/asound/cards
 2 [HD5000         ]: USB-Audio - Microsoft® LifeCam HD-5000
                      Microsoft Microsoft® LifeCam HD-5000 at usb-0000:01:00.0-3, high speed
mircea@linux-qz0r:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-hda-intel
# l2so.zTGtWUAW7TD:Starship/Matisse HD Audio Controller
alias snd-card-0 snd-hda-intel
# oM_+.9YsSUFHuWk9:Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]
alias snd-card-1 snd-hda-intel

/proc/asound/cards is missing the devices too. I understand this is a pre PulseAudio issue, which is very confusing to hear.

“cat /etc/modules-load.d/yast.conf” only gives me snd-hda-intel and nothing else. Shouldn’t there be more things in there too?

mkinitrd may clear that up

Already did that, no change. It might be related to the modules I mentioned in the last post. I never worked with those files though and am not sure how to repair them.

For a more complete picture, run the diagnostic script and post the link (to the uploaded output) that it provides here.

The problem has just been resolved. The solution was shockingly simple: All I had to do was delete the file /etc/modules-load.d/yast.cfg which contained just the line snd-hda-intel. Apparently this file was causing sound modules not to load properly on startup. Upon rebooting again, sound immediately worked once I logged in. Perhaps there’s a bug in the YaST2 - Sound program that caused it to be placed there when I generated new configs?