Audio CD is playing but NO SOUND ..Please help

This is the third install of Suse 11 on the same HDD. My God is it hard to get this mut working.

I have an audio CD in the drive playing away in KsCD. I can see it ticking away… but no sound.

Also …No sound on boot up.
All previous installs have played sound OK on bootup.

Sound hardware is good. (tested on adjacent machine)

Any help lovingly nurtured…!


If you go into YaST > Hardware > Sound. Is the sound card model of your machine listed? While you are there click the “Other” button and choose “Volume”. Check the settings and click “Test”. Hear anything?

For basic sound functionality, try working your way through the openSUSE audio troubleshooting guide.
SDB:AudioTroubleshooting - openSUSE

… assuming that you have your basic sound working, on some PCs getting an audio CD to play can be a bit tricky. Some hardware has an analog connection between the sound card and the cd/dvd drive. Others do not. Sometimes one has to go into their media player and select (or deselect) “direct digital playback” (or a similarly named option) to get audio to work.

Thanks: Yep gone in there and, on clicking ‘other > volume’ returns the followingxmessage:-

YaST got signal 11 at YCP file Wizard.ycp:740
/sbin/yast2: line 421: 23599 Segmentation fault
$ybindir/y2base $module “$” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

‘Play Test Sound’ returns:- nothing…!

Sound Config Window reads:-

Index 0 Card Model A7V8X-X Motherboard
Configured as sound card number 0 Driver snd-via82xx

Thanks. Yep - been through the sound troubleshooter as far as I can get :-

I get alsa-firmware Not Installed.
I go into root.
zypper install alsa-firmware.
Loading begins. Select ‘YES’
Message ends with:-

’ Failed to mount cd:////devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found)

Abort, retry, ignore? [A/r/i]:

retry = the same result. ignore = quits to root prompt.

So I went further to test speaker in terminal and typed:-

speaker-test -Dplug:front -c2 -l5 -twav

This returns:-

The spkr test shows things like 48000Hz S16_LE, 2 channels WAV files
Buffer sizes
ending in Time per period = 3.071156

Sorry, I can’t configure the K email client to send the log to my working computer. Issues.
I can’t put it on a USB stick to transfer to this machine because Suse does not mount any of the HDD or USB - another problem. (Both are visible in 'Computer> System Information> Disk Information … but can’t get to them, and I can’t find out how to mount - anything. Might this be a clue???)

So I reckon I’m a little bit on the stuck side at the moment.

Thanks for any help at all


That is telling you to insert your installation CD/DVD !! :slight_smile:

I suspect you can mount this manually.

If you plug in your USB stick, and type “lsusb” you should see your memory stick listed. While the memory stick is connected, if you type: su -c ‘fdisk -l’ you will see the memory stick listed. Its likely sdb1 or sdc1 and it is likely labelled as system “W95 FAT32”

Lets say it is sdc1 … then simpy open a gnome-terminal and type:
mkdir /home/youruser-name/usbstick
su *(enter root password when prompted) *
mount -t vfat -o rw,users,uid=youruser-name /dev/sdc1 /home/youruser-name/usbstick
and it will have been mounted under /home/youruser-name/usbstick. Note you need to apply some common sense when doing this. Substitute your user name for “youruser-name” and substitute your usbstick device name for /dev/sdc1 (ie it may be /dev/sdb1 or /dev/sdd1 … ).

You should be hearing a ladies voice saying “front left” , “front right” five times.

If you don’t hear that, and if you are still struggling with the troubleshooting guide, then provide me some more information on your hardware/software and I’ll walk you through manually. … To provide more information, then with your PC connected to the internet, please copy and paste the following into a gnome-terminal or konsole:

wget && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following, one line at a time, into a gnome-terminal or konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I think the solution is,
under kscd open extras
Configure kscd
enable use direct digital playback

This problem has been there since 9.1 version if this is just kscd specific
If memory serves I think it is due to cd/dvd that are not wired to the system correct me if I am wrong

Hi Oldcpu.
Thanks for your reply.

Re:- You should be hearing a ladies voice saying “front left” , “front right” five times.
Well I’ve been at this so long I think I’m hearing voices … but not this lady on my sound system…!

OK Done the infofiles/tsalsa and filled in the answers. OK Got to the end and a message says “paste this URL in #alsa:” I don’t know what it means when it says "paste this in #alsa… do I paste this into an alsa directory? can’t find one.

URL again tsalsa.txt - (beta)


user@linux-36zo:~> rpm -qa | grep alsa

user@linux-36zo:~> rpm -qa | grep pulse

user@linux-36zo:~> rpm -q libasound2

user@linux-36zo:~> uname -a
Linux linux-36zo.user #1 SMP 2008-10-21 16:30:26 +0200 i686 athlon i386 GNU/Linux
user@linux-36zo:~> cat /etc/modprobe.d/sound

options snd slots=snd-via82xx

Ssy1.LaYIBNkDBTE:A7V8X-X Motherboard

alias snd-card-0 snd-via82xx

Originally Posted by susewales
’ Failed to mount cd:////devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found)

Yes I understand what it is sying but my installation DVD is not recognised in response to the request to insert in the drive.


alsa-firmware is NOT installed and I have failed to install it [as per pervious post].

Many thanks for your help.


Thanks also for your reply.

I can’t figure out what KSCD is beyond a few old Forum posts which don’t explain what it is.
Can’t find anyting in my SUSE which is KSCD.

User gnubian in IRC chat channel freenode #alsa wrote that script to obtain information from users who were asking for help on IRC #alsa. Hence there is the instruction to paste the URL in IRC#alsa. I concede it is a bit confusing, but I did specifically state in my post that I wanted you to post the URL here, which should have eliminated the confusion.

OK, I note an AD1980 on openSUSE-11 with a kernel. You have 1.0.16 of alsa, and I also note there are updates on alsa for the AD1980: Search results for AD1980 - AlsaProject

But I recommend, before we consider updating alsa, that you FIRST install alsa-firmware (you may need to download that from the openSUSE-11.0 OSS repository on the web - I assume you know how to find that URL? Or should I dig that up for you as well ? No worries either way ).

And second, before we consider updating alsa, take a look at your mixer settings. The script tells me this:Amixer contents for card 0 [V8235] _____________________________________
amixer set ‘Master’,0 68% off 68% off
amixer set ‘Master Mono’,0 68% on
amixer set ‘Master Surround’,0 0% off 0% off
amixer set ‘Headphone Jack Sense’,0 off
amixer set ‘PCM’,0 68%,68% on
amixer set ‘Surround’,0 68% off 68% **off **
amixer set ‘Surround Jack Mode’,0 Items: ‘Shared’ ‘Independent’ Item0: ‘Shared’ It seems to me that having your master volume switched OFF may not be a good thing.

How about switching that ON and testing ?