audio and video WAY out of sync -- SuSE 11.0

Hello, everyone. I searched these forums for posts on audio and video sync problems but did not find anything close to my odd problem.

Two computers. Desktop (Dell Inspiron 530) was running various flavors of Ubuntu. Now running SuSE 11.0 for about 3 weeks.

Laptop (LinuxCertified model LC2210D) was running SuSE 10.0 – upgraded to 11.0 today.

On both pooters I followed the “Multi-Media and Restricted Format Installation Guide” posted to this forum by caf4926. I also completed the “Check your multimedia problems in ten steps” guide posted by RedDwarf. Everything done exactly as specified therein except that I have libavcodec52 instead of libavcodec51 as designated in the caf4926’s guide.

Audio and video are not in sync now whereas the desktop was fine with Ubuntu and the lappy was fine with SuSE 10.3. Here’s what’s happening.

On both machines the audio is from 1 to 2 1/2 seconds behind the video when playing through Kaffeine, depending on the clip. Same when played with MPlayer or KMplayer.

So for example, I have a clip of a goal scored in a soccer game. I know this clip played perfectly on both pooters before the updates to 11.0. The ball goes into the goal and the announcers immediately start to shout. However, now when I play the clip on either pooter the ball goes into goal and it’s fully 2 1/2 seconds after that the voices start! :confused:

On other clips where the speaker is looking directly at the camera the audio and video are clearly out of sync by at least 1 second. This seems to affect all video formats as best I can tell.

But here’s where it really gets strange. The audio and video do seem to be in sync when using SMplayer.

If possible I’d really prefer to use Kaffeine on my desktop (just seems most user-friendly of all the players) and KMplayer on the lappy (for logistical reasons having to do with showing videos during lectures and, also, configuring the lappy to output signal to a projector).

But I can’t use either Kaffeine or KMplayer now with this very obvious syncronization problem.

Any ideas on how to fix this problem for any or all video players? Do I need to provide additional information about either pooter?

Thanks.
socref

libavcodec52
This is fine.

I would double check you have done update all in Packman with no VLC repo remember.
Try a different video output eg:
change the “output video module” from “auto” (or from “xv” (xvideo)) to “x11” to see if that helps.

I always use xine audio in my setup too.

Yes, did that. I do have vlc downloaded from Packman since that is one of the items recommended in your guide. But the only thing I have from Videolan is libdvdcss.

Where is the “output video module?” Can’t find anything in Kaffeine designated that way. Can you point me there?

The closest I see is Settings > xine engine parameters > video > beginner options > driver video driver to use > (then drop down and select) > xshm. If that is what you mean, it makes no difference.

Where do I set that in Kaffeine?

Please note that KMplayer seems to work better when set with Preferences > Source > Use movie player: Mplayer rather than with Use movie player: Xine.

Using Xine the audio/video is way out of sync. Using MPlayer it seems better.

But I still need to get audio and video in sync with Kaffeine.
Thx
socref

In kaffeine I don’t think this setting is possible. But is in most other players like mplayer or vlc.

Setting up multi-media is really not difficult. Over the past week I have done this with my own guide at least 6 times.

I think you must be confused because I am not aware of libdvdcss in the Packman repo. That’s why we say enable VLC repo just for that package, then disable it.

Of course - every situation is different and it is possible you will find some dvd’s that just will not play. But to be honest there is nearly always a solution of sorts (ripping the dvd for eg, can sometimes be done even when it will not play).

I would check carefully your audio setup and how it performs in other areas too.

caf, it seems as if you have misread several parts of my posts.

  1. I said that I had libdvdcss and only libdvdcss from Videolan. I did not say it came from Packman.

  2. Nowhere in my posts did I mention tying to play DVDs. I refer in several places to audio and video being out of sync when playing video clips.

  3. The audio plays fine when viewing video clips. It’s just out of sync with the video. In other uses the audio plays fine – for example in xmms

  4. DVDs do play in perfect audio/video sync on both computers using Kaffeine or VLC. However, neither computer plays DVDs using KMplayer or Mplayer (no idea why), so I cannot evaluate the audio/video sync with DVDs on those two players.

What can I check, particularly in Kaffeine, to see why audio is out of sync with the video when playing clips?

Do the clarifications I’ve provided help? Something is causing Kaffeine to behave most uncharacteristically.

Thx
socref

Sorry for my mistake, I am dealing with many threads at once and sometimes get their similarities mixed up.

I can only suggest you try deleting the config files here:

.kde/share/apps/ the folder ‘kaffeine’

and

.kde/share/config the file ‘kaffeinerc’

these are viewable in dolphin /home/*username
when you enable ‘view hidden files’

When you start kaffeine again it should be like your first time. It’s worth a try.

Thanks for suggestion. Tried deleting the two items but that made no difference. Still WAY out of sync.

One other thing that may or may not point to a solution…From the time I first posted about this I’ve noticed that the sync problem is transient. Sometimes the audio and video on this video clip I’ve been using as the benchmark are WAY out of sync, and other times the audio and video are in sync. :confused:

Still hoping for a solution.
socref

More information on my problem.

I just discovered that the audio and video are similarly out of sync using Adobe Flash Player 9 (9.0.152.0-0.1) and flash plug-in 10 (10.0.15.3-release-i386) while viewing videos in Firefox.

For example, at this URL:

Graham Taylor - An Impossible Job

see the program between 20:57 and 21:31. On my computer the audio and video are not even close to sync – just awful.

So Kaffeine and Flash Player are way out of sync while KMplayer is in sync.

Any ideas?
Thx
socref

socref wrote on Sunday 25 Jan 2009 17:06:

> So Kaffeine and Flash Player are way out of sync while KMplayer is
> in sync.
>
> Any ideas?
> Thx
> socref
>
>

There is ab option in kaffiene to adjust the audio/video sync under:

Player>video>video Settings

Not sure about flash though/

HTH


Mark…

Nil illegitimi carborundum

That video you linked to as an example is the problem. It’s out of sync on my windows computer. But for the rest down grade your version of xine-lib, I was having problems with the one in the packman repo also. I down graded to libxine1-1.1.15-44.pm.2 and every thing is now in sync again

it can be found in this package.
Multimedia Pack Portable 2009 pre release by Easgs
MMP2009-111-32bit-PR.zip

Interesting. A 70ms offset brings one particularly bad clip back into sync. Thanks.

However, as soon as I close Kaffeine that offset goes away and I have to redo it to show that clip or to get any other clip back into sync. Is there a way to save that offset so that Kaffeine remembers it? I looked but did not see anywhere to save new settings.
Thx
socref

Tom, thanks. I downloaded the package you suggested. But before trying this I have two questions.

  1. My pooter is 64 bit. This rpm is 32 bit. Will using it cause me problems?

  2. If it’s OK to use this rpm should I also get the lib-xine1-codecs rpm?

Thx
socref

MMP2008-110-x64-v1.zip

this is a 64bit for 11.0 it should still work
extract the archive and add it to yast as a repo and install from there.

Thanks. I have the folder in my home directory and I added it as a repository. Now, please advise on each of these items. I don’t want to make a total mess of my audio/video set up. :slight_smile:

  1. Do I first delete the “offending” lib-xine1 in yast’s software management?

  2. Do I also delete lib-xine1-codecs?

  3. Any others that need to be deleted first?

Your reply to these first three questions will tell me which of the “older” lib-xine rpms I need to grab.

  1. When I’m done with the above is there any need for me to keep all of these rpms in a repository? Can I delete it or are there other rpms (not necessarily lib-xine) I might want to grab?

  2. Finally, what is the advantage or reason I’m doing this by creating a new repository? Why not just click on the individual rpms after extracting from the zip file and install with yast? (I don’t know Linux well enough to answer what may be a very simple question.)

Thanks!
socref

  1. no just downgrade

  2. again just downgrade

  3. no need to delete (uninstall) any thing just downgrade the packages

  4. yes delete it if you will not need it any more

  5. it’s to help resolve dependencies (if needed)

that should be it

OK, I replaced libxine-1 and libxine1-codecs with the earlier versions you recommended. Sync is better now with Kaffeine :wink:

Thanks!!

However, even though now closer I must say the audio and video still are not in-sync. It’s still noticeably better with KMplayer.

Appreciate your assistance getting things closer.:shake:
socref